]> git.pld-linux.org Git - packages/opensc.git/commitdiff
up to 0.23.0 (new sonames) auto/th/opensc-0.23.0-1
authorJan Palus <atler@pld-linux.org>
Tue, 29 Nov 2022 16:25:51 +0000 (17:25 +0100)
committerJan Palus <atler@pld-linux.org>
Tue, 29 Nov 2022 16:25:51 +0000 (17:25 +0100)
build.patch [deleted file]
no-Werror.patch [deleted file]
opensc.spec

diff --git a/build.patch b/build.patch
deleted file mode 100644 (file)
index 048c2d8..0000000
+++ /dev/null
@@ -1,137 +0,0 @@
---- /dev/null  2018-05-15 12:27:28.000000000 +0200
-+++ opensc-0.19.0/src/tests/p11test/p11test_common.h   2018-09-25 21:02:30.158771398 +0200
-@@ -0,0 +1,89 @@
-+/*
-+ * p11test_common.h: Test suite shared declarations for PKCS#11 API
-+ *
-+ * Copyright (C) 2016 Martin Strhársky <strharsky.martin@gmail.com>
-+ * Copyright (C) 2016, 2017 Red Hat, Inc.
-+ *
-+ * Author: Jakub Jelen <jjelen@redhat.com>
-+ *
-+ * This library is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU Lesser General Public
-+ * License as published by the Free Software Foundation; either
-+ * version 2.1 of the License, or (at your option) any later version.
-+ *
-+ * This library is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-+ * Lesser General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program.  If not, see <http://www.gnu.org/licenses/>.
-+ */
-+
-+#ifndef P11TEST_COMMON_H
-+#define P11TEST_COMMON_H
-+#include "config.h"
-+#include <stdio.h>
-+#include <stdlib.h>
-+#include <string.h>
-+#include <setjmp.h>
-+#include <cmocka.h>
-+#include "pkcs11/pkcs11.h"
-+#include "libopensc/sc-ossl-compat.h"
-+
-+#define MAX_MECHS 200
-+
-+#ifndef NDEBUG
-+      #define debug_print(fmt, ...) \
-+              { fprintf(stderr, fmt "\n", ##__VA_ARGS__); } while (0)
-+#else
-+      #define debug_print(fmt, ...)
-+#endif
-+
-+#define FLAGS_SIGN            0x01
-+#define FLAGS_SIGN_OPENSSL    0x02
-+#define FLAGS_SIGN_ANY                ( FLAGS_SIGN | FLAGS_SIGN_OPENSSL )
-+#define FLAGS_DECRYPT         0x04
-+#define FLAGS_DECRYPT_OPENSSL 0x08
-+#define FLAGS_DECRYPT_ANY     ( FLAGS_DECRYPT | FLAGS_DECRYPT_OPENSSL )
-+
-+typedef struct {
-+      char *outfile;
-+      FILE *fd;
-+      int in_test;
-+      int first;
-+      int in_data;
-+      int first_data;
-+} log_context_t;
-+
-+typedef struct {
-+      CK_MECHANISM_TYPE mech;
-+      CK_MECHANISM_TYPE hash;
-+      CK_RSA_PKCS_MGF_TYPE mgf;
-+      int salt;
-+      int usage_flags;
-+      int result_flags;
-+} test_mech_t;
-+
-+typedef struct {
-+      CK_FUNCTION_LIST_PTR function_pointer;
-+      CK_SLOT_ID slot_id;
-+      CK_SESSION_HANDLE session_handle;
-+      CK_UTF8CHAR* pin;
-+      size_t pin_length;
-+      char *library_path;
-+      unsigned int interactive;
-+      log_context_t log;
-+
-+      test_mech_t rsa_mechs[MAX_MECHS];
-+      size_t  num_rsa_mechs;
-+      test_mech_t     ec_mechs[MAX_MECHS];
-+      size_t  num_ec_mechs;
-+      test_mech_t     keygen_mechs[MAX_MECHS];
-+      size_t  num_keygen_mechs;
-+} token_info_t;
-+
-+extern token_info_t token;
-+
-+#endif /* P11TEST_COMMON_H */
-+
-From c012f46965b3fe24e31367796e52c2d0b14ca5d9 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 17 Dec 2018 18:44:23 -0800
-Subject: [PATCH] Remove redundant logging
-
-Same information is printed a few line below in same function, the only
-difference is that there it takes care of case when label is NULL pointer
-unlike this line
-
-secondly, every function call to cosm_write_tokeninfo() in this file
-passes label=NULL, and then it tries to print a null pointer
-
-Fixes errors like
-src/libopensc/log.h:48:47: error: '%s' directive argument is null
-[-Werror=format-overflow=]
-
-Upstream-Status: Submitted [https://github.com/OpenSC/OpenSC/pull/1557]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/pkcs15init/pkcs15-oberthur.c | 1 -
- 1 file changed, 1 deletion(-)
-
-Index: git/src/pkcs15init/pkcs15-oberthur.c
-===================================================================
---- git.orig/src/pkcs15init/pkcs15-oberthur.c
-+++ git/src/pkcs15init/pkcs15-oberthur.c
-@@ -70,7 +70,6 @@ cosm_write_tokeninfo (struct sc_pkcs15_c
-       ctx = p15card->card->ctx;
-       SC_FUNC_CALLED(ctx, SC_LOG_DEBUG_VERBOSE);
--      sc_debug(ctx, SC_LOG_DEBUG_NORMAL, "cosm_write_tokeninfo() label '%s'; flags 0x%X", label, flags);
-       if (sc_profile_get_file(profile, COSM_TITLE"-token-info", &file)) {
-               rv = SC_ERROR_INCONSISTENT_PROFILE;
-               SC_TEST_GOTO_ERR(ctx, SC_LOG_DEBUG_NORMAL, rv, "Cannot find "COSM_TITLE"-token-info");
---- opensc-0.19.0/src/tests/p11test/p11test.c~ 2018-09-13 13:52:42.000000000 +0200
-+++ opensc-0.19.0/src/tests/p11test/p11test.c  2021-10-15 22:37:12.303953281 +0200
-@@ -33,6 +33,8 @@
- #define DEFAULT_P11LIB        "../../pkcs11/.libs/opensc-pkcs11.so"
-+token_info_t token;
-+
- void display_usage() {
-       fprintf(stdout,
-               " Usage:\n"
diff --git a/no-Werror.patch b/no-Werror.patch
deleted file mode 100644 (file)
index 68d5db7..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- opensc-0.19.0/configure.ac~        2018-09-13 13:52:42.000000000 +0200
-+++ opensc-0.19.0/configure.ac 2021-10-04 22:28:33.902587661 +0200
-@@ -130,7 +130,6 @@
-       ;;
- esac
--AX_CHECK_COMPILE_FLAG(-Wunknown-warning-option, [have_unknown_warning_option="yes"], [have_unknown_warning_option="no"], [-Werror])
- AM_CONDITIONAL([HAVE_UNKNOWN_WARNING_OPTION], [test "${have_unknown_warning_option}" = "yes"])
- AC_ARG_ENABLE(
-@@ -1042,7 +1042,7 @@
-       CFLAGS="${CFLAGS} -pedantic"
- fi
- if test "${enable_strict}" = "yes"; then
--      CFLAGS="${CFLAGS} -Wall -Wextra -Wno-unused-parameter -Werror"
-+      CFLAGS="${CFLAGS} -Wall -Wextra -Wno-unused-parameter"
- fi
- AC_CONFIG_FILES([
---- opensc-0.19.0/m4/ax_pthread.m4~    2018-09-13 13:52:42.000000000 +0200
-+++ opensc-0.19.0/m4/ax_pthread.m4     2021-10-04 22:29:18.960949785 +0200
-@@ -299,7 +299,7 @@
-              ax_pthread_save_CFLAGS="$CFLAGS"
-              for ax_pthread_try in '' -Qunused-arguments -Wno-unused-command-line-argument unknown; do
-                 AS_IF([test "x$ax_pthread_try" = "xunknown"], [break])
--                CFLAGS="-Werror -Wunknown-warning-option $ax_pthread_try -pthread $ax_pthread_save_CFLAGS"
-+                CFLAGS="-Wunknown-warning-option $ax_pthread_try -pthread $ax_pthread_save_CFLAGS"
-                 ac_link="$ax_pthread_save_ac_link"
-                 AC_LINK_IFELSE([AC_LANG_SOURCE([[int main(void){return 0;}]])],
-                     [ac_link="$ax_pthread_2step_ac_link"
index ecff28d85d9c3ace3819486a0794747399a95577..6123454545ace8d042d8d7cd0e1604946e62d146 100644 (file)
@@ -6,17 +6,15 @@
 Summary:       OpenSC library - for accessing SmartCard devices using PC/SC Lite
 Summary(pl.UTF-8):     Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
 Name:          opensc
-Version:       0.19.0
-Release:       6
+Version:       0.23.0
+Release:       1
 License:       LGPL v2.1+
 Group:         Applications
 #Source0Download: https://github.com/OpenSC/OpenSC/releases
 Source0:       https://github.com/OpenSC/OpenSC/releases/download/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 40734b2343cf83c62c4c403f8a37475e
-Patch0:                build.patch
-Patch1:                no-Werror.patch
+# Source0-md5: 35c599e673ae9205550974e2dcbe0825
 URL:           https://github.com/OpenSC/OpenSC/wiki
-BuildRequires: autoconf >= 2.60
+BuildRequires: autoconf >= 2.68
 BuildRequires: automake >= 1:1.10
 BuildRequires: cmocka-devel
 BuildRequires: docbook-style-xsl
@@ -25,7 +23,7 @@ BuildRequires:        libtool >= 1:1.4.2-9
 BuildRequires: libxslt-progs
 %{?with_openct:BuildRequires:  openct-devel}
 %{?with_openpace:BuildRequires:        openpace-devel >= 0.9}
-BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: openssl-devel >= 1.1.1
 %{!?with_openct:BuildRequires: pcsc-lite-devel >= 1.8.22}
 BuildRequires: pkgconfig >= 1:0.9.0
 BuildRequires: readline-devel
@@ -68,7 +66,7 @@ Group:                Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      libltdl-devel
 %{?with_openct:Requires:       openct-devel}
-Requires:      openssl-devel >= 0.9.7d
+Requires:      openssl-devel >= 1.1.1
 %{!?with_openct:Requires:      pcsc-lite-devel >= 1.8.22}
 Requires:      zlib-devel
 
@@ -104,8 +102,6 @@ Bashowe uzupełnianie parametrów poleceń OpenSC.
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -118,6 +114,7 @@ Bashowe uzupełnianie parametrów poleceń OpenSC.
        %{!?with_openct:--enable-pcsc --disable-openct} \
        %{!?with_openpace:--disable-openpace} \
        --disable-silent-rules \
+       --disable-strict \
        --enable-doc \
        --with-pcsc-provider=%{_libdir}/libpcsclite.so.1
 
@@ -153,6 +150,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/egk-tool
 %attr(755,root,root) %{_bindir}/eidenv
 %attr(755,root,root) %{_bindir}/gids-tool
+%attr(755,root,root) %{_bindir}/goid-tool
 %attr(755,root,root) %{_bindir}/iasecc-tool
 %attr(755,root,root) %{_bindir}/netkey-tool
 %attr(755,root,root) %{_bindir}/npa-tool
@@ -162,6 +160,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/opensc-notify
 %attr(755,root,root) %{_bindir}/opensc-tool
 %attr(755,root,root) %{_bindir}/piv-tool
+%attr(755,root,root) %{_bindir}/pkcs11-register
 %attr(755,root,root) %{_bindir}/pkcs11-tool
 %attr(755,root,root) %{_bindir}/pkcs15-crypt
 %attr(755,root,root) %{_bindir}/pkcs15-init
@@ -169,9 +168,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/sc-hsm-tool
 %attr(755,root,root) %{_bindir}/westcos-tool
 %attr(755,root,root) %{_libdir}/libopensc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopensc.so.6
+%attr(755,root,root) %ghost %{_libdir}/libopensc.so.8
 %attr(755,root,root) %{_libdir}/libsmm-local.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsmm-local.so.6
+%attr(755,root,root) %ghost %{_libdir}/libsmm-local.so.8
 # PKCS11 modules
 %attr(755,root,root) %{_libdir}/onepin-opensc-pkcs11.so
 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
@@ -183,6 +182,7 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opensc.conf
 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
 %if %{with openpace}
+/etc/eac/cvc/DESCHSMCVCA00001
 /etc/eac/cvc/DESRCACC100001
 %endif
 %{_mandir}/man1/cardos-tool.1*
@@ -191,6 +191,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/egk-tool.1*
 %{_mandir}/man1/eidenv.1*
 %{_mandir}/man1/gids-tool.1*
+%{_mandir}/man1/goid-tool.1*
 %{_mandir}/man1/iasecc-tool.1*
 %{_mandir}/man1/netkey-tool.1*
 %{_mandir}/man1/npa-tool.1*
@@ -200,6 +201,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/opensc-notify.1*
 %{_mandir}/man1/opensc-tool.1*
 %{_mandir}/man1/piv-tool.1*
+%{_mandir}/man1/pkcs11-register.1*
 %{_mandir}/man1/pkcs11-tool.1*
 %{_mandir}/man1/pkcs15-crypt.1*
 %{_mandir}/man1/pkcs15-init.1*
@@ -227,6 +229,7 @@ rm -rf $RPM_BUILD_ROOT
 /etc/bash_completion.d/egk-tool
 /etc/bash_completion.d/eidenv
 /etc/bash_completion.d/gids-tool
+/etc/bash_completion.d/goid-tool
 /etc/bash_completion.d/iasecc-tool
 /etc/bash_completion.d/netkey-tool
 /etc/bash_completion.d/npa-tool
@@ -236,6 +239,7 @@ rm -rf $RPM_BUILD_ROOT
 /etc/bash_completion.d/opensc-notify
 /etc/bash_completion.d/opensc-tool
 /etc/bash_completion.d/piv-tool
+/etc/bash_completion.d/pkcs11-register
 /etc/bash_completion.d/pkcs11-tool
 /etc/bash_completion.d/pkcs15-crypt
 /etc/bash_completion.d/pkcs15-init
This page took 0.061329 seconds and 4 git commands to generate.