]> git.pld-linux.org Git - packages/opensc.git/commitdiff
- up to 0.19.0 auto/th/opensc-0.19.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 25 Sep 2018 19:09:50 +0000 (21:09 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 25 Sep 2018 19:09:50 +0000 (21:09 +0200)
build.patch [new file with mode: 0644]
opensc.spec

diff --git a/build.patch b/build.patch
new file mode 100644 (file)
index 0000000..d7fbaf4
--- /dev/null
@@ -0,0 +1,92 @@
+--- /dev/null  2018-05-15 12:27:28.000000000 +0200
++++ opensc-0.19.0/src/tests/p11test/p11test_common.h   2018-09-25 21:02:30.158771398 +0200
+@@ -0,0 +1,89 @@
++/*
++ * p11test_common.h: Test suite shared declarations for PKCS#11 API
++ *
++ * Copyright (C) 2016 Martin Strhársky <strharsky.martin@gmail.com>
++ * Copyright (C) 2016, 2017 Red Hat, Inc.
++ *
++ * Author: Jakub Jelen <jjelen@redhat.com>
++ *
++ * This library is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU Lesser General Public
++ * License as published by the Free Software Foundation; either
++ * version 2.1 of the License, or (at your option) any later version.
++ *
++ * This library is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
++ * Lesser General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License
++ * along with this program.  If not, see <http://www.gnu.org/licenses/>.
++ */
++
++#ifndef P11TEST_COMMON_H
++#define P11TEST_COMMON_H
++#include "config.h"
++#include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
++#include <setjmp.h>
++#include <cmocka.h>
++#include "pkcs11/pkcs11.h"
++#include "libopensc/sc-ossl-compat.h"
++
++#define MAX_MECHS 200
++
++#ifndef NDEBUG
++      #define debug_print(fmt, ...) \
++              { fprintf(stderr, fmt "\n", ##__VA_ARGS__); } while (0)
++#else
++      #define debug_print(fmt, ...)
++#endif
++
++#define FLAGS_SIGN            0x01
++#define FLAGS_SIGN_OPENSSL    0x02
++#define FLAGS_SIGN_ANY                ( FLAGS_SIGN | FLAGS_SIGN_OPENSSL )
++#define FLAGS_DECRYPT         0x04
++#define FLAGS_DECRYPT_OPENSSL 0x08
++#define FLAGS_DECRYPT_ANY     ( FLAGS_DECRYPT | FLAGS_DECRYPT_OPENSSL )
++
++typedef struct {
++      char *outfile;
++      FILE *fd;
++      int in_test;
++      int first;
++      int in_data;
++      int first_data;
++} log_context_t;
++
++typedef struct {
++      CK_MECHANISM_TYPE mech;
++      CK_MECHANISM_TYPE hash;
++      CK_RSA_PKCS_MGF_TYPE mgf;
++      int salt;
++      int usage_flags;
++      int result_flags;
++} test_mech_t;
++
++typedef struct {
++      CK_FUNCTION_LIST_PTR function_pointer;
++      CK_SLOT_ID slot_id;
++      CK_SESSION_HANDLE session_handle;
++      CK_UTF8CHAR* pin;
++      size_t pin_length;
++      char *library_path;
++      unsigned int interactive;
++      log_context_t log;
++
++      test_mech_t rsa_mechs[MAX_MECHS];
++      size_t  num_rsa_mechs;
++      test_mech_t     ec_mechs[MAX_MECHS];
++      size_t  num_ec_mechs;
++      test_mech_t     keygen_mechs[MAX_MECHS];
++      size_t  num_keygen_mechs;
++} token_info_t;
++
++token_info_t token;
++
++#endif /* P11TEST_COMMON_H */
++
index 851dc846d17dfcdde015d89e39be63fd5d42f40b..c89909acdef590b47c851e29e6c3d9fc07ff9f9a 100644 (file)
@@ -6,13 +6,14 @@
 Summary:       OpenSC library - for accessing SmartCard devices using PC/SC Lite
 Summary(pl.UTF-8):     Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
 Name:          opensc
-Version:       0.17.0
-Release:       2
+Version:       0.19.0
+Release:       1
 License:       LGPL v2.1+
 Group:         Applications
 #Source0Download: https://github.com/OpenSC/OpenSC/releases
 Source0:       https://github.com/OpenSC/OpenSC/releases/download/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: fc502ed7753f950b8e2a18a476d0cd52
+# Source0-md5: 40734b2343cf83c62c4c403f8a37475e
+Patch0:                build.patch
 URL:           https://github.com/OpenSC/OpenSC/wiki
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.10
@@ -101,6 +102,7 @@ Bashowe uzupełnianie parametrów poleceń OpenSC.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -145,13 +147,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/cardos-tool
 %attr(755,root,root) %{_bindir}/cryptoflex-tool
 %attr(755,root,root) %{_bindir}/dnie-tool
+%attr(755,root,root) %{_bindir}/egk-tool
 %attr(755,root,root) %{_bindir}/eidenv
 %attr(755,root,root) %{_bindir}/gids-tool
 %attr(755,root,root) %{_bindir}/iasecc-tool
 %attr(755,root,root) %{_bindir}/netkey-tool
 %attr(755,root,root) %{_bindir}/npa-tool
 %attr(755,root,root) %{_bindir}/openpgp-tool
+%attr(755,root,root) %{_bindir}/opensc-asn1
 %attr(755,root,root) %{_bindir}/opensc-explorer
+%attr(755,root,root) %{_bindir}/opensc-notify
 %attr(755,root,root) %{_bindir}/opensc-tool
 %attr(755,root,root) %{_bindir}/piv-tool
 %attr(755,root,root) %{_bindir}/pkcs11-tool
@@ -161,9 +166,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/sc-hsm-tool
 %attr(755,root,root) %{_bindir}/westcos-tool
 %attr(755,root,root) %{_libdir}/libopensc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopensc.so.5
+%attr(755,root,root) %ghost %{_libdir}/libopensc.so.6
 %attr(755,root,root) %{_libdir}/libsmm-local.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsmm-local.so.5
+%attr(755,root,root) %ghost %{_libdir}/libsmm-local.so.6
 # PKCS11 modules
 %attr(755,root,root) %{_libdir}/onepin-opensc-pkcs11.so
 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
@@ -180,13 +185,16 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/cardos-tool.1*
 %{_mandir}/man1/cryptoflex-tool.1*
 %{_mandir}/man1/dnie-tool.1*
+%{_mandir}/man1/egk-tool.1*
 %{_mandir}/man1/eidenv.1*
 %{_mandir}/man1/gids-tool.1*
 %{_mandir}/man1/iasecc-tool.1*
 %{_mandir}/man1/netkey-tool.1*
 %{_mandir}/man1/npa-tool.1*
 %{_mandir}/man1/openpgp-tool.1*
+%{_mandir}/man1/opensc-asn1.1*
 %{_mandir}/man1/opensc-explorer.1*
+%{_mandir}/man1/opensc-notify.1*
 %{_mandir}/man1/opensc-tool.1*
 %{_mandir}/man1/piv-tool.1*
 %{_mandir}/man1/pkcs11-tool.1*
@@ -195,6 +203,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/pkcs15-tool.1*
 %{_mandir}/man1/sc-hsm-tool.1*
 %{_mandir}/man1/westcos-tool.1*
+%{_mandir}/man5/opensc.conf.5*
 %{_mandir}/man5/pkcs15-profile.5*
 
 %files devel
@@ -212,12 +221,16 @@ rm -rf $RPM_BUILD_ROOT
 /etc/bash_completion.d/cardos-tool
 /etc/bash_completion.d/cryptoflex-tool
 /etc/bash_completion.d/dnie-tool
+/etc/bash_completion.d/egk-tool
 /etc/bash_completion.d/eidenv
 /etc/bash_completion.d/gids-tool
 /etc/bash_completion.d/iasecc-tool
 /etc/bash_completion.d/netkey-tool
+/etc/bash_completion.d/npa-tool
 /etc/bash_completion.d/openpgp-tool
+/etc/bash_completion.d/opensc-asn1
 /etc/bash_completion.d/opensc-explorer
+/etc/bash_completion.d/opensc-notify
 /etc/bash_completion.d/opensc-tool
 /etc/bash_completion.d/piv-tool
 /etc/bash_completion.d/pkcs11-tool
This page took 0.083644 seconds and 4 git commands to generate.