- disable Werror due to usage of deprecated openssl APIs auto/th/opensc-0.19.0-4
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 4 Oct 2021 20:33:12 +0000 (22:33 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 4 Oct 2021 20:33:12 +0000 (22:33 +0200)
- rel 4

no-Werror.patch [new file with mode: 0644]
opensc.spec

diff --git a/no-Werror.patch b/no-Werror.patch
new file mode 100644 (file)
index 0000000..68d5db7
--- /dev/null
@@ -0,0 +1,30 @@
+--- opensc-0.19.0/configure.ac~        2018-09-13 13:52:42.000000000 +0200
++++ opensc-0.19.0/configure.ac 2021-10-04 22:28:33.902587661 +0200
+@@ -130,7 +130,6 @@
+       ;;
+ esac
+-AX_CHECK_COMPILE_FLAG(-Wunknown-warning-option, [have_unknown_warning_option="yes"], [have_unknown_warning_option="no"], [-Werror])
+ AM_CONDITIONAL([HAVE_UNKNOWN_WARNING_OPTION], [test "${have_unknown_warning_option}" = "yes"])
+ AC_ARG_ENABLE(
+@@ -1042,7 +1042,7 @@
+       CFLAGS="${CFLAGS} -pedantic"
+ fi
+ if test "${enable_strict}" = "yes"; then
+-      CFLAGS="${CFLAGS} -Wall -Wextra -Wno-unused-parameter -Werror"
++      CFLAGS="${CFLAGS} -Wall -Wextra -Wno-unused-parameter"
+ fi
+ AC_CONFIG_FILES([
+--- opensc-0.19.0/m4/ax_pthread.m4~    2018-09-13 13:52:42.000000000 +0200
++++ opensc-0.19.0/m4/ax_pthread.m4     2021-10-04 22:29:18.960949785 +0200
+@@ -299,7 +299,7 @@
+              ax_pthread_save_CFLAGS="$CFLAGS"
+              for ax_pthread_try in '' -Qunused-arguments -Wno-unused-command-line-argument unknown; do
+                 AS_IF([test "x$ax_pthread_try" = "xunknown"], [break])
+-                CFLAGS="-Werror -Wunknown-warning-option $ax_pthread_try -pthread $ax_pthread_save_CFLAGS"
++                CFLAGS="-Wunknown-warning-option $ax_pthread_try -pthread $ax_pthread_save_CFLAGS"
+                 ac_link="$ax_pthread_save_ac_link"
+                 AC_LINK_IFELSE([AC_LANG_SOURCE([[int main(void){return 0;}]])],
+                     [ac_link="$ax_pthread_2step_ac_link"
index d5db61cfae6e0cea9a379984a3a0566d015204dc..35def41c1bedf296309304b9d9529cb82d1356c9 100644 (file)
@@ -7,13 +7,14 @@ Summary:      OpenSC library - for accessing SmartCard devices using PC/SC Lite
 Summary(pl.UTF-8):     Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
 Name:          opensc
 Version:       0.19.0
-Release:       3
+Release:       4
 License:       LGPL v2.1+
 Group:         Applications
 #Source0Download: https://github.com/OpenSC/OpenSC/releases
 Source0:       https://github.com/OpenSC/OpenSC/releases/download/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: 40734b2343cf83c62c4c403f8a37475e
 Patch0:                build.patch
+Patch1:                no-Werror.patch
 URL:           https://github.com/OpenSC/OpenSC/wiki
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.10
@@ -103,6 +104,7 @@ Bashowe uzupełnianie parametrów poleceń OpenSC.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
This page took 0.212607 seconds and 4 git commands to generate.