]> git.pld-linux.org Git - packages/opensc.git/blobdiff - opensc-missing.patch
- updated to 0.15.0
[packages/opensc.git] / opensc-missing.patch
diff --git a/opensc-missing.patch b/opensc-missing.patch
new file mode 100644 (file)
index 0000000..5f4af33
--- /dev/null
@@ -0,0 +1,48 @@
+--- opensc-0.15.0/doc/tools/completion-template.orig   1970-01-01 01:00:00.000000000 +0100
++++ opensc-0.15.0/doc/tools/completion-template        2016-01-31 12:03:43.666884836 +0100
+@@ -0,0 +1,45 @@
++# this was auto-generated by OpenSC/doc/tools/Makefile.am
++_FUNCTION_NAME()
++{
++    COMPREPLY=()
++    local cur prev split=false
++    _get_comp_words_by_ref cur prev
++
++    _split_longopt && split=true
++
++    opts="ALLOPTS"
++
++    if [ ${COMP_CWORD} -eq 1 ]; then
++        COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
++        return 0
++    fi
++
++    case "${prev}" in
++        OPTSWITHARGS)
++            return 0
++            ;;
++        *)
++            COMPREPLY=($(compgen -W "${opts}" -- ${cur}))
++            return 0
++            ;;
++    esac
++
++    $split && return 0
++
++    if [[ "$cur" == -* ]]; then
++        _longopt $1
++        return
++    fi
++
++    _filedir
++}
++complete -F _FUNCTION_NAME PROGRAM_NAME
++
++
++# Local variables:
++# mode: shell-script
++# sh-basic-offset: 4
++# sh-indent-comment: t
++# indent-tabs-mode: nil
++# End:
++# ex: ts=4 sw=4 et filetype=sh
This page took 0.072071 seconds and 4 git commands to generate.