]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- nest support
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl):    Biblioteka OpenSC - do korzystania z kart procesorowych przy u¿yciu PC/SC Lite
3 Name:           opensc
4 Version:        0.7.0
5 Release:        1
6 License:        LGPL
7 Group:          Applications
8 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-nolibs.patch
10 Patch1:         %{name}-segv.patch
11 Patch2:         %{name}-lt.patch
12 Patch3:         %{name}-ssl0.9.7.patch
13 URL:            http://www.opensc.org/
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake
16 BuildRequires:  libtool >= 1:1.4.2-9
17 BUildRequires:  openldap-devel
18 BuildRequires:  openssl-devel
19 BuildRequires:  pam-devel
20 BuildRequires:  pcsc-lite-devel
21 BuildRequires:  readline-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 libopensc is a library for accessing SmartCard devices using PC/SC
26 Lite middleware package. It is also the core library of the OpenSC
27 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
28 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
29 using private keys on the SmartCard is at the moment possible only
30 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
31 IDentity) card manufactured by Setec.
32
33 %description -l pl
34 libopensc to biblioteka do korzystania z kart procesorowych przy
35 u¿yciu pakietu warstwy po¶redniej PC/SC Lite. Jest to tak¿e podstawowa
36 biblioteka projektu OpenSC. Podstawowa funkcjonalno¶æ (np. SELECT
37 FILE, READ BINARY) powinna dzia³aæ tak¿e z dowoln± kart± procesorow±
38 zgodn± z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy u¿yciu
39 prywatnych kluczy na karcie na razie jest mo¿liwe tylko przy u¿yciu
40 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
41 IDentity) produkowanych przez Setec.
42
43 %package devel
44 Summary:        OpenSC development files
45 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenSC
46 Group:          Development/Tools
47 Requires:       %{name}-libs = %{version}
48
49 %description devel
50 OpenSC development files.
51
52 %description devel -l pl
53 Pliki dla programistów u¿ywaj±cych OpenSC.
54
55 %package static
56 Summary:        Static OpenSC libraries
57 Summary(pl):    Bibloteki statyczne OpenSC
58 Group:          Development/Tools
59 Requires:       %{name}-devel = %{version}
60
61 %description static
62 Static OpenSC libraries.
63
64 %description static -l pl
65 Statyczne biblioteki OpenSC.
66
67 %package -n pam_opensc
68 Summary:        OpenSC module for PAM
69 Summary(pl):    Modu³ PAM OpenSC
70 License:        GPL
71 Group:          Base
72 Requires:       %{name} = %{version}
73
74 %description -n pam_opensc
75 OpenSC module for PAM.
76
77 %description -n pam_opensc -l pl
78 Modu³ PAM OpenSC.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 %patch3 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__automake}
92 %configure
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install DESTDIR=$RPM_BUILD_ROOT
100
101 install -d $RPM_BUILD_ROOT/lib
102 mv -f $RPM_BUILD_ROOT%{_libdir}/security $RPM_BUILD_ROOT/lib
103
104 # libscam.a is broken (contains libscrandom.a) and not needed (static module)
105 rm -f $RPM_BUILD_ROOT%{_libdir}/libscam.{a,la}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS ChangeLog NEWS README README.signer THANKS TODO docs/pkcs-15v1_1.asn
116 %attr(755,root,root) %{_bindir}/cryptoflex-tool
117 %attr(755,root,root) %{_bindir}/opensc-explorer
118 %attr(755,root,root) %{_bindir}/opensc-tool
119 %attr(755,root,root) %{_bindir}/pkcs15-*
120 %attr(755,root,root) %{_libdir}/lib*.so.*.*
121 %attr(755,root,root) %{_libdir}/libscam.so
122 %dir %{_libdir}/pkcs11
123 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
124 %dir %{_datadir}/opensc
125 %{_datadir}/opensc/*.profile
126 %{_mandir}/man[157]/pkcs15*
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_bindir}/opensc-config
131 %attr(755,root,root) %{_libdir}/libopensc.so
132 %attr(755,root,root) %{_libdir}/libpkcs15init.so
133 %attr(755,root,root) %{_libdir}/libscconf.so
134 %attr(755,root,root) %{_libdir}/libscldap.so
135 %{_libdir}/libopensc.la
136 %{_libdir}/libpkcs15init.la
137 %{_libdir}/libscconf.la
138 %{_libdir}/libscldap.la
139 %{_libdir}/libscrandom.a
140 %{_includedir}/opensc
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libopensc.a
145 %{_libdir}/libpkcs15init.a
146 %{_libdir}/libscconf.a
147 %{_libdir}/libscldap.a
148
149 %files -n pam_opensc
150 %defattr(644,root,root,755)
151 %attr(755,root,root) /lib/security/pam_opensc.so
This page took 0.045833 seconds and 4 git commands to generate.