]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- updated to 0.12.2
[packages/opensc.git] / opensc.spec
1 #
2 # Conditional build:
3 %bcond_with     openct  # use OpenCT instead of PC/SC for reader access
4 #
5 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
6 Summary(pl.UTF-8):      Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
7 Name:           opensc
8 Version:        0.12.2
9 Release:        1
10 Epoch:          0
11 License:        LGPL v2.1+
12 Group:          Applications
13 Source0:        http://www.opensc-project.org/files/opensc/%{name}-%{version}.tar.gz
14 # Source0-md5:  5116adea5f2f9f22fb9896965789144b
15 Source1:        %{name}-initramfs-hook
16 Source2:        %{name}-initramfs-local-bottom
17 Source3:        %{name}-initramfs-local-top
18 Source4:        %{name}-initramfs-README
19 URL:            http://www.opensc-project.org/
20 BuildRequires:  autoconf >= 2.60
21 BuildRequires:  automake >= 1:1.10
22 BuildRequires:  docbook-style-xsl
23 BuildRequires:  libltdl-devel
24 BuildRequires:  libtool >= 1:1.4.2-9
25 BuildRequires:  libxslt-progs
26 %{?with_openct:BuildRequires:   openct-devel}
27 BuildRequires:  openldap-devel >= 2.4.6
28 BuildRequires:  openssl-devel >= 0.9.7d
29 %{!?with_openct:BuildRequires:  pcsc-lite-devel >= 1.6.0}
30 BuildRequires:  pkgconfig >= 1:0.9.0
31 BuildRequires:  readline-devel
32 BuildRequires:  rpmbuild(macros) >= 1.364
33 BuildRequires:  zlib-devel
34 %{!?with_openct:Requires:       pcsc-lite-libs >= 1.6.0}
35 Obsoletes:      browser-plugin-opensc
36 Obsoletes:      mozilla-plugin-opensc
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 # datadir is used for config files and (editable) profiles
40 %define         _datadir        /etc
41 %define         _sysconfdir     /etc/opensc
42
43 %description
44 libopensc is a library for accessing SmartCard devices using PC/SC
45 Lite middleware package. It is also the core library of the OpenSC
46 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
47 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
48 using private keys on the SmartCard is at the moment possible only
49 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
50 IDentity) card manufactured by Setec.
51
52 %description -l pl.UTF-8
53 libopensc to biblioteka do korzystania z kart procesorowych przy
54 użyciu pakietu warstwy pośredniej PC/SC Lite. Jest to także podstawowa
55 biblioteka projektu OpenSC. Podstawowa funkcjonalność (np. SELECT
56 FILE, READ BINARY) powinna działać także z dowolną kartą procesorową
57 zgodną z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy użyciu
58 prywatnych kluczy na karcie na razie jest możliwe tylko przy użyciu
59 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
60 IDentity) produkowanych przez Setec.
61
62 %package devel
63 Summary:        OpenSC development files
64 Summary(pl.UTF-8):      Pliki dla programistów używających OpenSC
65 Group:          Development/Tools
66 Requires:       %{name} = %{epoch}:%{version}-%{release}
67 Requires:       libltdl-devel
68 %{?with_openct:Requires:        openct-devel}
69 Requires:       openssl-devel
70 %{!?with_openct:Requires:       pcsc-lite-devel >= 1.6.0}
71
72 %description devel
73 OpenSC development files.
74
75 %description devel -l pl.UTF-8
76 Pliki dla programistów używających OpenSC.
77
78 %package static
79 Summary:        Static OpenSC library
80 Summary(pl.UTF-8):      Bibloteka statyczna OpenSC
81 Group:          Development/Tools
82 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
83
84 %description static
85 Static OpenSC library.
86
87 %description static -l pl.UTF-8
88 Biblioteka statyczna OpenSC.
89
90 %package initramfs
91 Summary:        OpenSC support scripts for initramfs-tools
92 Summary(pl.UTF-8):      Skrypty dla initramfs-tools ze wsparciem dla OpenSC
93 Group:          Base
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       initramfs-tools
96
97 %description initramfs
98 OpenSC support scripts for initramfs-tools.
99
100 %description initramfs -l pl.UTF-8
101 Skrypty dla initramfs-tools ze wsparciem dla OpenSC.
102
103 %prep
104 %setup -q
105 cp -p %{SOURCE4} README.initramfs
106
107 %build
108 %{__libtoolize}
109 %{__aclocal} -I m4
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         %{?with_openct:--enable-openct --disable-pcsc} \
115         %{!?with_openct:--enable-pcsc --disable-openct} \
116         --disable-silent-rules \
117         --enable-doc \
118         --with-pcsc-provider=%{_libdir}/libpcsclite.so.1
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/{hooks,scripts/local-{bottom,top}}
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/hooks/opensc
129 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/scripts/local-bottom/opensc
130 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/scripts/local-top/opensc
131
132 # not needed (dlopened by soname)
133 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{onepin-opensc-pkcs11,opensc-pkcs11,pkcs11-spy}.la
134
135 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 %doc ChangeLog NEWS README doc/html.out/tools.html
146 %attr(755,root,root) %{_bindir}/cardos-tool
147 %attr(755,root,root) %{_bindir}/cryptoflex-tool
148 %attr(755,root,root) %{_bindir}/eidenv
149 %attr(755,root,root) %{_bindir}/netkey-tool
150 %attr(755,root,root) %{_bindir}/opensc-explorer
151 %attr(755,root,root) %{_bindir}/opensc-tool
152 %attr(755,root,root) %{_bindir}/piv-tool
153 %attr(755,root,root) %{_bindir}/pkcs11-tool
154 %attr(755,root,root) %{_bindir}/pkcs15-crypt
155 %attr(755,root,root) %{_bindir}/pkcs15-init
156 %attr(755,root,root) %{_bindir}/pkcs15-tool
157 %attr(755,root,root) %{_bindir}/westcos-tool
158 %attr(755,root,root) %{_libdir}/libopensc.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libopensc.so.3
160 # PKCS11 modules
161 %attr(755,root,root) %{_libdir}/onepin-opensc-pkcs11.so
162 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
163 %attr(755,root,root) %{_libdir}/pkcs11-spy.so
164 %dir %{_libdir}/pkcs11
165 %attr(755,root,root) %{_libdir}/pkcs11/onepin-opensc-pkcs11.so
166 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
167 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
168 %dir %{_datadir}/opensc
169 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opensc.conf
170 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
171 %{_mandir}/man1/cardos-tool.1*
172 %{_mandir}/man1/cryptoflex-tool.1*
173 %{_mandir}/man1/eidenv.1*
174 %{_mandir}/man1/netkey-tool.1*
175 %{_mandir}/man1/opensc-explorer.1*
176 %{_mandir}/man1/opensc-tool.1*
177 %{_mandir}/man1/piv-tool.1*
178 %{_mandir}/man1/pkcs11-tool.1*
179 %{_mandir}/man1/pkcs15-crypt.1*
180 %{_mandir}/man1/pkcs15-init.1*
181 %{_mandir}/man1/pkcs15-tool.1*
182 %{_mandir}/man1/westcos-tool.1*
183 %{_mandir}/man5/pkcs15-profile.5*
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libopensc.so
188 %{_libdir}/libopensc.la
189
190 %files static
191 %defattr(644,root,root,755)
192 %{_libdir}/libopensc.a
193
194 %files initramfs
195 %defattr(644,root,root,755)
196 %doc README.initramfs
197 %attr(755,root,root) %{_datadir}/initramfs-tools/hooks/opensc
198 %attr(755,root,root) %{_datadir}/initramfs-tools/scripts/local-top/opensc
199 %attr(755,root,root) %{_datadir}/initramfs-tools/scripts/local-bottom/opensc
This page took 0.050184 seconds and 4 git commands to generate.