]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- massive change: BR openssl-devel >= 0.9.7d
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl):    Biblioteka OpenSC - do korzystania z kart procesorowych przy u¿yciu PC/SC Lite
3 Name:           opensc
4 Version:        0.8.1
5 Release:        3
6 Epoch:          0
7 License:        LGPL
8 Group:          Applications
9 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
10 # Source0-md5:  2b64a8e629bd28a00e707e35fd3eb9c7
11 Patch0:         %{name}-libdir.patch
12 Patch1:         %{name}-shared-ssl.patch
13 URL:            http://www.opensc.org/
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake
16 BuildRequires:  libassuan-devel >= 1:0.6.0
17 BuildRequires:  libtool >= 1:1.4.2-9
18 BuildRequires:  openldap-devel
19 BuildRequires:  openssl-devel >= 0.9.7d
20 BuildRequires:  openct-devel
21 BuildRequires:  pam-devel
22 BuildRequires:  pcsc-lite-devel
23 BuildRequires:  readline-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # datadir is used for config files and (editable) profiles
27 %define         _datadir        %{_sysconfdir}
28 %define         mozplugindir    /usr/lib/mozilla/plugins
29
30 %description
31 libopensc is a library for accessing SmartCard devices using PC/SC
32 Lite middleware package. It is also the core library of the OpenSC
33 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
34 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
35 using private keys on the SmartCard is at the moment possible only
36 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
37 IDentity) card manufactured by Setec.
38
39 %description -l pl
40 libopensc to biblioteka do korzystania z kart procesorowych przy
41 u¿yciu pakietu warstwy po¶redniej PC/SC Lite. Jest to tak¿e podstawowa
42 biblioteka projektu OpenSC. Podstawowa funkcjonalno¶æ (np. SELECT
43 FILE, READ BINARY) powinna dzia³aæ tak¿e z dowoln± kart± procesorow±
44 zgodn± z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy u¿yciu
45 prywatnych kluczy na karcie na razie jest mo¿liwe tylko przy u¿yciu
46 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
47 IDentity) produkowanych przez Setec.
48
49 %package devel
50 Summary:        OpenSC development files
51 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenSC
52 Group:          Development/Tools
53 Requires:       %{name} = %{epoch}:%{version}-%{release}
54 Requires:       openct-devel
55 Requires:       openssl-devel
56 Requires:       pcsc-lite-devel
57
58 %description devel
59 OpenSC development files.
60
61 %description devel -l pl
62 Pliki dla programistów u¿ywaj±cych OpenSC.
63
64 %package static
65 Summary:        Static OpenSC libraries
66 Summary(pl):    Bibloteki statyczne OpenSC
67 Group:          Development/Tools
68 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
69
70 %description static
71 Static OpenSC libraries.
72
73 %description static -l pl
74 Statyczne biblioteki OpenSC.
75
76 %package -n pam-pam_opensc
77 Summary:        OpenSC module for PAM
78 Summary(pl):    Modu³ PAM OpenSC
79 License:        GPL
80 Group:          Base
81 Requires:       %{name} = %{epoch}:%{version}-%{release}
82 Obsoletes:      pam_opensc
83
84 %description -n pam-pam_opensc
85 OpenSC module for PAM.
86
87 %description -n pam-pam_opensc -l pl
88 Modu³ PAM OpenSC.
89
90 %package -n mozilla-plugin-opensc
91 Summary:        OpenSC Signer plugin for Mozilla
92 Summary(pl):    Wtyczka OpenSC Signer dla Mozilli
93 # libassuan is GPL
94 License:        GPL
95 Group:          X11/Applications
96 Requires:       %{name} = %{epoch}:%{version}-%{release}
97 Requires:       pinentry-gtk
98
99 %description -n mozilla-plugin-opensc
100 OpenSC Signer plugin for Mozilla.
101
102 %description -n mozilla-plugin-opensc -l pl
103 Wtyczka OpenSC Signer dla Mozilli.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109
110 %build
111 %{__libtoolize}
112 %{__aclocal}
113 %{__autoconf}
114 %{__automake}
115 %configure \
116         --with-pin-entry=/usr/bin/pinentry-gtk \
117         --with-plugin-dir="%{mozplugindir}"
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT%{mozplugindir}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 install -d $RPM_BUILD_ROOT/lib
129 mv -f $RPM_BUILD_ROOT%{_libdir}/security $RPM_BUILD_ROOT/lib
130
131 # just install instead of symlinking
132 rm -f $RPM_BUILD_ROOT%{mozplugindir}/opensc-signer.so
133 mv -f $RPM_BUILD_ROOT%{_libdir}/opensc/opensc-signer.so $RPM_BUILD_ROOT%{mozplugindir}
134
135 # default config
136 mv -f $RPM_BUILD_ROOT%{_datadir}/opensc/opensc.conf{.example,}
137 mv -f $RPM_BUILD_ROOT%{_datadir}/opensc/scldap.conf{.example,}
138
139 # useless (dlopened by *.so)
140 rm -f $RPM_BUILD_ROOT%{_libdir}/libscam.{a,la} \
141         $RPM_BUILD_ROOT%{_libdir}/opensc/*.{a,la} \
142         $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.{a,la} \
143         $RPM_BUILD_ROOT/lib/security/pam_opensc.{a,la}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %files
152 %defattr(644,root,root,755)
153 %doc ANNOUNCE ChangeLog NEWS docs/{pkcs-15v1_1.asn,opensc.{html,css}}
154 %attr(755,root,root) %{_bindir}/cardos-info
155 %attr(755,root,root) %{_bindir}/cryptoflex-tool
156 %attr(755,root,root) %{_bindir}/opensc-explorer
157 %attr(755,root,root) %{_bindir}/opensc-tool
158 %attr(755,root,root) %{_bindir}/pkcs11-tool
159 %attr(755,root,root) %{_bindir}/pkcs15-*
160 %attr(755,root,root) %{_libdir}/lib*.so.*.*
161 %attr(755,root,root) %{_libdir}/libscam.so
162 %dir %{_libdir}/pkcs11
163 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
164 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
165 %dir %{_libdir}/opensc
166 %attr(755,root,root) %{_libdir}/opensc/engine_opensc.so
167 %attr(755,root,root) %{_libdir}/opensc/engine_pkcs11.so
168 %dir %{_datadir}/opensc
169 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.conf
170 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.profile
171 %{_mandir}/man1/cryptoflex-tool.1*
172 %{_mandir}/man1/opensc-explorer.1*
173 %{_mandir}/man1/opensc-tool.1*
174 %{_mandir}/man1/pkcs15*
175 %{_mandir}/man[57]/*
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_bindir}/opensc-config
180 %attr(755,root,root) %{_libdir}/libopensc.so
181 %attr(755,root,root) %{_libdir}/libpkcs11.so
182 %attr(755,root,root) %{_libdir}/libpkcs15init.so
183 %attr(755,root,root) %{_libdir}/libscconf.so
184 %attr(755,root,root) %{_libdir}/libscldap.so
185 %{_libdir}/lib*.la
186 %{_includedir}/opensc
187 %{_pkgconfigdir}/*.pc
188 %{_mandir}/man1/opensc-config.1*
189 %{_mandir}/man3/*
190
191 %files static
192 %defattr(644,root,root,755)
193 %{_libdir}/lib*.a
194
195 %files -n pam-pam_opensc
196 %defattr(644,root,root,755)
197 %attr(755,root,root) /lib/security/pam_opensc.so
198
199 %files -n mozilla-plugin-opensc
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{mozplugindir}/opensc-signer.so
This page took 0.061709 seconds and 4 git commands to generate.