]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- rel 2
[packages/opensc.git] / opensc.spec
1 #
2 # Conditional build:
3 %bcond_with     openct  # use OpenCT instead of PC/SC for reader access
4 #
5 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
6 Summary(pl.UTF-8):      Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
7 Name:           opensc
8 Version:        0.12.2
9 Release:        2
10 Epoch:          0
11 License:        LGPL v2.1+
12 Group:          Applications
13 Source0:        http://www.opensc-project.org/files/opensc/%{name}-%{version}.tar.gz
14 # Source0-md5:  5116adea5f2f9f22fb9896965789144b
15 URL:            http://www.opensc-project.org/
16 BuildRequires:  autoconf >= 2.60
17 BuildRequires:  automake >= 1:1.10
18 BuildRequires:  docbook-style-xsl
19 BuildRequires:  libltdl-devel
20 BuildRequires:  libtool >= 1:1.4.2-9
21 BuildRequires:  libxslt-progs
22 %{?with_openct:BuildRequires:   openct-devel}
23 BuildRequires:  openssl-devel >= 0.9.7d
24 %{!?with_openct:BuildRequires:  pcsc-lite-devel >= 1.6.0}
25 BuildRequires:  pkgconfig >= 1:0.9.0
26 BuildRequires:  readline-devel
27 BuildRequires:  rpmbuild(macros) >= 1.364
28 BuildRequires:  zlib-devel
29 %{!?with_openct:Requires:       pcsc-lite-libs >= 1.6.0}
30 Obsoletes:      browser-plugin-opensc
31 Obsoletes:      mozilla-plugin-opensc
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 # datadir is used for config files and (editable) profiles
35 %define         _datadir        /etc
36 %define         _sysconfdir     /etc/opensc
37
38 %description
39 libopensc is a library for accessing SmartCard devices using PC/SC
40 Lite middleware package. It is also the core library of the OpenSC
41 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
42 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
43 using private keys on the SmartCard is at the moment possible only
44 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
45 IDentity) card manufactured by Setec.
46
47 %description -l pl.UTF-8
48 libopensc to biblioteka do korzystania z kart procesorowych przy
49 użyciu pakietu warstwy pośredniej PC/SC Lite. Jest to także podstawowa
50 biblioteka projektu OpenSC. Podstawowa funkcjonalność (np. SELECT
51 FILE, READ BINARY) powinna działać także z dowolną kartą procesorową
52 zgodną z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy użyciu
53 prywatnych kluczy na karcie na razie jest możliwe tylko przy użyciu
54 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
55 IDentity) produkowanych przez Setec.
56
57 %package devel
58 Summary:        OpenSC development files
59 Summary(pl.UTF-8):      Pliki dla programistów używających OpenSC
60 Group:          Development/Tools
61 Requires:       %{name} = %{epoch}:%{version}-%{release}
62 Requires:       libltdl-devel
63 %{?with_openct:Requires:        openct-devel}
64 Requires:       openssl-devel
65 %{!?with_openct:Requires:       pcsc-lite-devel >= 1.6.0}
66
67 %description devel
68 OpenSC development files.
69
70 %description devel -l pl.UTF-8
71 Pliki dla programistów używających OpenSC.
72
73 %package static
74 Summary:        Static OpenSC library
75 Summary(pl.UTF-8):      Bibloteka statyczna OpenSC
76 Group:          Development/Tools
77 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
78
79 %description static
80 Static OpenSC library.
81
82 %description static -l pl.UTF-8
83 Biblioteka statyczna OpenSC.
84
85 %prep
86 %setup -q
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         %{?with_openct:--enable-openct --disable-pcsc} \
96         %{!?with_openct:--enable-pcsc --disable-openct} \
97         --disable-silent-rules \
98         --enable-doc \
99         --with-pcsc-provider=%{_libdir}/libpcsclite.so.1
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 # not needed (dlopened by soname)
109 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{onepin-opensc-pkcs11,opensc-pkcs11,pkcs11-spy}.la
110
111 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc ChangeLog NEWS README doc/html.out/tools.html
122 %attr(755,root,root) %{_bindir}/cardos-tool
123 %attr(755,root,root) %{_bindir}/cryptoflex-tool
124 %attr(755,root,root) %{_bindir}/eidenv
125 %attr(755,root,root) %{_bindir}/netkey-tool
126 %attr(755,root,root) %{_bindir}/opensc-explorer
127 %attr(755,root,root) %{_bindir}/opensc-tool
128 %attr(755,root,root) %{_bindir}/piv-tool
129 %attr(755,root,root) %{_bindir}/pkcs11-tool
130 %attr(755,root,root) %{_bindir}/pkcs15-crypt
131 %attr(755,root,root) %{_bindir}/pkcs15-init
132 %attr(755,root,root) %{_bindir}/pkcs15-tool
133 %attr(755,root,root) %{_bindir}/westcos-tool
134 %attr(755,root,root) %{_libdir}/libopensc.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libopensc.so.3
136 # PKCS11 modules
137 %attr(755,root,root) %{_libdir}/onepin-opensc-pkcs11.so
138 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
139 %attr(755,root,root) %{_libdir}/pkcs11-spy.so
140 %dir %{_libdir}/pkcs11
141 %attr(755,root,root) %{_libdir}/pkcs11/onepin-opensc-pkcs11.so
142 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
143 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
144 %dir %{_datadir}/opensc
145 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opensc.conf
146 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
147 %{_mandir}/man1/cardos-tool.1*
148 %{_mandir}/man1/cryptoflex-tool.1*
149 %{_mandir}/man1/eidenv.1*
150 %{_mandir}/man1/netkey-tool.1*
151 %{_mandir}/man1/opensc-explorer.1*
152 %{_mandir}/man1/opensc-tool.1*
153 %{_mandir}/man1/piv-tool.1*
154 %{_mandir}/man1/pkcs11-tool.1*
155 %{_mandir}/man1/pkcs15-crypt.1*
156 %{_mandir}/man1/pkcs15-init.1*
157 %{_mandir}/man1/pkcs15-tool.1*
158 %{_mandir}/man1/westcos-tool.1*
159 %{_mandir}/man5/pkcs15-profile.5*
160
161 %files devel
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libopensc.so
164 %{_libdir}/libopensc.la
165
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/libopensc.a
This page took 0.063458 seconds and 4 git commands to generate.