]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- added atr patch; libassuan is LGPL now - updated mozilla-plugin- license
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl):    Biblioteka OpenSC - do korzystania z kart procesorowych przy u¿yciu PC/SC Lite
3 Name:           opensc
4 Version:        0.8.1
5 Release:        5
6 Epoch:          0
7 License:        LGPL
8 Group:          Applications
9 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
10 # Source0-md5:  2b64a8e629bd28a00e707e35fd3eb9c7
11 Patch0:         %{name}-libdir.patch
12 Patch1:         %{name}-shared-ssl.patch
13 Patch2:         %{name}-segv.patch
14 Patch3:         %{name}-atr.patch
15 URL:            http://www.opensc.org/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake
18 BuildRequires:  libassuan-devel >= 1:0.6.0
19 BuildRequires:  libtool >= 1:1.4.2-9
20 BuildRequires:  openldap-devel
21 BuildRequires:  openssl-devel >= 0.9.7d
22 BuildRequires:  openct-devel
23 BuildRequires:  pam-devel
24 BuildRequires:  pcsc-lite-devel
25 BuildRequires:  readline-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # datadir is used for config files and (editable) profiles
29 %define         _datadir        /etc
30 %define         _sysconfdir     /etc/opensc
31 %define         mozplugindir    /usr/%{_lib}/mozilla/plugins
32
33 %description
34 libopensc is a library for accessing SmartCard devices using PC/SC
35 Lite middleware package. It is also the core library of the OpenSC
36 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
37 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
38 using private keys on the SmartCard is at the moment possible only
39 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
40 IDentity) card manufactured by Setec.
41
42 %description -l pl
43 libopensc to biblioteka do korzystania z kart procesorowych przy
44 u¿yciu pakietu warstwy po¶redniej PC/SC Lite. Jest to tak¿e podstawowa
45 biblioteka projektu OpenSC. Podstawowa funkcjonalno¶æ (np. SELECT
46 FILE, READ BINARY) powinna dzia³aæ tak¿e z dowoln± kart± procesorow±
47 zgodn± z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy u¿yciu
48 prywatnych kluczy na karcie na razie jest mo¿liwe tylko przy u¿yciu
49 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
50 IDentity) produkowanych przez Setec.
51
52 %package devel
53 Summary:        OpenSC development files
54 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenSC
55 Group:          Development/Tools
56 Requires:       %{name} = %{epoch}:%{version}-%{release}
57 Requires:       openct-devel
58 Requires:       openssl-devel
59 Requires:       pcsc-lite-devel
60
61 %description devel
62 OpenSC development files.
63
64 %description devel -l pl
65 Pliki dla programistów u¿ywaj±cych OpenSC.
66
67 %package static
68 Summary:        Static OpenSC libraries
69 Summary(pl):    Bibloteki statyczne OpenSC
70 Group:          Development/Tools
71 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
72
73 %description static
74 Static OpenSC libraries.
75
76 %description static -l pl
77 Statyczne biblioteki OpenSC.
78
79 %package -n pam-pam_opensc
80 Summary:        OpenSC module for PAM
81 Summary(pl):    Modu³ PAM OpenSC
82 License:        GPL
83 Group:          Base
84 Requires:       %{name} = %{epoch}:%{version}-%{release}
85 Obsoletes:      pam_opensc
86
87 %description -n pam-pam_opensc
88 OpenSC module for PAM.
89
90 %description -n pam-pam_opensc -l pl
91 Modu³ PAM OpenSC.
92
93 %package -n mozilla-plugin-opensc
94 Summary:        OpenSC Signer plugin for Mozilla
95 Summary(pl):    Wtyczka OpenSC Signer dla Mozilli
96 Group:          X11/Applications
97 Requires:       %{name} = %{epoch}:%{version}-%{release}
98 Requires:       pinentry-gtk
99
100 %description -n mozilla-plugin-opensc
101 OpenSC Signer plugin for Mozilla.
102
103 %description -n mozilla-plugin-opensc -l pl
104 Wtyczka OpenSC Signer dla Mozilli.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111 %patch3 -p1
112
113 %build
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoconf}
117 %{__autoheader}
118 %{__automake}
119 %configure \
120         --with-pin-entry=/usr/bin/pinentry-gtk \
121         --with-plugin-dir="%{mozplugindir}"
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT%{mozplugindir}
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install -d $RPM_BUILD_ROOT/%{_lib}
133 mv -f $RPM_BUILD_ROOT%{_libdir}/security $RPM_BUILD_ROOT/%{_lib}
134
135 # just install instead of symlinking
136 rm -f $RPM_BUILD_ROOT%{mozplugindir}/opensc-signer.so
137 mv -f $RPM_BUILD_ROOT%{_libdir}/opensc/opensc-signer.so $RPM_BUILD_ROOT%{mozplugindir}
138
139 # default config
140 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/opensc.conf{.example,}
141 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/scldap.conf{.example,}
142
143 # useless (dlopened by *.so)
144 rm -f $RPM_BUILD_ROOT%{_libdir}/{libscam,opensc-*}.{a,la} \
145         $RPM_BUILD_ROOT%{_libdir}/opensc/*.{a,la} \
146         $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.{a,la} \
147         $RPM_BUILD_ROOT/%{_lib}/security/pam_opensc.{a,la}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc ANNOUNCE ChangeLog NEWS docs/{pkcs-15v1_1.asn,opensc.{html,css}}
158 %attr(755,root,root) %{_bindir}/cardos-info
159 %attr(755,root,root) %{_bindir}/cryptoflex-tool
160 %attr(755,root,root) %{_bindir}/opensc-explorer
161 %attr(755,root,root) %{_bindir}/opensc-tool
162 %attr(755,root,root) %{_bindir}/pkcs11-tool
163 %attr(755,root,root) %{_bindir}/pkcs15-*
164 %attr(755,root,root) %{_libdir}/lib*.so.*.*
165 %attr(755,root,root) %{_libdir}/libscam.so
166 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
167 %dir %{_libdir}/pkcs11
168 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
169 %dir %{_libdir}/opensc
170 %attr(755,root,root) %{_libdir}/opensc/engine_opensc.so
171 %attr(755,root,root) %{_libdir}/opensc/engine_pkcs11.so
172 %dir %{_datadir}/opensc
173 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.conf
174 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.profile
175 %{_mandir}/man1/cryptoflex-tool.1*
176 %{_mandir}/man1/opensc-explorer.1*
177 %{_mandir}/man1/opensc-tool.1*
178 %{_mandir}/man1/pkcs15*
179 %{_mandir}/man[57]/*
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_bindir}/opensc-config
184 %attr(755,root,root) %{_libdir}/libopensc.so
185 %attr(755,root,root) %{_libdir}/libpkcs11.so
186 %attr(755,root,root) %{_libdir}/libpkcs15init.so
187 %attr(755,root,root) %{_libdir}/libscconf.so
188 %attr(755,root,root) %{_libdir}/libscldap.so
189 %{_libdir}/lib*.la
190 %{_includedir}/opensc
191 %{_pkgconfigdir}/*.pc
192 %{_mandir}/man1/opensc-config.1*
193 %{_mandir}/man3/*
194
195 %files static
196 %defattr(644,root,root,755)
197 %{_libdir}/lib*.a
198
199 %files -n pam-pam_opensc
200 %defattr(644,root,root,755)
201 %attr(755,root,root) /%{_lib}/security/pam_opensc.so
202
203 %files -n mozilla-plugin-opensc
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{mozplugindir}/opensc-signer.so
This page took 0.035711 seconds and 4 git commands to generate.