]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- added pkcs15init-help patch (fix for pkcs15-init help)
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl):    Biblioteka OpenSC - do korzystania z kart procesorowych przy u¿yciu PC/SC Lite
3 Name:           opensc
4 Version:        0.7.0
5 Release:        2
6 License:        LGPL
7 Group:          Applications
8 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-nolibs.patch
10 Patch1:         %{name}-segv.patch
11 Patch2:         %{name}-lt.patch
12 Patch3:         %{name}-ssl0.9.7.patch
13 Patch4:         %{name}-cryptoflex.patch
14 Patch5:         %{name}-pkcs15init-help.patch
15 URL:            http://www.opensc.org/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake
18 BuildRequires:  libassuan-devel
19 BuildRequires:  libtool >= 1:1.4.2-9
20 BUildRequires:  openldap-devel
21 BuildRequires:  openssl-devel
22 BuildRequires:  pam-devel
23 BuildRequires:  pcsc-lite-devel
24 BuildRequires:  readline-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # datadir is used for config files and (editable) profiles
28 %define         _datadir        %{_sysconfdir}
29 %define         mozplugindir    /usr/lib/mozilla/plugins
30
31 %description
32 libopensc is a library for accessing SmartCard devices using PC/SC
33 Lite middleware package. It is also the core library of the OpenSC
34 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
35 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
36 using private keys on the SmartCard is at the moment possible only
37 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
38 IDentity) card manufactured by Setec.
39
40 %description -l pl
41 libopensc to biblioteka do korzystania z kart procesorowych przy
42 u¿yciu pakietu warstwy po¶redniej PC/SC Lite. Jest to tak¿e podstawowa
43 biblioteka projektu OpenSC. Podstawowa funkcjonalno¶æ (np. SELECT
44 FILE, READ BINARY) powinna dzia³aæ tak¿e z dowoln± kart± procesorow±
45 zgodn± z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy u¿yciu
46 prywatnych kluczy na karcie na razie jest mo¿liwe tylko przy u¿yciu
47 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
48 IDentity) produkowanych przez Setec.
49
50 %package devel
51 Summary:        OpenSC development files
52 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenSC
53 Group:          Development/Tools
54 Requires:       %{name} = %{version}
55
56 %description devel
57 OpenSC development files.
58
59 %description devel -l pl
60 Pliki dla programistów u¿ywaj±cych OpenSC.
61
62 %package static
63 Summary:        Static OpenSC libraries
64 Summary(pl):    Bibloteki statyczne OpenSC
65 Group:          Development/Tools
66 Requires:       %{name}-devel = %{version}
67
68 %description static
69 Static OpenSC libraries.
70
71 %description static -l pl
72 Statyczne biblioteki OpenSC.
73
74 %package -n pam_opensc
75 Summary:        OpenSC module for PAM
76 Summary(pl):    Modu³ PAM OpenSC
77 License:        GPL
78 Group:          Base
79 Requires:       %{name} = %{version}
80
81 %description -n pam_opensc
82 OpenSC module for PAM.
83
84 %description -n pam_opensc -l pl
85 Modu³ PAM OpenSC.
86
87 %package -n mozilla-plugin-opensc
88 Summary:        OpenSC Signer plugin for Mozilla
89 Summary(pl):    Wtyczka OpenSC Signer dla Mozilli
90 # libassuan is GPL
91 License:        GPL
92 Group:          X11/Applications
93 Requires:       %{name} = %{version}
94 Requires:       pinentry-gtk
95
96 %description -n mozilla-plugin-opensc
97 OpenSC Signer plugin for Mozilla.
98
99 %description -n mozilla-plugin-opensc -l pl
100 Wtyczka OpenSC Signer dla Mozilli.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107 %patch3 -p1
108 %patch4 -p1
109 %patch5 -p1
110
111 %build
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__automake}
116 %configure \
117         --with-pin-entry=/usr/bin/pinentry-gtk \
118         --with-plugin-dir="%{mozplugindir}"
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install DESTDIR=$RPM_BUILD_ROOT
126
127 install -d $RPM_BUILD_ROOT/lib
128 mv -f $RPM_BUILD_ROOT%{_libdir}/security $RPM_BUILD_ROOT/lib
129
130 # libscam.a is broken (contains libscrandom.a) and not needed (static module)
131 rm -f $RPM_BUILD_ROOT%{_libdir}/libscam.{a,la}
132
133 mv -f $RPM_BUILD_ROOT%{_datadir}/opensc/opensc.conf{.example,}
134 mv -f $RPM_BUILD_ROOT%{_datadir}/opensc/scldap.conf{.example,}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog NEWS README README.signer THANKS TODO docs/pkcs-15v1_1.asn
145 %attr(755,root,root) %{_bindir}/cryptoflex-tool
146 %attr(755,root,root) %{_bindir}/opensc-explorer
147 %attr(755,root,root) %{_bindir}/opensc-tool
148 %attr(755,root,root) %{_bindir}/pkcs15-*
149 %attr(755,root,root) %{_libdir}/lib*.so.*.*
150 %attr(755,root,root) %{_libdir}/libscam.so
151 %dir %{_libdir}/pkcs11
152 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
153 %dir %{_datadir}/opensc
154 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.conf
155 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.profile
156 %{_mandir}/man[157]/pkcs15*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/opensc-config
161 %attr(755,root,root) %{_libdir}/libopensc.so
162 %attr(755,root,root) %{_libdir}/libpkcs15init.so
163 %attr(755,root,root) %{_libdir}/libscconf.so
164 %attr(755,root,root) %{_libdir}/libscldap.so
165 %{_libdir}/libopensc.la
166 %{_libdir}/libpkcs15init.la
167 %{_libdir}/libscconf.la
168 %{_libdir}/libscldap.la
169 %{_libdir}/libscrandom.a
170 %{_includedir}/opensc
171
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/libopensc.a
175 %{_libdir}/libpkcs15init.a
176 %{_libdir}/libscconf.a
177 %{_libdir}/libscldap.a
178
179 %files -n pam_opensc
180 %defattr(644,root,root,755)
181 %attr(755,root,root) /lib/security/pam_opensc.so
182
183 %files -n mozilla-plugin-opensc
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{mozplugindir}/opensc-signer.so
This page took 0.041093 seconds and 4 git commands to generate.