]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- release 2
[packages/opensc.git] / opensc.spec
1 #
2 # Conditional build:
3 %bcond_with     openct          # use OpenCT instead of PC/SC for reader access
4 %bcond_without  openpace        # OpenPACE support
5 #
6 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
7 Summary(pl.UTF-8):      Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
8 Name:           opensc
9 Version:        0.19.0
10 Release:        6
11 License:        LGPL v2.1+
12 Group:          Applications
13 #Source0Download: https://github.com/OpenSC/OpenSC/releases
14 Source0:        https://github.com/OpenSC/OpenSC/releases/download/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  40734b2343cf83c62c4c403f8a37475e
16 Patch0:         build.patch
17 Patch1:         no-Werror.patch
18 URL:            https://github.com/OpenSC/OpenSC/wiki
19 BuildRequires:  autoconf >= 2.60
20 BuildRequires:  automake >= 1:1.10
21 BuildRequires:  cmocka-devel
22 BuildRequires:  docbook-style-xsl
23 BuildRequires:  libltdl-devel
24 BuildRequires:  libtool >= 1:1.4.2-9
25 BuildRequires:  libxslt-progs
26 %{?with_openct:BuildRequires:   openct-devel}
27 %{?with_openpace:BuildRequires: openpace-devel >= 0.9}
28 BuildRequires:  openssl-devel >= 0.9.7d
29 %{!?with_openct:BuildRequires:  pcsc-lite-devel >= 1.8.22}
30 BuildRequires:  pkgconfig >= 1:0.9.0
31 BuildRequires:  readline-devel
32 BuildRequires:  rpmbuild(macros) >= 1.364
33 BuildRequires:  zlib-devel
34 Requires:       filesystem >= 4.0-28
35 %{?with_openpace:Requires:      openpace >= 0.9}
36 %{!?with_openct:Requires:       pcsc-lite-libs >= 1.8.22}
37 Obsoletes:      browser-plugin-opensc
38 Obsoletes:      mozilla-plugin-opensc
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 # datadir is used for config files and (editable) profiles
42 %define         _datadir        /etc
43 %define         _sysconfdir     /etc/opensc
44
45 %description
46 libopensc is a library for accessing SmartCard devices using PC/SC
47 Lite middleware package. It is also the core library of the OpenSC
48 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
49 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
50 using private keys on the SmartCard is at the moment possible only
51 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
52 IDentity) card manufactured by Setec.
53
54 %description -l pl.UTF-8
55 libopensc to biblioteka do korzystania z kart procesorowych przy
56 użyciu pakietu warstwy pośredniej PC/SC Lite. Jest to także podstawowa
57 biblioteka projektu OpenSC. Podstawowa funkcjonalność (np. SELECT
58 FILE, READ BINARY) powinna działać także z dowolną kartą procesorową
59 zgodną z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy użyciu
60 prywatnych kluczy na karcie na razie jest możliwe tylko przy użyciu
61 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
62 IDentity) produkowanych przez Setec.
63
64 %package devel
65 Summary:        OpenSC development files
66 Summary(pl.UTF-8):      Pliki dla programistów używających OpenSC
67 Group:          Development/Tools
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       libltdl-devel
70 %{?with_openct:Requires:        openct-devel}
71 Requires:       openssl-devel >= 0.9.7d
72 %{!?with_openct:Requires:       pcsc-lite-devel >= 1.8.22}
73 Requires:       zlib-devel
74
75 %description devel
76 OpenSC development files.
77
78 %description devel -l pl.UTF-8
79 Pliki dla programistów używających OpenSC.
80
81 %package static
82 Summary:        Static OpenSC library
83 Summary(pl.UTF-8):      Bibloteka statyczna OpenSC
84 Group:          Development/Tools
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static OpenSC library.
89
90 %description static -l pl.UTF-8
91 Biblioteka statyczna OpenSC.
92
93 %package -n bash-completion-opensc
94 Summary:        Bash completion for OpenSC commands
95 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów poleceń OpenSC
96 Group:          Applications/Shells
97 Requires:       %{name} = %{version}-%{release}
98
99 %description -n bash-completion-opensc
100 Bash completion for OpenSC commands.
101
102 %description -n bash-completion-opensc -l pl.UTF-8
103 Bashowe uzupełnianie parametrów poleceń OpenSC.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109
110 %build
111 %{__libtoolize}
112 %{__aclocal} -I m4
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         %{?with_openct:--enable-openct --disable-pcsc} \
118         %{!?with_openct:--enable-pcsc --disable-openct} \
119         %{!?with_openpace:--disable-openpace} \
120         --disable-silent-rules \
121         --enable-doc \
122         --with-pcsc-provider=%{_libdir}/libpcsclite.so.1
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_libdir}/pkcs11}
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT \
132         completiondir=/etc/bash_completion.d
133
134 # not needed (dlopened by soname)
135 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{onepin-opensc-pkcs11,opensc-pkcs11,pkcs11-spy}.la
136 # API not exported
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{opensc,smm-local}.la
138
139 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc NEWS README doc/tools/tools.html
150 %attr(755,root,root) %{_bindir}/cardos-tool
151 %attr(755,root,root) %{_bindir}/cryptoflex-tool
152 %attr(755,root,root) %{_bindir}/dnie-tool
153 %attr(755,root,root) %{_bindir}/egk-tool
154 %attr(755,root,root) %{_bindir}/eidenv
155 %attr(755,root,root) %{_bindir}/gids-tool
156 %attr(755,root,root) %{_bindir}/iasecc-tool
157 %attr(755,root,root) %{_bindir}/netkey-tool
158 %attr(755,root,root) %{_bindir}/npa-tool
159 %attr(755,root,root) %{_bindir}/openpgp-tool
160 %attr(755,root,root) %{_bindir}/opensc-asn1
161 %attr(755,root,root) %{_bindir}/opensc-explorer
162 %attr(755,root,root) %{_bindir}/opensc-notify
163 %attr(755,root,root) %{_bindir}/opensc-tool
164 %attr(755,root,root) %{_bindir}/piv-tool
165 %attr(755,root,root) %{_bindir}/pkcs11-tool
166 %attr(755,root,root) %{_bindir}/pkcs15-crypt
167 %attr(755,root,root) %{_bindir}/pkcs15-init
168 %attr(755,root,root) %{_bindir}/pkcs15-tool
169 %attr(755,root,root) %{_bindir}/sc-hsm-tool
170 %attr(755,root,root) %{_bindir}/westcos-tool
171 %attr(755,root,root) %{_libdir}/libopensc.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libopensc.so.6
173 %attr(755,root,root) %{_libdir}/libsmm-local.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libsmm-local.so.6
175 # PKCS11 modules
176 %attr(755,root,root) %{_libdir}/onepin-opensc-pkcs11.so
177 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
178 %attr(755,root,root) %{_libdir}/pkcs11-spy.so
179 %attr(755,root,root) %{_libdir}/pkcs11/onepin-opensc-pkcs11.so
180 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
181 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
182 %dir %{_datadir}/opensc
183 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opensc.conf
184 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
185 %if %{with openpace}
186 /etc/eac/cvc/DESRCACC100001
187 %endif
188 %{_mandir}/man1/cardos-tool.1*
189 %{_mandir}/man1/cryptoflex-tool.1*
190 %{_mandir}/man1/dnie-tool.1*
191 %{_mandir}/man1/egk-tool.1*
192 %{_mandir}/man1/eidenv.1*
193 %{_mandir}/man1/gids-tool.1*
194 %{_mandir}/man1/iasecc-tool.1*
195 %{_mandir}/man1/netkey-tool.1*
196 %{_mandir}/man1/npa-tool.1*
197 %{_mandir}/man1/openpgp-tool.1*
198 %{_mandir}/man1/opensc-asn1.1*
199 %{_mandir}/man1/opensc-explorer.1*
200 %{_mandir}/man1/opensc-notify.1*
201 %{_mandir}/man1/opensc-tool.1*
202 %{_mandir}/man1/piv-tool.1*
203 %{_mandir}/man1/pkcs11-tool.1*
204 %{_mandir}/man1/pkcs15-crypt.1*
205 %{_mandir}/man1/pkcs15-init.1*
206 %{_mandir}/man1/pkcs15-tool.1*
207 %{_mandir}/man1/sc-hsm-tool.1*
208 %{_mandir}/man1/westcos-tool.1*
209 %{_mandir}/man5/opensc.conf.5*
210 %{_mandir}/man5/pkcs15-profile.5*
211
212 %files devel
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_libdir}/libopensc.so
215 %attr(755,root,root) %{_libdir}/libsmm-local.so
216 %{_pkgconfigdir}/opensc-pkcs11.pc
217
218 %files static
219 %defattr(644,root,root,755)
220 %{_libdir}/libopensc.a
221
222 %files -n bash-completion-opensc
223 %defattr(644,root,root,755)
224 /etc/bash_completion.d/cardos-tool
225 /etc/bash_completion.d/cryptoflex-tool
226 /etc/bash_completion.d/dnie-tool
227 /etc/bash_completion.d/egk-tool
228 /etc/bash_completion.d/eidenv
229 /etc/bash_completion.d/gids-tool
230 /etc/bash_completion.d/iasecc-tool
231 /etc/bash_completion.d/netkey-tool
232 /etc/bash_completion.d/npa-tool
233 /etc/bash_completion.d/openpgp-tool
234 /etc/bash_completion.d/opensc-asn1
235 /etc/bash_completion.d/opensc-explorer
236 /etc/bash_completion.d/opensc-notify
237 /etc/bash_completion.d/opensc-tool
238 /etc/bash_completion.d/piv-tool
239 /etc/bash_completion.d/pkcs11-tool
240 /etc/bash_completion.d/pkcs15-crypt
241 /etc/bash_completion.d/pkcs15-init
242 /etc/bash_completion.d/pkcs15-tool
243 /etc/bash_completion.d/sc-hsm-tool
244 /etc/bash_completion.d/westcos-tool
This page took 0.100242 seconds and 3 git commands to generate.