]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- leaded common naming conventions for PAM module packages
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl):    Biblioteka OpenSC - do korzystania z kart procesorowych przy u¿yciu PC/SC Lite
3 Name:           opensc
4 Version:        0.8.1
5 Release:        2
6 Epoch:          0
7 License:        LGPL
8 Group:          Applications
9 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
10 # Source0-md5:  2b64a8e629bd28a00e707e35fd3eb9c7
11 Patch0:         %{name}-libdir.patch
12 Patch1:         %{name}-shared-ssl.patch
13 URL:            http://www.opensc.org/
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake
16 BuildRequires:  libassuan-devel >= 1:0.6.0
17 BuildRequires:  libtool >= 1:1.4.2-9
18 BuildRequires:  openldap-devel
19 BuildRequires:  openssl-devel >= 0.9.7c
20 BuildRequires:  openct-devel
21 BuildRequires:  pam-devel
22 BuildRequires:  pcsc-lite-devel
23 BuildRequires:  readline-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # datadir is used for config files and (editable) profiles
27 %define         _datadir        %{_sysconfdir}
28 %define         mozplugindir    /usr/lib/mozilla/plugins
29
30 %description
31 libopensc is a library for accessing SmartCard devices using PC/SC
32 Lite middleware package. It is also the core library of the OpenSC
33 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
34 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
35 using private keys on the SmartCard is at the moment possible only
36 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
37 IDentity) card manufactured by Setec.
38
39 %description -l pl
40 libopensc to biblioteka do korzystania z kart procesorowych przy
41 u¿yciu pakietu warstwy po¶redniej PC/SC Lite. Jest to tak¿e podstawowa
42 biblioteka projektu OpenSC. Podstawowa funkcjonalno¶æ (np. SELECT
43 FILE, READ BINARY) powinna dzia³aæ tak¿e z dowoln± kart± procesorow±
44 zgodn± z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy u¿yciu
45 prywatnych kluczy na karcie na razie jest mo¿liwe tylko przy u¿yciu
46 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
47 IDentity) produkowanych przez Setec.
48
49 %package devel
50 Summary:        OpenSC development files
51 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenSC
52 Group:          Development/Tools
53 Requires:       %{name} = %{version}
54
55 %description devel
56 OpenSC development files.
57
58 %description devel -l pl
59 Pliki dla programistów u¿ywaj±cych OpenSC.
60
61 %package static
62 Summary:        Static OpenSC libraries
63 Summary(pl):    Bibloteki statyczne OpenSC
64 Group:          Development/Tools
65 Requires:       %{name}-devel = %{version}
66
67 %description static
68 Static OpenSC libraries.
69
70 %description static -l pl
71 Statyczne biblioteki OpenSC.
72
73 %package -n pam-pam_opensc
74 Summary:        OpenSC module for PAM
75 Summary(pl):    Modu³ PAM OpenSC
76 License:        GPL
77 Group:          Base
78 Requires:       %{name} = %{version}
79
80 %description -n pam-pam_opensc
81 OpenSC module for PAM.
82
83 %description -n pam-pam_opensc -l pl
84 Modu³ PAM OpenSC.
85
86 %package -n mozilla-plugin-opensc
87 Summary:        OpenSC Signer plugin for Mozilla
88 Summary(pl):    Wtyczka OpenSC Signer dla Mozilli
89 # libassuan is GPL
90 License:        GPL
91 Group:          X11/Applications
92 Requires:       %{name} = %{version}
93 Requires:       pinentry-gtk
94
95 %description -n mozilla-plugin-opensc
96 OpenSC Signer plugin for Mozilla.
97
98 %description -n mozilla-plugin-opensc -l pl
99 Wtyczka OpenSC Signer dla Mozilli.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105
106 %build
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoconf}
110 %{__automake}
111 %configure \
112         --with-pin-entry=/usr/bin/pinentry-gtk \
113         --with-plugin-dir="%{mozplugindir}"
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT%{mozplugindir}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install -d $RPM_BUILD_ROOT/lib
125 mv -f $RPM_BUILD_ROOT%{_libdir}/security $RPM_BUILD_ROOT/lib
126
127 # just install instead of symlinking
128 rm -f $RPM_BUILD_ROOT%{mozplugindir}/opensc-signer.so
129 mv -f $RPM_BUILD_ROOT%{_libdir}/opensc/opensc-signer.so $RPM_BUILD_ROOT%{mozplugindir}
130
131 # default config
132 mv -f $RPM_BUILD_ROOT%{_datadir}/opensc/opensc.conf{.example,}
133 mv -f $RPM_BUILD_ROOT%{_datadir}/opensc/scldap.conf{.example,}
134
135 # useless (dlopened by *.so)
136 rm -f $RPM_BUILD_ROOT%{_libdir}/libscam.{a,la} \
137         $RPM_BUILD_ROOT%{_libdir}/opensc/*.{a,la} \
138         $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.{a,la} \
139         $RPM_BUILD_ROOT/lib/security/pam_opensc.{a,la}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc ANNOUNCE ChangeLog NEWS docs/{pkcs-15v1_1.asn,opensc.{html,css}}
150 %attr(755,root,root) %{_bindir}/cardos-info
151 %attr(755,root,root) %{_bindir}/cryptoflex-tool
152 %attr(755,root,root) %{_bindir}/opensc-explorer
153 %attr(755,root,root) %{_bindir}/opensc-tool
154 %attr(755,root,root) %{_bindir}/pkcs11-tool
155 %attr(755,root,root) %{_bindir}/pkcs15-*
156 %attr(755,root,root) %{_libdir}/lib*.so.*.*
157 %attr(755,root,root) %{_libdir}/libscam.so
158 %dir %{_libdir}/pkcs11
159 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
160 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
161 %dir %{_libdir}/opensc
162 %attr(755,root,root) %{_libdir}/opensc/engine_opensc.so
163 %attr(755,root,root) %{_libdir}/opensc/engine_pkcs11.so
164 %dir %{_datadir}/opensc
165 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.conf
166 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.profile
167 %{_mandir}/man1/cryptoflex-tool.1*
168 %{_mandir}/man1/opensc-explorer.1*
169 %{_mandir}/man1/opensc-tool.1*
170 %{_mandir}/man1/pkcs15*
171 %{_mandir}/man[57]/*
172
173 %files devel
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_bindir}/opensc-config
176 %attr(755,root,root) %{_libdir}/libopensc.so
177 %attr(755,root,root) %{_libdir}/libpkcs15init.so
178 %attr(755,root,root) %{_libdir}/libscconf.so
179 %attr(755,root,root) %{_libdir}/libscldap.so
180 %{_libdir}/lib*.la
181 %{_includedir}/opensc
182 %{_pkgconfigdir}/*.pc
183 %{_mandir}/man1/opensc-config.1*
184 %{_mandir}/man3/*
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/lib*.a
189
190 %files -n pam-pam_opensc
191 %defattr(644,root,root,755)
192 %attr(755,root,root) /lib/security/pam_opensc.so
193
194 %files -n mozilla-plugin-opensc
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{mozplugindir}/opensc-signer.so
This page took 0.037449 seconds and 3 git commands to generate.