]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- updated to 0.11.0
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl):    Biblioteka OpenSC - do korzystania z kart procesorowych przy u¿yciu PC/SC Lite
3 Name:           opensc
4 Version:        0.11.0
5 Release:        1
6 Epoch:          0
7 License:        LGPL
8 Group:          Applications
9 Source0:        http://www.opensc-project.org/files/opensc/%{name}-%{version}.tar.gz
10 # Source0-md5:  be9cced6c703253baf78ccd9970679fa
11 Patch0:         %{name}-explorer-debug.patch
12 Patch1:         %{name}-libassuan.patch
13 URL:            http://www.opensc-project.org/
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake
16 BuildRequires:  libassuan-devel >= 1:0.6.0
17 BuildRequires:  libltdl-devel
18 BuildRequires:  libtool >= 1:1.4.2-9
19 BuildRequires:  openldap-devel
20 BuildRequires:  openssl-devel >= 0.9.7d
21 BuildRequires:  openct-devel
22 BuildRequires:  pcsc-lite-devel
23 BuildRequires:  pkgconfig >= 1:0.9.0
24 BuildRequires:  readline-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # datadir is used for config files and (editable) profiles
28 %define         _datadir        /etc
29 %define         _sysconfdir     /etc/opensc
30 %define         mozplugindir    /usr/%{_lib}/mozilla/plugins
31
32 %description
33 libopensc is a library for accessing SmartCard devices using PC/SC
34 Lite middleware package. It is also the core library of the OpenSC
35 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
36 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
37 using private keys on the SmartCard is at the moment possible only
38 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
39 IDentity) card manufactured by Setec.
40
41 %description -l pl
42 libopensc to biblioteka do korzystania z kart procesorowych przy
43 u¿yciu pakietu warstwy po¶redniej PC/SC Lite. Jest to tak¿e podstawowa
44 biblioteka projektu OpenSC. Podstawowa funkcjonalno¶æ (np. SELECT
45 FILE, READ BINARY) powinna dzia³aæ tak¿e z dowoln± kart± procesorow±
46 zgodn± z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy u¿yciu
47 prywatnych kluczy na karcie na razie jest mo¿liwe tylko przy u¿yciu
48 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
49 IDentity) produkowanych przez Setec.
50
51 %package devel
52 Summary:        OpenSC development files
53 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenSC
54 Group:          Development/Tools
55 Requires:       %{name} = %{epoch}:%{version}-%{release}
56 Requires:       libltdl-devel
57 Requires:       openct-devel
58 Requires:       openssl-devel
59 Requires:       pcsc-lite-devel
60
61 %description devel
62 OpenSC development files.
63
64 %description devel -l pl
65 Pliki dla programistów u¿ywaj±cych OpenSC.
66
67 %package static
68 Summary:        Static OpenSC libraries
69 Summary(pl):    Bibloteki statyczne OpenSC
70 Group:          Development/Tools
71 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
72
73 %description static
74 Static OpenSC libraries.
75
76 %description static -l pl
77 Statyczne biblioteki OpenSC.
78
79 %package -n mozilla-plugin-opensc
80 Summary:        OpenSC Signer plugin for Mozilla
81 Summary(pl):    Wtyczka OpenSC Signer dla Mozilli
82 Group:          X11/Applications
83 Requires:       %{name} = %{epoch}:%{version}-%{release}
84 Requires:       pinentry-gtk
85
86 %description -n mozilla-plugin-opensc
87 OpenSC Signer plugin for Mozilla.
88
89 %description -n mozilla-plugin-opensc -l pl
90 Wtyczka OpenSC Signer dla Mozilli.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96
97 %build
98 %{__libtoolize}
99 %{__aclocal} -I aclocal
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         --with-pin-entry=/usr/bin/pinentry-gtk \
105         --with-plugin-dir="%{mozplugindir}"
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT%{mozplugindir}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 # just install instead of symlinking
117 rm -f $RPM_BUILD_ROOT%{mozplugindir}/opensc-signer.so
118 mv -f $RPM_BUILD_ROOT%{_libdir}/opensc-signer.so $RPM_BUILD_ROOT%{mozplugindir}
119
120 # default config
121 install etc/opensc.conf $RPM_BUILD_ROOT%{_sysconfdir}
122
123 # useless (dlopened by *.so)
124 rm -f $RPM_BUILD_ROOT%{_libdir}/{opensc,pkcs11}-*.{a,la} \
125         $RPM_BUILD_ROOT%{_libdir}/opensc/*.{a,la}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc NEWS README doc/ChangeLog doc/{*.{html,css},html/tools.html}
136 %attr(755,root,root) %{_bindir}/cardos-info
137 %attr(755,root,root) %{_bindir}/cryptoflex-tool
138 %attr(755,root,root) %{_bindir}/eidenv
139 %attr(755,root,root) %{_bindir}/netkey-tool
140 %attr(755,root,root) %{_bindir}/opensc-explorer
141 %attr(755,root,root) %{_bindir}/opensc-tool
142 %attr(755,root,root) %{_bindir}/piv-tool
143 %attr(755,root,root) %{_bindir}/pkcs11-tool
144 %attr(755,root,root) %{_bindir}/pkcs15-*
145 %attr(755,root,root) %{_libdir}/lib*.so.*.*
146 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
147 %attr(755,root,root) %{_libdir}/pkcs11-spy.so
148 %dir %{_datadir}/opensc
149 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
150 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
151 %{_mandir}/man1/cardos-info.1*
152 %{_mandir}/man1/cryptoflex-tool.1*
153 %{_mandir}/man1/netkey-tool.1*
154 %{_mandir}/man1/opensc-explorer.1*
155 %{_mandir}/man1/opensc-tool.1*
156 %{_mandir}/man1/pkcs11-tool.1*
157 %{_mandir}/man1/pkcs15-*.1*
158 %{_mandir}/man[57]/*
159
160 %files devel
161 %defattr(644,root,root,755)
162 %doc doc/html/api.html
163 %attr(755,root,root) %{_bindir}/opensc-config
164 %attr(755,root,root) %{_libdir}/libopensc.so
165 %attr(755,root,root) %{_libdir}/libpkcs15init.so
166 %attr(755,root,root) %{_libdir}/libscconf.so
167 %{_libdir}/libopensc.la
168 %{_libdir}/libpkcs15init.la
169 %{_libdir}/libscconf.la
170 %{_includedir}/opensc
171 %{_pkgconfigdir}/*.pc
172 %{_mandir}/man1/opensc-config.1*
173 %{_mandir}/man3/*
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/libopensc.a
178 %{_libdir}/libpkcs15init.a
179 %{_libdir}/libscconf.a
180
181 %files -n mozilla-plugin-opensc
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{mozplugindir}/opensc-signer.so
This page took 0.058494 seconds and 3 git commands to generate.