]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- added cryptoflex patch (CryptoFlex 8k v2 support)
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl):    Biblioteka OpenSC - do korzystania z kart procesorowych przy u¿yciu PC/SC Lite
3 Name:           opensc
4 Version:        0.7.0
5 Release:        1
6 License:        LGPL
7 Group:          Applications
8 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-nolibs.patch
10 Patch1:         %{name}-segv.patch
11 Patch2:         %{name}-lt.patch
12 Patch3:         %{name}-ssl0.9.7.patch
13 Patch4:         %{name}-cryptoflex.patch
14 URL:            http://www.opensc.org/
15 BuildRequires:  autoconf >= 2.52
16 BuildRequires:  automake
17 BuildRequires:  libassuan-devel
18 BuildRequires:  libtool >= 1:1.4.2-9
19 BUildRequires:  openldap-devel
20 BuildRequires:  openssl-devel
21 BuildRequires:  pam-devel
22 BuildRequires:  pcsc-lite-devel
23 BuildRequires:  readline-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         mozplugindir    /usr/lib/mozilla/plugins
27
28 %description
29 libopensc is a library for accessing SmartCard devices using PC/SC
30 Lite middleware package. It is also the core library of the OpenSC
31 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
32 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
33 using private keys on the SmartCard is at the moment possible only
34 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
35 IDentity) card manufactured by Setec.
36
37 %description -l pl
38 libopensc to biblioteka do korzystania z kart procesorowych przy
39 u¿yciu pakietu warstwy po¶redniej PC/SC Lite. Jest to tak¿e podstawowa
40 biblioteka projektu OpenSC. Podstawowa funkcjonalno¶æ (np. SELECT
41 FILE, READ BINARY) powinna dzia³aæ tak¿e z dowoln± kart± procesorow±
42 zgodn± z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy u¿yciu
43 prywatnych kluczy na karcie na razie jest mo¿liwe tylko przy u¿yciu
44 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
45 IDentity) produkowanych przez Setec.
46
47 %package devel
48 Summary:        OpenSC development files
49 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenSC
50 Group:          Development/Tools
51 Requires:       %{name}-libs = %{version}
52
53 %description devel
54 OpenSC development files.
55
56 %description devel -l pl
57 Pliki dla programistów u¿ywaj±cych OpenSC.
58
59 %package static
60 Summary:        Static OpenSC libraries
61 Summary(pl):    Bibloteki statyczne OpenSC
62 Group:          Development/Tools
63 Requires:       %{name}-devel = %{version}
64
65 %description static
66 Static OpenSC libraries.
67
68 %description static -l pl
69 Statyczne biblioteki OpenSC.
70
71 %package -n pam_opensc
72 Summary:        OpenSC module for PAM
73 Summary(pl):    Modu³ PAM OpenSC
74 License:        GPL
75 Group:          Base
76 Requires:       %{name} = %{version}
77
78 %description -n pam_opensc
79 OpenSC module for PAM.
80
81 %description -n pam_opensc -l pl
82 Modu³ PAM OpenSC.
83
84 %package -n mozilla-plugin-opensc
85 Summary:        OpenSC Signer plugin for Mozilla
86 Summary(pl):    Wtyczka OpenSC Signer dla Mozilli
87 # libassuan is GPL
88 License:        GPL
89 Group:          X11/Applications
90 Requires:       %{name} = %{version}
91 Requires:       pinentry-gtk
92
93 %description -n mozilla-plugin-opensc
94 OpenSC Signer plugin for Mozilla.
95
96 %description -n mozilla-plugin-opensc -l pl
97 Wtyczka OpenSC Signer dla Mozilli.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105 %patch4 -p1
106
107 %build
108 %{__libtoolize}
109 %{__aclocal}
110 %{__autoconf}
111 %{__automake}
112 %configure \
113         --with-pin-entry=/usr/bin/pinentry-gtk \
114         --with-plugin-dir="%{mozplugindir}"
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install DESTDIR=$RPM_BUILD_ROOT
122
123 install -d $RPM_BUILD_ROOT/lib
124 mv -f $RPM_BUILD_ROOT%{_libdir}/security $RPM_BUILD_ROOT/lib
125
126 # libscam.a is broken (contains libscrandom.a) and not needed (static module)
127 rm -f $RPM_BUILD_ROOT%{_libdir}/libscam.{a,la}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog NEWS README README.signer THANKS TODO docs/pkcs-15v1_1.asn
138 %attr(755,root,root) %{_bindir}/cryptoflex-tool
139 %attr(755,root,root) %{_bindir}/opensc-explorer
140 %attr(755,root,root) %{_bindir}/opensc-tool
141 %attr(755,root,root) %{_bindir}/pkcs15-*
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*
143 %attr(755,root,root) %{_libdir}/libscam.so
144 %dir %{_libdir}/pkcs11
145 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
146 %dir %{_datadir}/opensc
147 %{_datadir}/opensc/*.profile
148 %{_mandir}/man[157]/pkcs15*
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/opensc-config
153 %attr(755,root,root) %{_libdir}/libopensc.so
154 %attr(755,root,root) %{_libdir}/libpkcs15init.so
155 %attr(755,root,root) %{_libdir}/libscconf.so
156 %attr(755,root,root) %{_libdir}/libscldap.so
157 %{_libdir}/libopensc.la
158 %{_libdir}/libpkcs15init.la
159 %{_libdir}/libscconf.la
160 %{_libdir}/libscldap.la
161 %{_libdir}/libscrandom.a
162 %{_includedir}/opensc
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libopensc.a
167 %{_libdir}/libpkcs15init.a
168 %{_libdir}/libscconf.a
169 %{_libdir}/libscldap.a
170
171 %files -n pam_opensc
172 %defattr(644,root,root,755)
173 %attr(755,root,root) /lib/security/pam_opensc.so
174
175 %files -n mozilla-plugin-opensc
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{mozplugindir}/opensc-signer.so
This page took 0.046657 seconds and 3 git commands to generate.