]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
a29d2ae9f8c1f4addf2a7c6da20c4c1968e9fb53
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl.UTF-8):      Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
3 Name:           opensc
4 Version:        0.11.6
5 Release:        3
6 Epoch:          0
7 License:        LGPL v2.1+
8 Group:          Applications
9 Source0:        http://www.opensc-project.org/files/opensc/%{name}-%{version}.tar.gz
10 # Source0-md5:  a426759f11350c32af2f17a5cd4d5938
11 Source1:        %{name}-initramfs-hook
12 Source2:        %{name}-initramfs-local-bottom
13 Source3:        %{name}-initramfs-local-top
14 Source4:        %{name}-initramfs-README
15 URL:            http://www.opensc-project.org/
16 BuildRequires:  autoconf >= 2.60
17 BuildRequires:  automake >= 1:1.10
18 BuildRequires:  libassuan-devel >= 1:0.6.0
19 BuildRequires:  libltdl-devel
20 BuildRequires:  libtool >= 1:1.4.2-9
21 BuildRequires:  openct-devel
22 BuildRequires:  openldap-devel >= 2.4.6
23 BuildRequires:  openssl-devel >= 0.9.7d
24 BuildRequires:  pkgconfig >= 1:0.9.0
25 BuildRequires:  readline-devel
26 BuildRequires:  rpmbuild(macros) >= 1.364
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # datadir is used for config files and (editable) profiles
31 %define         _datadir        /etc
32 %define         _sysconfdir     /etc/opensc
33
34 %description
35 libopensc is a library for accessing SmartCard devices using PC/SC
36 Lite middleware package. It is also the core library of the OpenSC
37 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
38 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
39 using private keys on the SmartCard is at the moment possible only
40 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
41 IDentity) card manufactured by Setec.
42
43 %description -l pl.UTF-8
44 libopensc to biblioteka do korzystania z kart procesorowych przy
45 użyciu pakietu warstwy pośredniej PC/SC Lite. Jest to także podstawowa
46 biblioteka projektu OpenSC. Podstawowa funkcjonalność (np. SELECT
47 FILE, READ BINARY) powinna działać także z dowolną kartą procesorową
48 zgodną z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy użyciu
49 prywatnych kluczy na karcie na razie jest możliwe tylko przy użyciu
50 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
51 IDentity) produkowanych przez Setec.
52
53 %package devel
54 Summary:        OpenSC development files
55 Summary(pl.UTF-8):      Pliki dla programistów używających OpenSC
56 Group:          Development/Tools
57 Requires:       %{name} = %{epoch}:%{version}-%{release}
58 Requires:       libltdl-devel
59 Requires:       openct-devel
60 Requires:       openssl-devel
61 Requires:       pcsc-lite-devel
62
63 %description devel
64 OpenSC development files.
65
66 %description devel -l pl.UTF-8
67 Pliki dla programistów używających OpenSC.
68
69 %package static
70 Summary:        Static OpenSC libraries
71 Summary(pl.UTF-8):      Bibloteki statyczne OpenSC
72 Group:          Development/Tools
73 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
74
75 %description static
76 Static OpenSC libraries.
77
78 %description static -l pl.UTF-8
79 Statyczne biblioteki OpenSC.
80
81 %package -n browser-plugin-opensc
82 Summary:        OpenSC Signer plugin for Mozilla
83 Summary(pl.UTF-8):      Wtyczka OpenSC Signer dla Mozilli
84 Group:          X11/Applications
85 Requires:       %{name} = %{epoch}:%{version}-%{release}
86 Requires:       browser-plugins >= 2.0
87 Requires:       browser-plugins(%{_target_base_arch})
88 Requires:       pinentry >= 0.7.5-2
89 Provides:       mozilla-plugin-opensc
90 Obsoletes:      mozilla-plugin-opensc
91
92 %description -n browser-plugin-opensc
93 OpenSC Signer browser plugin.
94
95 Supported browsers: %{browsers}.
96
97 %description -n browser-plugin-opensc -l pl.UTF-8
98 Wtyczka OpenSC Signer dla przeglądarek.
99
100 Obsługiwane przeglądarki: %{browsers}.
101
102 %package initramfs
103 Summary:        OpenSC support scripts for initramfs-tools
104 Summary(pl.UTF-8):      Skrypty dla initramfs-tools ze wsparciem dla OpenSC
105 Group:          Base
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       initramfs-tools
108
109 %description initramfs
110 OpenSC support scripts for initramfs-tools.
111
112 %description initramfs -l pl.UTF-8
113 Skrypty dla initramfs-tools ze wsparciem dla OpenSC.
114
115 %prep
116 %setup -q
117
118 install %{SOURCE4} README.initramfs
119
120 %build
121 %{__libtoolize}
122 %{__aclocal} -I m4
123 %{__autoconf}
124 %{__autoheader}
125 %{__automake}
126 %configure \
127         --enable-openct \
128         --enable-nsplugin \
129         --enable-pcsc \
130         --with-pcsc-provider=%{_libdir}/libpcsclite.so.1 \
131         --with-pinentry=/usr/bin/pinentry \
132         --with-plugindir=%{_browserpluginsdir}
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT%{_browserpluginsdir} \
139         $RPM_BUILD_ROOT%{_datadir}initramfs-tools/{hooks,scripts/local-{bottom,top}}
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 # just install instead of symlinking
145 %{__rm} $RPM_BUILD_ROOT%{_browserpluginsdir}/opensc-signer.so
146 mv -f $RPM_BUILD_ROOT%{_libdir}/opensc-signer.so $RPM_BUILD_ROOT%{_browserpluginsdir}
147
148 # default config
149 install etc/opensc.conf $RPM_BUILD_ROOT%{_sysconfdir}
150
151 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}initramfs-tools/hooks/opensc
152 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}initramfs-tools/scripts/local-bottom/opensc
153 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}initramfs-tools/scripts/local-top/opensc
154
155 # useless (dlopened by *.so)
156 rm -f $RPM_BUILD_ROOT%{_libdir}/{onepin-opensc,opensc,pkcs11}-*.{a,la} \
157         $RPM_BUILD_ROOT%{_libdir}/opensc/*.{a,la}
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %post   -n browser-plugin-opensc
166 %update_browser_plugins
167
168 %postun -n browser-plugin-opensc
169 if [ "$1" = "0" ]; then
170         %update_browser_plugins
171 fi
172
173 %files
174 %defattr(644,root,root,755)
175 %doc NEWS README doc/nonpersistent/{ChangeLog,wiki.out} doc/html.out/tools.html
176 %attr(755,root,root) %{_bindir}/cardos-info
177 %attr(755,root,root) %{_bindir}/cryptoflex-tool
178 %attr(755,root,root) %{_bindir}/eidenv
179 %attr(755,root,root) %{_bindir}/netkey-tool
180 %attr(755,root,root) %{_bindir}/opensc-explorer
181 %attr(755,root,root) %{_bindir}/opensc-tool
182 %attr(755,root,root) %{_bindir}/piv-tool
183 %attr(755,root,root) %{_bindir}/pkcs11-tool
184 %attr(755,root,root) %{_bindir}/pkcs15-*
185 %attr(755,root,root) %{_bindir}/rutoken-tool
186 %attr(755,root,root) %{_libdir}/libopensc.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libopensc.so.2
188 %attr(755,root,root) %{_libdir}/libpkcs15init.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libpkcs15init.so.2
190 %attr(755,root,root) %{_libdir}/libscconf.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libscconf.so.2
192 # PKCS11 modules
193 %attr(755,root,root) %{_libdir}/onepin-opensc-pkcs11.so
194 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
195 %attr(755,root,root) %{_libdir}/pkcs11-spy.so
196 %dir %{_libdir}/pkcs11
197 %attr(755,root,root) %{_libdir}/pkcs11/onepin-opensc-pkcs11.so
198 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
199 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
200 %dir %{_datadir}/opensc
201 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
202 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
203 %{_mandir}/man1/cardos-info.1*
204 %{_mandir}/man1/cryptoflex-tool.1*
205 %{_mandir}/man1/netkey-tool.1*
206 %{_mandir}/man1/opensc-explorer.1*
207 %{_mandir}/man1/opensc-tool.1*
208 %{_mandir}/man1/pkcs11-tool.1*
209 %{_mandir}/man1/pkcs15-*.1*
210 %{_mandir}/man5/pkcs15-profile.5*
211
212 %files devel
213 %defattr(644,root,root,755)
214 %doc doc/html.out/api.html
215 %attr(755,root,root) %{_bindir}/opensc-config
216 %attr(755,root,root) %{_libdir}/libopensc.so
217 %attr(755,root,root) %{_libdir}/libpkcs15init.so
218 %attr(755,root,root) %{_libdir}/libscconf.so
219 %{_libdir}/libopensc.la
220 %{_libdir}/libpkcs15init.la
221 %{_libdir}/libscconf.la
222 %{_includedir}/opensc
223 %{_pkgconfigdir}/libopensc.pc
224 %{_pkgconfigdir}/libpkcs15init.pc
225 %{_pkgconfigdir}/libscconf.pc
226 %{_mandir}/man1/opensc-config.1*
227 %{_mandir}/man3/sc_*.3*
228
229 %files static
230 %defattr(644,root,root,755)
231 %{_libdir}/libopensc.a
232 %{_libdir}/libpkcs15init.a
233 %{_libdir}/libscconf.a
234
235 %files -n browser-plugin-opensc
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_browserpluginsdir}/opensc-signer.so
238
239 %files initramfs
240 %defattr(644,root,root,755)
241 %doc README.initramfs
242 %attr(755,root,root) %{_datadir}/initramfs-tools/hooks/opensc
243 %attr(755,root,root) %{_datadir}/initramfs-tools/scripts/local-top/opensc
244 %attr(755,root,root) %{_datadir}/initramfs-tools/scripts/local-bottom/opensc
This page took 0.078407 seconds and 3 git commands to generate.