]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- patched for libassuan 0.6.0
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl):    Biblioteka OpenSC - do korzystania z kart procesorowych przy u¿yciu PC/SC Lite
3 Name:           opensc
4 Version:        0.8.0
5 Release:        1
6 License:        LGPL
7 Group:          Applications
8 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
9 # Source0-md5:  46bb22935040816a0d741b5f76ed4b81
10 Patch0:         %{name}-nolibs.patch
11 Patch1:         %{name}-libdir.patch
12 Patch2:         %{name}-assuan.patch
13 URL:            http://www.opensc.org/
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake
16 BuildRequires:  libassuan-devel >= 1:0.6.0
17 BuildRequires:  libtool >= 1:1.4.2-9
18 BuildRequires:  openldap-devel
19 BuildRequires:  openssl-devel
20 BuildRequires:  pam-devel
21 BuildRequires:  pcsc-lite-devel
22 BuildRequires:  readline-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # datadir is used for config files and (editable) profiles
26 %define         _datadir        %{_sysconfdir}
27 %define         mozplugindir    /usr/lib/mozilla/plugins
28
29 %description
30 libopensc is a library for accessing SmartCard devices using PC/SC
31 Lite middleware package. It is also the core library of the OpenSC
32 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
33 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
34 using private keys on the SmartCard is at the moment possible only
35 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
36 IDentity) card manufactured by Setec.
37
38 %description -l pl
39 libopensc to biblioteka do korzystania z kart procesorowych przy
40 u¿yciu pakietu warstwy po¶redniej PC/SC Lite. Jest to tak¿e podstawowa
41 biblioteka projektu OpenSC. Podstawowa funkcjonalno¶æ (np. SELECT
42 FILE, READ BINARY) powinna dzia³aæ tak¿e z dowoln± kart± procesorow±
43 zgodn± z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy u¿yciu
44 prywatnych kluczy na karcie na razie jest mo¿liwe tylko przy u¿yciu
45 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
46 IDentity) produkowanych przez Setec.
47
48 %package devel
49 Summary:        OpenSC development files
50 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenSC
51 Group:          Development/Tools
52 Requires:       %{name} = %{version}
53
54 %description devel
55 OpenSC development files.
56
57 %description devel -l pl
58 Pliki dla programistów u¿ywaj±cych OpenSC.
59
60 %package static
61 Summary:        Static OpenSC libraries
62 Summary(pl):    Bibloteki statyczne OpenSC
63 Group:          Development/Tools
64 Requires:       %{name}-devel = %{version}
65
66 %description static
67 Static OpenSC libraries.
68
69 %description static -l pl
70 Statyczne biblioteki OpenSC.
71
72 %package -n pam_opensc
73 Summary:        OpenSC module for PAM
74 Summary(pl):    Modu³ PAM OpenSC
75 License:        GPL
76 Group:          Base
77 Requires:       %{name} = %{version}
78
79 %description -n pam_opensc
80 OpenSC module for PAM.
81
82 %description -n pam_opensc -l pl
83 Modu³ PAM OpenSC.
84
85 %package -n mozilla-plugin-opensc
86 Summary:        OpenSC Signer plugin for Mozilla
87 Summary(pl):    Wtyczka OpenSC Signer dla Mozilli
88 # libassuan is GPL
89 License:        GPL
90 Group:          X11/Applications
91 Requires:       %{name} = %{version}
92 Requires:       pinentry-gtk
93
94 %description -n mozilla-plugin-opensc
95 OpenSC Signer plugin for Mozilla.
96
97 %description -n mozilla-plugin-opensc -l pl
98 Wtyczka OpenSC Signer dla Mozilli.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105
106 %build
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoconf}
110 %{__automake}
111 %configure \
112         --with-pin-entry=/usr/bin/pinentry-gtk \
113         --with-plugin-dir="%{mozplugindir}"
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT%{mozplugindir}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install -d $RPM_BUILD_ROOT/lib
125 mv -f $RPM_BUILD_ROOT%{_libdir}/security $RPM_BUILD_ROOT/lib
126
127 # just install instead of symlinking
128 rm -f $RPM_BUILD_ROOT%{mozplugindir}/opensc-signer.so
129 mv -f $RPM_BUILD_ROOT%{_libdir}/opensc/opensc-signer.so $RPM_BUILD_ROOT%{mozplugindir}
130
131 # default config
132 mv -f $RPM_BUILD_ROOT%{_datadir}/opensc/opensc.conf{.example,}
133 mv -f $RPM_BUILD_ROOT%{_datadir}/opensc/scldap.conf{.example,}
134
135 # useless (dlopened by *.so)
136 rm -f $RPM_BUILD_ROOT%{_libdir}/libscam.{a,la} \
137         $RPM_BUILD_ROOT%{_libdir}/opensc/opensc-signer.{a,la} \
138         $RPM_BUILD_ROOT%{_libdir}/pkcs11/opensc-pkcs11.{a,la} \
139         $RPM_BUILD_ROOT/lib/security/pam_opensc.{a,la}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc ANNOUNCE ChangeLog NEWS docs/{pkcs-15v1_1.asn,opensc.{html,css}}
150 %attr(755,root,root) %{_bindir}/cardos-info
151 %attr(755,root,root) %{_bindir}/cryptoflex-tool
152 %attr(755,root,root) %{_bindir}/opensc-explorer
153 %attr(755,root,root) %{_bindir}/opensc-tool
154 %attr(755,root,root) %{_bindir}/pkcs11-tool
155 %attr(755,root,root) %{_bindir}/pkcs15-*
156 %attr(755,root,root) %{_libdir}/lib*.so.*.*
157 %attr(755,root,root) %{_libdir}/libscam.so
158 %dir %{_libdir}/pkcs11
159 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
160 %dir %{_datadir}/opensc
161 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.conf
162 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.profile
163 %{_mandir}/man1/cryptoflex-tool.1*
164 %{_mandir}/man1/opensc-explorer.1*
165 %{_mandir}/man1/opensc-tool.1*
166 %{_mandir}/man1/pkcs15*
167 %{_mandir}/man[57]/*
168
169 %files devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/opensc-config
172 %attr(755,root,root) %{_libdir}/libopensc.so
173 %attr(755,root,root) %{_libdir}/libpkcs15init.so
174 %attr(755,root,root) %{_libdir}/libscconf.so
175 %attr(755,root,root) %{_libdir}/libscldap.so
176 %{_libdir}/lib*.la
177 %{_includedir}/opensc
178 %{_pkgconfigdir}/*.pc
179 %{_mandir}/man1/opensc-config.1*
180 %{_mandir}/man3/*
181
182 %files static
183 %defattr(644,root,root,755)
184 %{_libdir}/lib*.a
185
186 %files -n pam_opensc
187 %defattr(644,root,root,755)
188 %attr(755,root,root) /lib/security/pam_opensc.so
189
190 %files -n mozilla-plugin-opensc
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{mozplugindir}/opensc-signer.so
This page took 0.068967 seconds and 3 git commands to generate.