]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- another one
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl):    Biblioteka OpenSC - do korzystania z kart procesorowych przy u¿yciu PC/SC Lite
3 Name:           opensc
4 Version:        0.8.1
5 Release:        4
6 Epoch:          0
7 License:        LGPL
8 Group:          Applications
9 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
10 # Source0-md5:  2b64a8e629bd28a00e707e35fd3eb9c7
11 Patch0:         %{name}-libdir.patch
12 Patch1:         %{name}-shared-ssl.patch
13 URL:            http://www.opensc.org/
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake
16 BuildRequires:  libassuan-devel >= 1:0.6.0
17 BuildRequires:  libtool >= 1:1.4.2-9
18 BuildRequires:  openldap-devel
19 BuildRequires:  openssl-devel >= 0.9.7d
20 BuildRequires:  openct-devel
21 BuildRequires:  pam-devel
22 BuildRequires:  pcsc-lite-devel
23 BuildRequires:  readline-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # datadir is used for config files and (editable) profiles
27 %define         _datadir        /etc
28 %define         _sysconfdir     /etc/opensc
29 %define         mozplugindir    /usr/%{_lib}/mozilla/plugins
30
31 %description
32 libopensc is a library for accessing SmartCard devices using PC/SC
33 Lite middleware package. It is also the core library of the OpenSC
34 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
35 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
36 using private keys on the SmartCard is at the moment possible only
37 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
38 IDentity) card manufactured by Setec.
39
40 %description -l pl
41 libopensc to biblioteka do korzystania z kart procesorowych przy
42 u¿yciu pakietu warstwy po¶redniej PC/SC Lite. Jest to tak¿e podstawowa
43 biblioteka projektu OpenSC. Podstawowa funkcjonalno¶æ (np. SELECT
44 FILE, READ BINARY) powinna dzia³aæ tak¿e z dowoln± kart± procesorow±
45 zgodn± z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy u¿yciu
46 prywatnych kluczy na karcie na razie jest mo¿liwe tylko przy u¿yciu
47 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
48 IDentity) produkowanych przez Setec.
49
50 %package devel
51 Summary:        OpenSC development files
52 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenSC
53 Group:          Development/Tools
54 Requires:       %{name} = %{epoch}:%{version}-%{release}
55 Requires:       openct-devel
56 Requires:       openssl-devel
57 Requires:       pcsc-lite-devel
58
59 %description devel
60 OpenSC development files.
61
62 %description devel -l pl
63 Pliki dla programistów u¿ywaj±cych OpenSC.
64
65 %package static
66 Summary:        Static OpenSC libraries
67 Summary(pl):    Bibloteki statyczne OpenSC
68 Group:          Development/Tools
69 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
70
71 %description static
72 Static OpenSC libraries.
73
74 %description static -l pl
75 Statyczne biblioteki OpenSC.
76
77 %package -n pam-pam_opensc
78 Summary:        OpenSC module for PAM
79 Summary(pl):    Modu³ PAM OpenSC
80 License:        GPL
81 Group:          Base
82 Requires:       %{name} = %{epoch}:%{version}-%{release}
83 Obsoletes:      pam_opensc
84
85 %description -n pam-pam_opensc
86 OpenSC module for PAM.
87
88 %description -n pam-pam_opensc -l pl
89 Modu³ PAM OpenSC.
90
91 %package -n mozilla-plugin-opensc
92 Summary:        OpenSC Signer plugin for Mozilla
93 Summary(pl):    Wtyczka OpenSC Signer dla Mozilli
94 # libassuan is GPL
95 License:        GPL
96 Group:          X11/Applications
97 Requires:       %{name} = %{epoch}:%{version}-%{release}
98 Requires:       pinentry-gtk
99
100 %description -n mozilla-plugin-opensc
101 OpenSC Signer plugin for Mozilla.
102
103 %description -n mozilla-plugin-opensc -l pl
104 Wtyczka OpenSC Signer dla Mozilli.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110
111 %build
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         --with-pin-entry=/usr/bin/pinentry-gtk \
119         --with-plugin-dir="%{mozplugindir}"
120
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT%{mozplugindir}
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 install -d $RPM_BUILD_ROOT/%{_lib}
131 mv -f $RPM_BUILD_ROOT%{_libdir}/security $RPM_BUILD_ROOT/%{_lib}
132
133 # just install instead of symlinking
134 rm -f $RPM_BUILD_ROOT%{mozplugindir}/opensc-signer.so
135 mv -f $RPM_BUILD_ROOT%{_libdir}/opensc/opensc-signer.so $RPM_BUILD_ROOT%{mozplugindir}
136
137 # default config
138 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/opensc.conf{.example,}
139 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/scldap.conf{.example,}
140
141 # useless (dlopened by *.so)
142 rm -f $RPM_BUILD_ROOT%{_libdir}/libscam.{a,la} \
143         $RPM_BUILD_ROOT%{_libdir}/opensc/*.{a,la} \
144         $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.{a,la} \
145         $RPM_BUILD_ROOT/%{_lib}/security/pam_opensc.{a,la}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc ANNOUNCE ChangeLog NEWS docs/{pkcs-15v1_1.asn,opensc.{html,css}}
156 %attr(755,root,root) %{_bindir}/cardos-info
157 %attr(755,root,root) %{_bindir}/cryptoflex-tool
158 %attr(755,root,root) %{_bindir}/opensc-explorer
159 %attr(755,root,root) %{_bindir}/opensc-tool
160 %attr(755,root,root) %{_bindir}/pkcs11-tool
161 %attr(755,root,root) %{_bindir}/pkcs15-*
162 %attr(755,root,root) %{_libdir}/lib*.so.*.*
163 %attr(755,root,root) %{_libdir}/libscam.so
164 %dir %{_libdir}/pkcs11
165 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
166 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
167 %dir %{_libdir}/opensc
168 %attr(755,root,root) %{_libdir}/opensc/engine_opensc.so
169 %attr(755,root,root) %{_libdir}/opensc/engine_pkcs11.so
170 %dir %{_datadir}/opensc
171 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.conf
172 %config(noreplace) %verify(not size mtime md5) %{_datadir}/opensc/*.profile
173 %{_mandir}/man1/cryptoflex-tool.1*
174 %{_mandir}/man1/opensc-explorer.1*
175 %{_mandir}/man1/opensc-tool.1*
176 %{_mandir}/man1/pkcs15*
177 %{_mandir}/man[57]/*
178
179 %files devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_bindir}/opensc-config
182 %attr(755,root,root) %{_libdir}/libopensc.so
183 %attr(755,root,root) %{_libdir}/libpkcs11.so
184 %attr(755,root,root) %{_libdir}/libpkcs15init.so
185 %attr(755,root,root) %{_libdir}/libscconf.so
186 %attr(755,root,root) %{_libdir}/libscldap.so
187 %{_libdir}/lib*.la
188 %{_includedir}/opensc
189 %{_pkgconfigdir}/*.pc
190 %{_mandir}/man1/opensc-config.1*
191 %{_mandir}/man3/*
192
193 %files static
194 %defattr(644,root,root,755)
195 %{_libdir}/lib*.a
196
197 %files -n pam-pam_opensc
198 %defattr(644,root,root,755)
199 %attr(755,root,root) /%{_lib}/security/pam_opensc.so
200
201 %files -n mozilla-plugin-opensc
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{mozplugindir}/opensc-signer.so
This page took 0.060636 seconds and 3 git commands to generate.