]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
3572fa41e67035e3889582aae1caafc538d21adc
[packages/opensc.git] / opensc.spec
1 #
2 # Conditional build:
3 %bcond_with     openct  # use OpenCT instead of PC/SC for reader access
4 #
5 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
6 Summary(pl.UTF-8):      Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
7 Name:           opensc
8 Version:        0.13.0
9 Release:        1
10 Epoch:          0
11 License:        LGPL v2.1+
12 Group:          Applications
13 Source0:        http://downloads.sourceforge.net/opensc/%{name}-%{version}.tar.gz
14 # Source0-md5:  74a10de6c646bdaae307d6dc9e9accc0
15 Patch0:         %{name}-pc.patch
16 URL:            https://github.com/OpenSC/OpenSC/wiki
17 BuildRequires:  autoconf >= 2.60
18 BuildRequires:  automake >= 1:1.10
19 BuildRequires:  docbook-style-xsl
20 BuildRequires:  libltdl-devel
21 BuildRequires:  libtool >= 1:1.4.2-9
22 BuildRequires:  libxslt-progs
23 %{?with_openct:BuildRequires:   openct-devel}
24 BuildRequires:  openssl-devel >= 0.9.7d
25 %{!?with_openct:BuildRequires:  pcsc-lite-devel >= 1.6.0}
26 BuildRequires:  pkgconfig >= 1:0.9.0
27 BuildRequires:  readline-devel
28 BuildRequires:  rpmbuild(macros) >= 1.364
29 BuildRequires:  zlib-devel
30 Requires:       filesystem >= 4.0-28
31 %{!?with_openct:Requires:       pcsc-lite-libs >= 1.6.0}
32 Obsoletes:      browser-plugin-opensc
33 Obsoletes:      mozilla-plugin-opensc
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 # datadir is used for config files and (editable) profiles
37 %define         _datadir        /etc
38 %define         _sysconfdir     /etc/opensc
39
40 %description
41 libopensc is a library for accessing SmartCard devices using PC/SC
42 Lite middleware package. It is also the core library of the OpenSC
43 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
44 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
45 using private keys on the SmartCard is at the moment possible only
46 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
47 IDentity) card manufactured by Setec.
48
49 %description -l pl.UTF-8
50 libopensc to biblioteka do korzystania z kart procesorowych przy
51 użyciu pakietu warstwy pośredniej PC/SC Lite. Jest to także podstawowa
52 biblioteka projektu OpenSC. Podstawowa funkcjonalność (np. SELECT
53 FILE, READ BINARY) powinna działać także z dowolną kartą procesorową
54 zgodną z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy użyciu
55 prywatnych kluczy na karcie na razie jest możliwe tylko przy użyciu
56 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
57 IDentity) produkowanych przez Setec.
58
59 %package devel
60 Summary:        OpenSC development files
61 Summary(pl.UTF-8):      Pliki dla programistów używających OpenSC
62 Group:          Development/Tools
63 Requires:       %{name} = %{epoch}:%{version}-%{release}
64 Requires:       libltdl-devel
65 %{?with_openct:Requires:        openct-devel}
66 Requires:       openssl-devel
67 %{!?with_openct:Requires:       pcsc-lite-devel >= 1.6.0}
68
69 %description devel
70 OpenSC development files.
71
72 %description devel -l pl.UTF-8
73 Pliki dla programistów używających OpenSC.
74
75 %package static
76 Summary:        Static OpenSC library
77 Summary(pl.UTF-8):      Bibloteka statyczna OpenSC
78 Group:          Development/Tools
79 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
80
81 %description static
82 Static OpenSC library.
83
84 %description static -l pl.UTF-8
85 Biblioteka statyczna OpenSC.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90
91 %build
92 %{__libtoolize}
93 %{__aclocal} -I m4
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 %configure \
98         %{?with_openct:--enable-openct --disable-pcsc} \
99         %{!?with_openct:--enable-pcsc --disable-openct} \
100         --disable-silent-rules \
101         --enable-doc \
102         --with-pcsc-provider=%{_libdir}/libpcsclite.so.1
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_libdir}/pkcs11}
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 # not needed (dlopened by soname)
114 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{opensc-pkcs11,pkcs11-spy}.la
115 # obsoleted by pkg-config
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libopensc.la
117
118 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc ChangeLog NEWS README doc/tools/tools.html
129 %attr(755,root,root) %{_bindir}/cardos-tool
130 %attr(755,root,root) %{_bindir}/cryptoflex-tool
131 %attr(755,root,root) %{_bindir}/eidenv
132 %attr(755,root,root) %{_bindir}/iasecc-tool
133 %attr(755,root,root) %{_bindir}/netkey-tool
134 %attr(755,root,root) %{_bindir}/openpgp-tool
135 %attr(755,root,root) %{_bindir}/opensc-explorer
136 %attr(755,root,root) %{_bindir}/opensc-tool
137 %attr(755,root,root) %{_bindir}/piv-tool
138 %attr(755,root,root) %{_bindir}/pkcs11-tool
139 %attr(755,root,root) %{_bindir}/pkcs15-crypt
140 %attr(755,root,root) %{_bindir}/pkcs15-init
141 %attr(755,root,root) %{_bindir}/pkcs15-tool
142 %attr(755,root,root) %{_bindir}/sc-hsm-tool
143 %attr(755,root,root) %{_bindir}/westcos-tool
144 %attr(755,root,root) %{_libdir}/libopensc.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libopensc.so.3
146 # PKCS11 modules
147 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
148 %attr(755,root,root) %{_libdir}/pkcs11-spy.so
149 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
150 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
151 %dir %{_datadir}/opensc
152 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opensc.conf
153 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
154 %{_mandir}/man1/cardos-tool.1*
155 %{_mandir}/man1/cryptoflex-tool.1*
156 %{_mandir}/man1/eidenv.1*
157 %{_mandir}/man1/iasecc-tool.1*
158 %{_mandir}/man1/netkey-tool.1*
159 %{_mandir}/man1/openpgp-tool.1*
160 %{_mandir}/man1/opensc-explorer.1*
161 %{_mandir}/man1/opensc-tool.1*
162 %{_mandir}/man1/piv-tool.1*
163 %{_mandir}/man1/pkcs11-tool.1*
164 %{_mandir}/man1/pkcs15-crypt.1*
165 %{_mandir}/man1/pkcs15-init.1*
166 %{_mandir}/man1/pkcs15-tool.1*
167 %{_mandir}/man1/sc-hsm-tool.1*
168 %{_mandir}/man1/westcos-tool.1*
169 %{_mandir}/man5/pkcs15-profile.5*
170
171 %files devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libopensc.so
174 %{_pkgconfigdir}/libopensc.pc
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libopensc.a
This page took 0.031783 seconds and 2 git commands to generate.