]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
- updated to 0.10.0 (note: new soname, engines and pam module separated)
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl):    Biblioteka OpenSC - do korzystania z kart procesorowych przy u¿yciu PC/SC Lite
3 Name:           opensc
4 Version:        0.10.0
5 Release:        1
6 Epoch:          0
7 License:        LGPL
8 Group:          Applications
9 Source0:        http://www.opensc.org/files/%{name}-%{version}.tar.gz
10 # Source0-md5:  d25271140776df94ada13f45dad34996
11 Patch0:         %{name}-explorer-debug.patch
12 Patch1:         %{name}-libassuan.patch
13 URL:            http://www.opensc.org/
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake
16 BuildRequires:  libassuan-devel >= 1:0.6.0
17 BuildRequires:  libltdl-devel
18 BuildRequires:  libtool >= 1:1.4.2-9
19 BuildRequires:  openldap-devel
20 BuildRequires:  openssl-devel >= 0.9.7d
21 BuildRequires:  openct-devel
22 BuildRequires:  pcsc-lite-devel
23 BuildRequires:  pkgconfig >= 1:0.9.0
24 BuildRequires:  readline-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # datadir is used for config files and (editable) profiles
28 %define         _datadir        /etc
29 %define         _sysconfdir     /etc/opensc
30 %define         mozplugindir    /usr/%{_lib}/mozilla/plugins
31
32 %description
33 libopensc is a library for accessing SmartCard devices using PC/SC
34 Lite middleware package. It is also the core library of the OpenSC
35 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
36 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
37 using private keys on the SmartCard is at the moment possible only
38 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
39 IDentity) card manufactured by Setec.
40
41 %description -l pl
42 libopensc to biblioteka do korzystania z kart procesorowych przy
43 u¿yciu pakietu warstwy po¶redniej PC/SC Lite. Jest to tak¿e podstawowa
44 biblioteka projektu OpenSC. Podstawowa funkcjonalno¶æ (np. SELECT
45 FILE, READ BINARY) powinna dzia³aæ tak¿e z dowoln± kart± procesorow±
46 zgodn± z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy u¿yciu
47 prywatnych kluczy na karcie na razie jest mo¿liwe tylko przy u¿yciu
48 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
49 IDentity) produkowanych przez Setec.
50
51 %package devel
52 Summary:        OpenSC development files
53 Summary(pl):    Pliki dla programistów u¿ywaj±cych OpenSC
54 Group:          Development/Tools
55 Requires:       %{name} = %{epoch}:%{version}-%{release}
56 Requires:       openct-devel
57 Requires:       openssl-devel
58 Requires:       pcsc-lite-devel
59
60 %description devel
61 OpenSC development files.
62
63 %description devel -l pl
64 Pliki dla programistów u¿ywaj±cych OpenSC.
65
66 %package static
67 Summary:        Static OpenSC libraries
68 Summary(pl):    Bibloteki statyczne OpenSC
69 Group:          Development/Tools
70 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
71
72 %description static
73 Static OpenSC libraries.
74
75 %description static -l pl
76 Statyczne biblioteki OpenSC.
77
78 %package -n mozilla-plugin-opensc
79 Summary:        OpenSC Signer plugin for Mozilla
80 Summary(pl):    Wtyczka OpenSC Signer dla Mozilli
81 Group:          X11/Applications
82 Requires:       %{name} = %{epoch}:%{version}-%{release}
83 Requires:       pinentry-gtk
84
85 %description -n mozilla-plugin-opensc
86 OpenSC Signer plugin for Mozilla.
87
88 %description -n mozilla-plugin-opensc -l pl
89 Wtyczka OpenSC Signer dla Mozilli.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95
96 %build
97 %{__libtoolize}
98 %{__aclocal} -I aclocal
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         --with-pin-entry=/usr/bin/pinentry-gtk \
104         --with-plugin-dir="%{mozplugindir}"
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{mozplugindir}
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 # just install instead of symlinking
116 rm -f $RPM_BUILD_ROOT%{mozplugindir}/opensc-signer.so
117 mv -f $RPM_BUILD_ROOT%{_libdir}/opensc/opensc-signer.so $RPM_BUILD_ROOT%{mozplugindir}
118
119 # default config
120 install etc/opensc.conf $RPM_BUILD_ROOT%{_sysconfdir}
121
122 # useless (dlopened by *.so)
123 rm -f $RPM_BUILD_ROOT%{_libdir}/{opensc,pkcs11}-*.{a,la} \
124         $RPM_BUILD_ROOT%{_libdir}/opensc/*.{a,la}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc NEWS README doc/{*.{html,css},html/tools.html}
135 %attr(755,root,root) %{_bindir}/cardos-info
136 %attr(755,root,root) %{_bindir}/cryptoflex-tool
137 %attr(755,root,root) %{_bindir}/eidenv
138 %attr(755,root,root) %{_bindir}/netkey-tool
139 %attr(755,root,root) %{_bindir}/opensc-explorer
140 %attr(755,root,root) %{_bindir}/opensc-tool
141 %attr(755,root,root) %{_bindir}/pkcs11-tool
142 %attr(755,root,root) %{_bindir}/pkcs15-*
143 %attr(755,root,root) %{_libdir}/lib*.so.*.*
144 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
145 %attr(755,root,root) %{_libdir}/pkcs11-spy.so
146 %dir %{_datadir}/opensc
147 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
148 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
149 %{_mandir}/man1/cardos-info.1*
150 %{_mandir}/man1/cryptoflex-tool.1*
151 %{_mandir}/man1/netkey-tool.1*
152 %{_mandir}/man1/opensc-explorer.1*
153 %{_mandir}/man1/opensc-tool.1*
154 %{_mandir}/man1/pkcs11-tool.1*
155 %{_mandir}/man1/pkcs15-*.1*
156 %{_mandir}/man[57]/*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %doc doc/html/api.html
161 %attr(755,root,root) %{_bindir}/opensc-config
162 %attr(755,root,root) %{_libdir}/libopensc.so
163 %attr(755,root,root) %{_libdir}/libpkcs15init.so
164 %attr(755,root,root) %{_libdir}/libscconf.so
165 %{_libdir}/libopensc.la
166 %{_libdir}/libpkcs15init.la
167 %{_libdir}/libscconf.la
168 %{_includedir}/opensc
169 %{_pkgconfigdir}/*.pc
170 %{_mandir}/man1/opensc-config.1*
171 %{_mandir}/man3/*
172
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/libopensc.a
176 %{_libdir}/libpkcs15init.a
177 %{_libdir}/libscconf.a
178
179 %files -n mozilla-plugin-opensc
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{mozplugindir}/opensc-signer.so
This page took 0.056139 seconds and 3 git commands to generate.