]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
0dad630e2ad029ce39ea9f914b3554b5b48d7389
[packages/opensc.git] / opensc.spec
1 #
2 # Conditional build:
3 %bcond_with     openct  # use OpenCT instead of PC/SC for reader access
4 #
5 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
6 Summary(pl.UTF-8):      Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
7 Name:           opensc
8 Version:        0.14.0
9 Release:        1
10 Epoch:          0
11 License:        LGPL v2.1+
12 Group:          Applications
13 Source0:        http://downloads.sourceforge.net/opensc/%{name}-%{version}.tar.gz
14 # Source0-md5:  8e99885dbe28a9c71d5140f0105c56ff
15 Patch0:         %{name}-pc.patch
16 URL:            https://github.com/OpenSC/OpenSC/wiki
17 BuildRequires:  autoconf >= 2.60
18 BuildRequires:  automake >= 1:1.10
19 BuildRequires:  docbook-style-xsl
20 BuildRequires:  libltdl-devel
21 BuildRequires:  libtool >= 1:1.4.2-9
22 BuildRequires:  libxslt-progs
23 %{?with_openct:BuildRequires:   openct-devel}
24 BuildRequires:  openssl-devel >= 0.9.7d
25 %{!?with_openct:BuildRequires:  pcsc-lite-devel >= 1.6.0}
26 BuildRequires:  pkgconfig >= 1:0.9.0
27 BuildRequires:  readline-devel
28 BuildRequires:  rpmbuild(macros) >= 1.364
29 BuildRequires:  zlib-devel
30 Requires:       filesystem >= 4.0-28
31 %{!?with_openct:Requires:       pcsc-lite-libs >= 1.6.0}
32 Obsoletes:      browser-plugin-opensc
33 Obsoletes:      mozilla-plugin-opensc
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 # datadir is used for config files and (editable) profiles
37 %define         _datadir        /etc
38 %define         _sysconfdir     /etc/opensc
39
40 %description
41 libopensc is a library for accessing SmartCard devices using PC/SC
42 Lite middleware package. It is also the core library of the OpenSC
43 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
44 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
45 using private keys on the SmartCard is at the moment possible only
46 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
47 IDentity) card manufactured by Setec.
48
49 %description -l pl.UTF-8
50 libopensc to biblioteka do korzystania z kart procesorowych przy
51 użyciu pakietu warstwy pośredniej PC/SC Lite. Jest to także podstawowa
52 biblioteka projektu OpenSC. Podstawowa funkcjonalność (np. SELECT
53 FILE, READ BINARY) powinna działać także z dowolną kartą procesorową
54 zgodną z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy użyciu
55 prywatnych kluczy na karcie na razie jest możliwe tylko przy użyciu
56 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
57 IDentity) produkowanych przez Setec.
58
59 %package devel
60 Summary:        OpenSC development files
61 Summary(pl.UTF-8):      Pliki dla programistów używających OpenSC
62 Group:          Development/Tools
63 Requires:       %{name} = %{epoch}:%{version}-%{release}
64 Requires:       libltdl-devel
65 %{?with_openct:Requires:        openct-devel}
66 Requires:       openssl-devel >= 0.9.7d
67 %{!?with_openct:Requires:       pcsc-lite-devel >= 1.6.0}
68 Requires:       zlib-devel
69
70 %description devel
71 OpenSC development files.
72
73 %description devel -l pl.UTF-8
74 Pliki dla programistów używających OpenSC.
75
76 %package static
77 Summary:        Static OpenSC library
78 Summary(pl.UTF-8):      Bibloteka statyczna OpenSC
79 Group:          Development/Tools
80 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
81
82 %description static
83 Static OpenSC library.
84
85 %description static -l pl.UTF-8
86 Biblioteka statyczna OpenSC.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         %{?with_openct:--enable-openct --disable-pcsc} \
100         %{!?with_openct:--enable-pcsc --disable-openct} \
101         --disable-silent-rules \
102         --enable-doc \
103         --with-pcsc-provider=%{_libdir}/libpcsclite.so.1
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_libdir}/pkcs11}
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 # not needed (dlopened by soname)
115 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{onepin-opensc-pkcs11,opensc-pkcs11,pkcs11-spy}.la
116 # obsoleted by pkg-config
117 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{opensc,smm-local}.la
118
119 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc ChangeLog NEWS README doc/tools/tools.html
130 %attr(755,root,root) %{_bindir}/cardos-tool
131 %attr(755,root,root) %{_bindir}/cryptoflex-tool
132 %attr(755,root,root) %{_bindir}/dnie-tool
133 %attr(755,root,root) %{_bindir}/eidenv
134 %attr(755,root,root) %{_bindir}/iasecc-tool
135 %attr(755,root,root) %{_bindir}/netkey-tool
136 %attr(755,root,root) %{_bindir}/openpgp-tool
137 %attr(755,root,root) %{_bindir}/opensc-explorer
138 %attr(755,root,root) %{_bindir}/opensc-tool
139 %attr(755,root,root) %{_bindir}/piv-tool
140 %attr(755,root,root) %{_bindir}/pkcs11-tool
141 %attr(755,root,root) %{_bindir}/pkcs15-crypt
142 %attr(755,root,root) %{_bindir}/pkcs15-init
143 %attr(755,root,root) %{_bindir}/pkcs15-tool
144 %attr(755,root,root) %{_bindir}/sc-hsm-tool
145 %attr(755,root,root) %{_bindir}/westcos-tool
146 %attr(755,root,root) %{_libdir}/libopensc.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libopensc.so.3
148 %attr(755,root,root) %{_libdir}/libsmm-local.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/libsmm-local.so.3
150 # PKCS11 modules
151 %attr(755,root,root) %{_libdir}/onepin-opensc-pkcs11.so
152 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
153 %attr(755,root,root) %{_libdir}/pkcs11-spy.so
154 %attr(755,root,root) %{_libdir}/pkcs11/onepin-opensc-pkcs11.so
155 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
156 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
157 %dir %{_datadir}/opensc
158 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opensc.conf
159 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
160 %{_mandir}/man1/cardos-tool.1*
161 %{_mandir}/man1/cryptoflex-tool.1*
162 %{_mandir}/man1/eidenv.1*
163 %{_mandir}/man1/iasecc-tool.1*
164 %{_mandir}/man1/netkey-tool.1*
165 %{_mandir}/man1/openpgp-tool.1*
166 %{_mandir}/man1/opensc-explorer.1*
167 %{_mandir}/man1/opensc-tool.1*
168 %{_mandir}/man1/piv-tool.1*
169 %{_mandir}/man1/pkcs11-tool.1*
170 %{_mandir}/man1/pkcs15-crypt.1*
171 %{_mandir}/man1/pkcs15-init.1*
172 %{_mandir}/man1/pkcs15-tool.1*
173 %{_mandir}/man1/sc-hsm-tool.1*
174 %{_mandir}/man1/westcos-tool.1*
175 %{_mandir}/man5/pkcs15-profile.5*
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libopensc.so
180 %attr(755,root,root) %{_libdir}/libsmm-local.so
181 %{_pkgconfigdir}/libopensc.pc
182
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/libopensc.a
186 %{_libdir}/libsmm-local.a
This page took 0.043896 seconds and 2 git commands to generate.