]> git.pld-linux.org Git - packages/opensc.git/blob - opensc.spec
09e34af38613b9db160efa6c293d65d6f4dcebc0
[packages/opensc.git] / opensc.spec
1 Summary:        OpenSC library - for accessing SmartCard devices using PC/SC Lite
2 Summary(pl.UTF-8):      Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
3 Name:           opensc
4 Version:        0.11.6
5 Release:        2
6 Epoch:          0
7 License:        LGPL v2.1+
8 Group:          Applications
9 Source0:        http://www.opensc-project.org/files/opensc/%{name}-%{version}.tar.gz
10 # Source0-md5:  a426759f11350c32af2f17a5cd4d5938
11 Source1:        %{name}-initramfs-hook
12 Source2:        %{name}-initramfs-local-bottom
13 Source3:        %{name}-initramfs-local-top
14 Source4:        %{name}-initramfs-README
15 URL:            http://www.opensc-project.org/
16 BuildRequires:  autoconf >= 2.60
17 BuildRequires:  automake >= 1:1.10
18 BuildRequires:  libassuan-devel >= 1:0.6.0
19 BuildRequires:  libltdl-devel
20 BuildRequires:  libtool >= 1:1.4.2-9
21 BuildRequires:  openct-devel
22 BuildRequires:  openldap-devel >= 2.4.6
23 BuildRequires:  openssl-devel >= 0.9.7d
24 BuildRequires:  pkgconfig >= 1:0.9.0
25 BuildRequires:  readline-devel
26 BuildRequires:  rpmbuild(macros) >= 1.364
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # datadir is used for config files and (editable) profiles
31 %define         _datadir        /etc
32 %define         _sysconfdir     /etc/opensc
33
34 %description
35 libopensc is a library for accessing SmartCard devices using PC/SC
36 Lite middleware package. It is also the core library of the OpenSC
37 project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
38 work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
39 using private keys on the SmartCard is at the moment possible only
40 with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
41 IDentity) card manufactured by Setec.
42
43 %description -l pl.UTF-8
44 libopensc to biblioteka do korzystania z kart procesorowych przy
45 użyciu pakietu warstwy pośredniej PC/SC Lite. Jest to także podstawowa
46 biblioteka projektu OpenSC. Podstawowa funkcjonalność (np. SELECT
47 FILE, READ BINARY) powinna działać także z dowolną kartą procesorową
48 zgodną z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy użyciu
49 prywatnych kluczy na karcie na razie jest możliwe tylko przy użyciu
50 kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
51 IDentity) produkowanych przez Setec.
52
53 %package devel
54 Summary:        OpenSC development files
55 Summary(pl.UTF-8):      Pliki dla programistów używających OpenSC
56 Group:          Development/Tools
57 Requires:       %{name} = %{epoch}:%{version}-%{release}
58 Requires:       libltdl-devel
59 Requires:       openct-devel
60 Requires:       openssl-devel
61 Requires:       pcsc-lite-devel
62
63 %description devel
64 OpenSC development files.
65
66 %description devel -l pl.UTF-8
67 Pliki dla programistów używających OpenSC.
68
69 %package static
70 Summary:        Static OpenSC libraries
71 Summary(pl.UTF-8):      Bibloteki statyczne OpenSC
72 Group:          Development/Tools
73 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
74
75 %description static
76 Static OpenSC libraries.
77
78 %description static -l pl.UTF-8
79 Statyczne biblioteki OpenSC.
80
81 %package -n browser-plugin-opensc
82 Summary:        OpenSC Signer plugin for Mozilla
83 Summary(pl.UTF-8):      Wtyczka OpenSC Signer dla Mozilli
84 Group:          X11/Applications
85 Requires:       %{name} = %{epoch}:%{version}-%{release}
86 Requires:       browser-plugins >= 2.0
87 Requires:       browser-plugins(%{_target_base_arch})
88 Requires:       pinentry >= 0.7.5-2
89 Provides:       mozilla-plugin-opensc
90 Obsoletes:      mozilla-plugin-opensc
91
92 %description -n browser-plugin-opensc
93 OpenSC Signer browser plugin.
94
95 Supported browsers: %{browsers}.
96
97 %description -n browser-plugin-opensc -l pl.UTF-8
98 Wtyczka OpenSC Signer dla przeglądarek.
99
100 Obsługiwane przeglądarki: %{browsers}.
101
102 %prep
103 %setup -q
104
105 %build
106 %{__libtoolize}
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --enable-openct \
113         --enable-nsplugin \
114         --enable-pcsc \
115         --with-pcsc-provider=%{_libdir}/libpcsclite.so.1 \
116         --with-pinentry=/usr/bin/pinentry \
117         --with-plugindir=%{_browserpluginsdir}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT%{_browserpluginsdir}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 # just install instead of symlinking
129 %{__rm} $RPM_BUILD_ROOT%{_browserpluginsdir}/opensc-signer.so
130 mv -f $RPM_BUILD_ROOT%{_libdir}/opensc-signer.so $RPM_BUILD_ROOT%{_browserpluginsdir}
131
132 # default config
133 install etc/opensc.conf $RPM_BUILD_ROOT%{_sysconfdir}
134
135 # useless (dlopened by *.so)
136 rm -f $RPM_BUILD_ROOT%{_libdir}/{onepin-opensc,opensc,pkcs11}-*.{a,la} \
137         $RPM_BUILD_ROOT%{_libdir}/opensc/*.{a,la}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %post   -n browser-plugin-opensc
146 %update_browser_plugins
147
148 %postun -n browser-plugin-opensc
149 if [ "$1" = "0" ]; then
150         %update_browser_plugins
151 fi
152
153 %files
154 %defattr(644,root,root,755)
155 %doc NEWS README doc/nonpersistent/{ChangeLog,wiki.out} doc/html.out/tools.html
156 %attr(755,root,root) %{_bindir}/cardos-info
157 %attr(755,root,root) %{_bindir}/cryptoflex-tool
158 %attr(755,root,root) %{_bindir}/eidenv
159 %attr(755,root,root) %{_bindir}/netkey-tool
160 %attr(755,root,root) %{_bindir}/opensc-explorer
161 %attr(755,root,root) %{_bindir}/opensc-tool
162 %attr(755,root,root) %{_bindir}/piv-tool
163 %attr(755,root,root) %{_bindir}/pkcs11-tool
164 %attr(755,root,root) %{_bindir}/pkcs15-*
165 %attr(755,root,root) %{_bindir}/rutoken-tool
166 %attr(755,root,root) %{_libdir}/libopensc.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libopensc.so.2
168 %attr(755,root,root) %{_libdir}/libpkcs15init.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libpkcs15init.so.2
170 %attr(755,root,root) %{_libdir}/libscconf.so.*.*.*
171 %attr(755,root,root) %ghost %{_libdir}/libscconf.so.2
172 # PKCS11 modules
173 %attr(755,root,root) %{_libdir}/onepin-opensc-pkcs11.so
174 %attr(755,root,root) %{_libdir}/opensc-pkcs11.so
175 %attr(755,root,root) %{_libdir}/pkcs11-spy.so
176 %dir %{_libdir}/pkcs11
177 %attr(755,root,root) %{_libdir}/pkcs11/onepin-opensc-pkcs11.so
178 %attr(755,root,root) %{_libdir}/pkcs11/opensc-pkcs11.so
179 %attr(755,root,root) %{_libdir}/pkcs11/pkcs11-spy.so
180 %dir %{_datadir}/opensc
181 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
182 %config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
183 %{_mandir}/man1/cardos-info.1*
184 %{_mandir}/man1/cryptoflex-tool.1*
185 %{_mandir}/man1/netkey-tool.1*
186 %{_mandir}/man1/opensc-explorer.1*
187 %{_mandir}/man1/opensc-tool.1*
188 %{_mandir}/man1/pkcs11-tool.1*
189 %{_mandir}/man1/pkcs15-*.1*
190 %{_mandir}/man5/pkcs15-profile.5*
191
192 %files devel
193 %defattr(644,root,root,755)
194 %doc doc/html.out/api.html
195 %attr(755,root,root) %{_bindir}/opensc-config
196 %attr(755,root,root) %{_libdir}/libopensc.so
197 %attr(755,root,root) %{_libdir}/libpkcs15init.so
198 %attr(755,root,root) %{_libdir}/libscconf.so
199 %{_libdir}/libopensc.la
200 %{_libdir}/libpkcs15init.la
201 %{_libdir}/libscconf.la
202 %{_includedir}/opensc
203 %{_pkgconfigdir}/libopensc.pc
204 %{_pkgconfigdir}/libpkcs15init.pc
205 %{_pkgconfigdir}/libscconf.pc
206 %{_mandir}/man1/opensc-config.1*
207 %{_mandir}/man3/sc_*.3*
208
209 %files static
210 %defattr(644,root,root,755)
211 %{_libdir}/libopensc.a
212 %{_libdir}/libpkcs15init.a
213 %{_libdir}/libscconf.a
214
215 %files -n browser-plugin-opensc
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_browserpluginsdir}/opensc-signer.so
This page took 0.030438 seconds and 2 git commands to generate.