]> git.pld-linux.org Git - packages/opensc.git/blob - opensc-ssl0.9.7.patch
- pkcs11 plugin in /usr/lib/pkcs11, but library in /usr/lib
[packages/opensc.git] / opensc-ssl0.9.7.patch
1 --- opensc-0.7.0/src/libopensc/card-gpk.c.orig  Thu May  2 13:54:27 2002
2 +++ opensc-0.7.0/src/libopensc/card-gpk.c       Wed Mar 12 10:31:58 2003
3 @@ -735,8 +735,8 @@
4         apdu->le += 3;
5         if (crycks1)
6                 memcpy(crycks1, out, 3);
7 -       memset(k1, 0, sizeof(k1));
8 -       memset(k2, 0, sizeof(k2));
9 +       memset(&k1, 0, sizeof(k1));
10 +       memset(&k2, 0, sizeof(k2));
11         memset(in, 0, sizeof(in));
12         memset(out, 0, sizeof(out));
13         memset(block, 0, sizeof(block));
14 @@ -878,8 +878,8 @@
15         if (memcmp(r_rn, out+4, 4) != 0)
16                 r = SC_ERROR_INVALID_ARGUMENTS;
17  
18 -       memset(k1, 0, sizeof(k1));
19 -       memset(k2, 0, sizeof(k2));
20 +       memset(&k1, 0, sizeof(k1));
21 +       memset(&k2, 0, sizeof(k2));
22         memset(out, 0, sizeof(out));
23         return r;
24  }
This page took 0.037839 seconds and 3 git commands to generate.