]> git.pld-linux.org Git - packages/openjdk9.git/commitdiff
protos.patch: Missing includes / prototypes
authorJacek Konieczny <jajcus@jajcus.net>
Wed, 10 Aug 2016 09:08:54 +0000 (11:08 +0200)
committerJacek Konieczny <jajcus@jajcus.net>
Wed, 10 Aug 2016 09:08:54 +0000 (11:08 +0200)
openjdk8.spec
protos.patch [new file with mode: 0644]

index 54bafbd46f6be429fd9c3a3ad5239ba81b8af79f..e522979b977004e1d3fe07ccd74d29c83bdab750 100644 (file)
@@ -57,6 +57,7 @@ Patch5:               system-libpng.patch
 Patch6:                system-lcms.patch
 Patch7:                system-pcsclite.patch
 Patch8:                x32.patch
+Patch9:                protos.patch
 URL:           http://openjdk.java.net/
 BuildRequires: /usr/bin/jar
 BuildRequires: alsa-lib-devel
@@ -423,6 +424,7 @@ done
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 %build
 # Make sure we have /proc mounted - otherwise idlc will fail later.
diff --git a/protos.patch b/protos.patch
new file mode 100644 (file)
index 0000000..251a48a
--- /dev/null
@@ -0,0 +1,24 @@
+--- jdk8u-jdk8u92-b31/jdk/src/share/native/sun/misc/URLClassPath.c.orig        2016-07-29 15:33:17.499988085 +0200
++++ jdk8u-jdk8u92-b31/jdk/src/share/native/sun/misc/URLClassPath.c     2016-07-29 15:35:59.085075633 +0200
+@@ -24,6 +24,7 @@
+  */
+ #include <string.h>
++#include <stdlib.h>
+ #include "jni.h"
+ #include "jni_util.h"
+@@ -36,6 +37,12 @@
+ extern char*
+ getUTF(JNIEnv *env, jstring str, char* localBuf, int bufSize);
++extern JNIEXPORT jboolean
++VerifyClassname(char *name, jboolean allowArrayClass);
++
++extern JNIEXPORT jboolean
++VerifyFixClassname(char *name);
++
+ JNIEXPORT jboolean JNICALL
+ Java_sun_misc_URLClassPath_knownToNotExist0(JNIEnv *env, jclass cls, jobject loader,
+
This page took 0.215797 seconds and 4 git commands to generate.