]> git.pld-linux.org Git - packages/openjdk9.git/blobdiff - openjdk8.spec
Run java as smoke test to find problems early
[packages/openjdk9.git] / openjdk8.spec
index fec6f3cc90f694f6aa810d3a458dbdaea533d506..fc4115a2ee26996fd2b8c650fd9c20697a824b23 100644 (file)
@@ -1,11 +1,12 @@
 #
+# NOTE:        versioning and release status might not be clear
+#      http://openjdk.java.net/projects/jdk8u/ gives some information
+#      about current status of the 'updates'
+#
 # TODO:
-#      - fix BuildRequires
-#      - fix build with system giflib
 #      - use other system libs (libsctp?)
-#      - build alternative VM for x32
 #      - include icedtea-sound?
-#      - port PLD-specific changes from icedtea7?
+#      - consider zeroshark (LLVM-based JIT) for x32
 
 %bcond_with bootstrap   # build a bootstrap version, using icedtea6
 %bcond_without cacerts # don't include the default CA certificates
 # JDK/JRE version, as returned with `java -version`, '_' replaced with '.'
 %define                _jdkversion 1.8.0.internal
 
-%define        ver_u   66
-%define        ver_b   02
+%define        ver_u   92
+%define        ver_b   31
 Summary:       Open-source implementation of the Java Platform, Standard Edition
 Summary(pl.UTF-8):     Wolnoźródłowa implementacja Java 8 SE
 Name:          openjdk8
 Version:       8u%{ver_u}.b%{ver_b}
-Release:       0.1
+Release:       1
 License:       GPL v2
 Group:         Development/Languages/Java
 Source0:       %{name}-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
-# Source0-md5: 1d115662e175470270e89a4da8e0fce2
+# Source0-md5: 12c37c3002601a22d3738fbfc7ce7fc4
 Source1:       %{name}-corba-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
-# Source1-md5: e14d8f51b9ca30d798094a2867f3f5d0
+# Source1-md5: 04527579bbf4d1d62174e580c73b37f4
 Source2:       %{name}-hotspot-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
-# Source2-md5: b49a7b7f2db5b07306b7b5739e87ccc0
+# Source2-md5: 9af1f1d01de54a7f1ee775747e97f603
 Source3:       %{name}-jaxp-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
-# Source3-md5: 6bd5ae187272a209439d1a95ac6c9025
+# Source3-md5: 462b944cbf7f082ded61dc4e4437a23c
 Source4:       %{name}-jaxws-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
-# Source4-md5: 15e6a93009bdc73194e7118988d5ab8d
+# Source4-md5: 8e387a76f8d7c13cc3cb28efa400a134
 Source5:       %{name}-jdk-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
-# Source5-md5: 74f2cf3815659b83993c4187e7fc4f6b
+# Source5-md5: 4a9c93dfef91c94779dd7606df04116e
 Source6:       %{name}-langtools-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
-# Source6-md5: de5c9b5fdbcd75028b71ed667d4b99d2
+# Source6-md5: 5f6e4140c3ac0b76f1841a8adcaf416a
 Source7:       %{name}-nashorn-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
-# Source7-md5: 7da4e88349cfc45ee9726eaa4386be03
+# Source7-md5: dca7539d79ca8ff2695fab7dcd260971
 Source10:      make-cacerts.sh
 Patch0:                adjust-mflags.patch
 Patch1:                format_strings.patch
@@ -55,6 +56,8 @@ Patch4:               system-libjpeg.patch
 Patch5:                system-libpng.patch
 Patch6:                system-lcms.patch
 Patch7:                system-pcsclite.patch
+Patch8:                x32.patch
+Patch9:                protos.patch
 URL:           http://openjdk.java.net/
 BuildRequires: /usr/bin/jar
 BuildRequires: alsa-lib-devel
@@ -65,7 +68,7 @@ BuildRequires:        bash
 BuildRequires: cups-devel
 BuildRequires: freetype-devel >= 2.3
 BuildRequires: gawk
-#BuildRequires:        giflib-devel >= 5.1
+BuildRequires: giflib-devel >= 5.1
 BuildRequires: glibc-misc
 %{?buildrequires_jdk}
 BuildRequires: lcms2-devel
@@ -185,7 +188,7 @@ Summary:    OpenJDK - software development kit
 Summary(pl.UTF-8):     Kod OpenJDK - środowisko programistyczne
 Group:         Development/Languages/Java
 Requires:      %{name}-jre-base = %{version}-%{release}
-Requires:      jpackage-utils >= 0:1.7.5-4
+Requires:      jpackage-utils >= 0:1.7.5-7
 Provides:      jdk(%{name})
 
 %description jdk-base
@@ -268,7 +271,7 @@ wolnego oprogramowania.
 Summary:       OpenJDK - runtime environment
 Summary(pl.UTF-8):     OpenJDK - środowisko uruchomieniowe
 Group:         Development/Languages/Java
-Requires:      jpackage-utils >= 0:1.7.5-4
+Requires:      jpackage-utils >= 0:1.7.5-7
 Provides:      jre(%{name})
 
 %description jre-base
@@ -420,6 +423,8 @@ done
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 %build
 # Make sure we have /proc mounted - otherwise idlc will fail later.
@@ -429,6 +434,7 @@ if [ ! -f /proc/self/stat ]; then
 fi
 
 cd common/autoconf
+rm generated-configure.sh
 %{__autoconf} -o generated-configure.sh
 cd ../..
 
@@ -447,11 +453,14 @@ chmod a+x configure
 
 # disable-debug-symbols so openjdk debuginfo handling won't conflict with ours
 %configure \
+%ifarch x32
+       --with-jvm-variants=zero \
+%endif
        --with-extra-cflags="%{rpmcflags}" \
        --with-extra-cxxflags="%{rpmcxxflags}" \
        --with-extra-ldflags="%{rpmldflags}" \
        --disable-debug-symbols \
-       --with-giflib=bundled \
+       --with-giflib=system \
        --with-libjpeg=system \
        --with-libpng=system \
        --with-lcms=system \
@@ -473,6 +482,9 @@ EOF
        LIBHPROF_OPTIMIZATION=LOW \
        LIBVERIFY_OPTIMIZATION=LOW
 
+# smoke test
+tmp-bin/java -version
+
 export PATH="$(pwd)/build-bin:$PATH"
 %{?with_cacerts:%{__sh} %{SOURCE10}}
 
@@ -777,7 +789,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava_crw_demo.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjavajpeg.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjavalcms.so
-%attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjawt.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjdwp.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsdt.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsig.so
@@ -838,6 +849,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsplashscreen.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libawt_xawt.so
 %attr(755,root,root) %{dstdir}/lib/%{jre_arch}/libjawt.so
+%attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjawt.so
 
 %files jre-base-alsa
 %defattr(644,root,root,755)
This page took 0.103997 seconds and 4 git commands to generate.