]> git.pld-linux.org Git - packages/openjdk9.git/blobdiff - openjdk8.spec
Pass JOBS=N instead -jN to make
[packages/openjdk9.git] / openjdk8.spec
index 72d422e2fbc6fc97f5e4b495c39505282fca5d39..ea2de66f5b8412a24b5ac1493cc2987e485a7168 100644 (file)
@@ -2,7 +2,7 @@
 # TODO:
 #      - fix BuildRequires
 #      - fix build with system giflib
-#      - use other system libs (libjpeg, liblcms, libsctp)
+#      - use other system libs (libsctp?)
 #      - build alternative VM for x32
 #      - include icedtea-sound?
 #      - port PLD-specific changes from icedtea7?
@@ -40,6 +40,7 @@ Source2:      openjdk8-hotspot-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
 Source3:       openjdk8-jaxp-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
 # Source3-md5: 6bd5ae187272a209439d1a95ac6c9025
 Source4:       openjdk8-jaxws-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
+# Source4-md5: 15e6a93009bdc73194e7118988d5ab8d
 Source5:       openjdk8-jdk-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
 # Source5-md5: 74f2cf3815659b83993c4187e7fc4f6b
 Source6:       openjdk8-langtools-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
@@ -51,11 +52,14 @@ Patch0:             adjust-mflags.patch
 Patch1:                format_strings.patch
 Patch2:                CompileDemos.patch
 Patch3:                libpath.patch
+Patch4:                system-libjpeg.patch
+Patch5:                system-libpng.patch
+Patch6:                system-lcms.patch
+Patch7:                system-pcsclite.patch
 URL:           http://openjdk.java.net/
 BuildRequires: alsa-lib-devel
 BuildRequires: ant
 BuildRequires: autoconf
-BuildRequires: automake
 BuildRequires: bash
 %{?with_cacerts:BuildRequires: ca-certificates-update}
 BuildRequires: cups-devel
@@ -65,8 +69,11 @@ BuildRequires:       gawk
 #BuildRequires:        giflib-devel >= 5.1
 BuildRequires: glibc-misc
 %buildrequires_jdk
+BuildRequires: lcms2-devel
 BuildRequires: libjpeg-devel
+BuildRequires: libpng-devel
 BuildRequires: lsb-release
+BuildRequires: pcsc-lite-devel
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.557
 BuildRequires: unzip
@@ -410,6 +417,10 @@ done
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
 %build
 # Make sure we have /proc mounted - otherwise idlc will fail later.
@@ -418,6 +429,10 @@ if [ ! -f /proc/self/stat ]; then
        exit 1
 fi
 
+cd common/autoconf
+%{__autoconf} -o generated-configure.sh
+cd ../..
+
 mkdir -p build-bin
 export JAVA_HOME=%{java_home}
 export PATH="$JAVA_HOME/bin:$PATH"
@@ -430,6 +445,10 @@ chmod a+x configure
        --with-extra-cxxflags="%{rpmcxxflags}" \
        --with-extra-ldflags="%{rpmldflags}" \
        --with-giflib=bundled \
+       --with-libjpeg=system \
+       --with-libpng=system \
+       --with-lcms=system \
+       --with-libpcsclite=system \
        --with-zlib=system
 
 specdir="$(dirname build/*-release/spec.gmk)"
@@ -439,6 +458,7 @@ EOF
 [ -d tmp-bin ] || ln -s "$specdir/jdk/bin" tmp-bin
 
 %{__make} all \
+       -j1 JOBS=%{__jobs} \
        LOG=debug
 
 export PATH="$(pwd)/build-bin:$PATH"
@@ -747,11 +767,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2pkcs11.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjaas_unix.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava.so
-%attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjpeg.so
-%attr(755,root,root) %{jredir}/lib/%{jre_arch}/liblcms.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsctp.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsunec.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava_crw_demo.so
+%attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjavajpeg.so
+%attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjavalcms.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjawt.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjdwp.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsdt.so
This page took 0.038421 seconds and 4 git commands to generate.