]> git.pld-linux.org Git - packages/openjdk9.git/blobdiff - openjdk8.spec
R: jpackage-utils-1.7.5-7
[packages/openjdk9.git] / openjdk8.spec
index 88b01f23cab9d931bf0ba8d8311e86b7ffcd7ba4..a932527712acb3c251c7c5696bac4aae62df2c6c 100644 (file)
@@ -1,9 +1,12 @@
 #
+# NOTE:        versioning and release status might not be clear
+#      http://openjdk.java.net/projects/jdk8u/ gives some information
+#      about current status of the 'updates'
+#
 # TODO:
 #      - use other system libs (libsctp?)
-#      - build alternative VM for x32
 #      - include icedtea-sound?
-#      - port PLD-specific changes from icedtea7?
+#      - consider zeroshark (LLVM-based JIT) for x32
 
 %bcond_with bootstrap   # build a bootstrap version, using icedtea6
 %bcond_without cacerts # don't include the default CA certificates
@@ -25,7 +28,7 @@ Summary:      Open-source implementation of the Java Platform, Standard Edition
 Summary(pl.UTF-8):     Wolnoźródłowa implementacja Java 8 SE
 Name:          openjdk8
 Version:       8u%{ver_u}.b%{ver_b}
-Release:       0.1
+Release:       2
 License:       GPL v2
 Group:         Development/Languages/Java
 Source0:       %{name}-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
@@ -53,6 +56,8 @@ Patch4:               system-libjpeg.patch
 Patch5:                system-libpng.patch
 Patch6:                system-lcms.patch
 Patch7:                system-pcsclite.patch
+Patch8:                x32.patch
+Patch9:                current_stack_pointer.patch
 URL:           http://openjdk.java.net/
 BuildRequires: /usr/bin/jar
 BuildRequires: alsa-lib-devel
@@ -183,7 +188,7 @@ Summary:    OpenJDK - software development kit
 Summary(pl.UTF-8):     Kod OpenJDK - środowisko programistyczne
 Group:         Development/Languages/Java
 Requires:      %{name}-jre-base = %{version}-%{release}
-Requires:      jpackage-utils >= 0:1.7.5-4
+Requires:      jpackage-utils >= 0:1.7.5-7
 Provides:      jdk(%{name})
 
 %description jdk-base
@@ -266,7 +271,7 @@ wolnego oprogramowania.
 Summary:       OpenJDK - runtime environment
 Summary(pl.UTF-8):     OpenJDK - środowisko uruchomieniowe
 Group:         Development/Languages/Java
-Requires:      jpackage-utils >= 0:1.7.5-4
+Requires:      jpackage-utils >= 0:1.7.5-7
 Provides:      jre(%{name})
 
 %description jre-base
@@ -418,6 +423,8 @@ done
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 %build
 # Make sure we have /proc mounted - otherwise idlc will fail later.
@@ -427,6 +434,7 @@ if [ ! -f /proc/self/stat ]; then
 fi
 
 cd common/autoconf
+rm generated-configure.sh
 %{__autoconf} -o generated-configure.sh
 cd ../..
 
@@ -445,6 +453,9 @@ chmod a+x configure
 
 # disable-debug-symbols so openjdk debuginfo handling won't conflict with ours
 %configure \
+%ifarch x32
+       --with-jvm-variants=zero \
+%endif
        --with-extra-cflags="%{rpmcflags}" \
        --with-extra-cxxflags="%{rpmcxxflags}" \
        --with-extra-ldflags="%{rpmldflags}" \
@@ -775,7 +786,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava_crw_demo.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjavajpeg.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjavalcms.so
-%attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjawt.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjdwp.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsdt.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsig.so
@@ -836,6 +846,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsplashscreen.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libawt_xawt.so
 %attr(755,root,root) %{dstdir}/lib/%{jre_arch}/libjawt.so
+%attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjawt.so
 
 %files jre-base-alsa
 %defattr(644,root,root,755)
This page took 0.032716 seconds and 4 git commands to generate.