]> git.pld-linux.org Git - packages/openjdk9.git/blobdiff - openjdk8.spec
Release: 1
[packages/openjdk9.git] / openjdk8.spec
index aadebbc30306c2487ff790421a0f9467aa06ff82..69a34defdd27e8f26ef1096194e29a2cf41e0421 100644 (file)
@@ -1,11 +1,12 @@
 #
+# NOTE:        versioning and release status might not be clear
+#      http://openjdk.java.net/projects/jdk8u/ gives some information
+#      about current status of the 'updates'
+#
 # TODO:
-#      - fix BuildRequires
-#      - fix build with system giflib
 #      - use other system libs (libsctp?)
-#      - build alternative VM for x32
 #      - include icedtea-sound?
-#      - port PLD-specific changes from icedtea7?
+#      - consider zeroshark (LLVM-based JIT) for x32
 
 %bcond_with bootstrap   # build a bootstrap version, using icedtea6
 %bcond_without cacerts # don't include the default CA certificates
@@ -27,7 +28,7 @@ Summary:      Open-source implementation of the Java Platform, Standard Edition
 Summary(pl.UTF-8):     Wolnoźródłowa implementacja Java 8 SE
 Name:          openjdk8
 Version:       8u%{ver_u}.b%{ver_b}
-Release:       0.1
+Release:       1
 License:       GPL v2
 Group:         Development/Languages/Java
 Source0:       %{name}-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
@@ -55,6 +56,8 @@ Patch4:               system-libjpeg.patch
 Patch5:                system-libpng.patch
 Patch6:                system-lcms.patch
 Patch7:                system-pcsclite.patch
+Patch8:                x32.patch
+Patch9:                current_stack_pointer.patch
 URL:           http://openjdk.java.net/
 BuildRequires: /usr/bin/jar
 BuildRequires: alsa-lib-devel
@@ -65,7 +68,7 @@ BuildRequires:        bash
 BuildRequires: cups-devel
 BuildRequires: freetype-devel >= 2.3
 BuildRequires: gawk
-#BuildRequires:        giflib-devel >= 5.1
+BuildRequires: giflib-devel >= 5.1
 BuildRequires: glibc-misc
 %{?buildrequires_jdk}
 BuildRequires: lcms2-devel
@@ -420,6 +423,8 @@ done
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 %build
 # Make sure we have /proc mounted - otherwise idlc will fail later.
@@ -429,6 +434,7 @@ if [ ! -f /proc/self/stat ]; then
 fi
 
 cd common/autoconf
+rm generated-configure.sh
 %{__autoconf} -o generated-configure.sh
 cd ../..
 
@@ -447,11 +453,14 @@ chmod a+x configure
 
 # disable-debug-symbols so openjdk debuginfo handling won't conflict with ours
 %configure \
+%ifarch x32
+       --with-jvm-variants=zero \
+%endif
        --with-extra-cflags="%{rpmcflags}" \
        --with-extra-cxxflags="%{rpmcxxflags}" \
        --with-extra-ldflags="%{rpmldflags}" \
        --disable-debug-symbols \
-       --with-giflib=bundled \
+       --with-giflib=system \
        --with-libjpeg=system \
        --with-libpng=system \
        --with-lcms=system \
@@ -755,11 +764,6 @@ rm -rf $RPM_BUILD_ROOT
 %{jredir}/lib/cmm
 %{jredir}/lib/ext
 %dir %{jredir}/lib/%{jre_arch}
-%ifnarch %{x8664} x32
-%dir %{jredir}/lib/%{jre_arch}/client
-%{jredir}/lib/%{jre_arch}/client/Xusage.txt
-%attr(755,root,root) %{jredir}/lib/%{jre_arch}/client/*.so
-%endif
 %dir %{jredir}/lib/%{jre_arch}/jli
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/jli/*.so
 %dir %{jredir}/lib/%{jre_arch}/server
This page took 0.065952 seconds and 4 git commands to generate.