]> git.pld-linux.org Git - packages/openjdk8.git/commitdiff
up to 1.8.0.322
authorJan Palus <atler@pld-linux.org>
Mon, 31 Jan 2022 19:34:15 +0000 (20:34 +0100)
committerJan Palus <atler@pld-linux.org>
Mon, 31 Jan 2022 19:34:15 +0000 (20:34 +0100)
- upstream switched to single (mono) repo for all compoenents
- aarch32 still lives in separate tree but also switched to mono repo

aarch32.patch [deleted file]
openjdk8.spec

diff --git a/aarch32.patch b/aarch32.patch
deleted file mode 100644 (file)
index 4d0b3ec..0000000
+++ /dev/null
@@ -1,179 +0,0 @@
---- a/common/autoconf/jdk-options.m4
-+++ b/common/autoconf/jdk-options.m4
-@@ -98,7 +98,11 @@ AC_DEFUN_ONCE([JDKOPT_SETUP_JVM_VARIANTS
-       [JVM variants (separated by commas) to build (server, client, minimal1, kernel, zero, zeroshark, core) @<:@server@:>@])])
-   if test "x$with_jvm_variants" = x; then
--    with_jvm_variants="server"
-+    if test "x$OPENJDK_TARGET_CPU" = xaarch32; then
-+      with_jvm_variants="client";
-+    else
-+      with_jvm_variants="server";
-+    fi
-   fi
-   JVM_VARIANTS=",$with_jvm_variants,"
-@@ -161,6 +165,9 @@ AC_DEFUN_ONCE([JDKOPT_SETUP_JVM_VARIANTS
-   if test "x$VAR_CPU" = xppc64 -o "x$VAR_CPU" = xppc64le ; then
-     INCLUDE_SA=false
-   fi
-+  if test "x$OPENJDK_TARGET_CPU" = xaarch32; then
-+    INCLUDE_SA=false
-+  fi
-   AC_SUBST(INCLUDE_SA)
-   if test "x$OPENJDK_TARGET_OS" = "xmacosx"; then
---- a/common/autoconf/platform.m4
-+++ b/common/autoconf/platform.m4
-@@ -56,8 +56,8 @@ AC_DEFUN([PLATFORM_EXTRACT_VARS_FROM_CPU
-       VAR_CPU_ENDIAN=little
-       ;;
-     arm*)
--      VAR_CPU=arm
--      VAR_CPU_ARCH=arm
-+      VAR_CPU=aarch32
-+      VAR_CPU_ARCH=aarch32
-       VAR_CPU_BITS=32
-       VAR_CPU_ENDIAN=little
-       ;;
-@@ -346,6 +346,8 @@ AC_DEFUN([PLATFORM_SETUP_LEGACY_VARS],
-   elif test "x$OPENJDK_TARGET_OS" != xmacosx && test "x$OPENJDK_TARGET_CPU" = xx86_64; then
-     # On all platforms except MacOSX replace x86_64 with amd64.
-     OPENJDK_TARGET_CPU_LEGACY="amd64"
-+  elif test "x$OPENJDK_TARGET_CPU" = xaarch32; then
-+    OPENJDK_TARGET_CPU_LEGACY="arm"
-   fi
-   AC_SUBST(OPENJDK_TARGET_CPU_LEGACY)
-@@ -356,6 +358,8 @@ AC_DEFUN([PLATFORM_SETUP_LEGACY_VARS],
-     OPENJDK_TARGET_CPU_LEGACY_LIB="i386"
-   elif test "x$OPENJDK_TARGET_CPU" = xx86_64; then
-     OPENJDK_TARGET_CPU_LEGACY_LIB="amd64"
-+  elif test "x$OPENJDK_TARGET_CPU" = xaarch32; then
-+    OPENJDK_TARGET_CPU_LEGACY_LIB="arm"
-   fi
-   AC_SUBST(OPENJDK_TARGET_CPU_LEGACY_LIB)
-@@ -389,6 +393,8 @@ AC_DEFUN([PLATFORM_SETUP_LEGACY_VARS],
-   elif test "x$OPENJDK_TARGET_OS" != xmacosx && test "x$OPENJDK_TARGET_CPU" = xx86_64; then
-     # On all platforms except macosx, we replace x86_64 with amd64.
-     OPENJDK_TARGET_CPU_OSARCH="amd64"
-+  elif test "x$OPENJDK_TARGET_CPU" = xaarch32; then
-+    OPENJDK_TARGET_CPU_OSARCH="arm"
-   fi
-   AC_SUBST(OPENJDK_TARGET_CPU_OSARCH)
-@@ -398,6 +404,8 @@ AC_DEFUN([PLATFORM_SETUP_LEGACY_VARS],
-   elif test "x$OPENJDK_TARGET_OS" != xmacosx && test "x$OPENJDK_TARGET_CPU" = xx86_64; then
-     # On all platforms except macosx, we replace x86_64 with amd64.
-     OPENJDK_TARGET_CPU_JLI="amd64"
-+  elif test "x$OPENJDK_TARGET_CPU" = xaarch32; then
-+    OPENJDK_TARGET_CPU_JLI="arm"
-   fi
-   # Now setup the -D flags for building libjli.
-   OPENJDK_TARGET_CPU_JLI_CFLAGS="-DLIBARCHNAME='\"$OPENJDK_TARGET_CPU_JLI\"'"
---- a/hotspot/make/defs.make
-+++ b/hotspot/make/defs.make
-@@ -335,6 +335,11 @@ ifneq ($(OSNAME),windows)
-   LIBARCH/ppc64   = ppc64
-   LIBARCH/aarch32 = aarch32
-+  # Override LIBARCH for aarch32
-+  ifeq ($(ARCH), aarch32)
-+    LIBARCH = arm
-+  endif
-+
-   LP64_ARCH += sparcv9 amd64 ia64 ppc64 aarch64 zero
- endif
---- a/jdk/make/CopyFiles.gmk
-+++ b/jdk/make/CopyFiles.gmk
-@@ -328,9 +328,15 @@ else
-   ifeq ($(CLIENT_AND_SERVER), true)
-     COPY_JVM_CFG_FILE := true
-   else
--    # For zero, the default jvm.cfg file is sufficient
-+    # For zero, the default jvm.cfg file is sufficient.
-     ifeq ($(JVM_VARIANT_ZERO), true)
-       COPY_JVM_CFG_FILE := true
-+    else
-+      ifeq ($(OPENJDK_TARGET_CPU), aarch32)
-+        ifeq ($(JVM_VARIANT_CORE), true)
-+          COPY_JVM_CFG_FILE := true
-+        endif
-+      endif
-     endif
-   endif
- endif
---- a/jdk/make/lib/NioLibraries.gmk
-+++ b/jdk/make/lib/NioLibraries.gmk
-@@ -174,6 +174,9 @@ ifeq ($(OPENJDK_TARGET_OS_API), posix)
-     ifeq ($(OPENJDK_TARGET_CPU_ARCH), ppc)
-       SCTP_WERROR :=
-     endif
-+    ifeq ($(OPENJDK_TARGET_CPU_ARCH), aarch32)
-+      SCTP_WERROR :=
-+    endif
-     $(eval $(call SetupNativeCompilation,BUILD_LIBSCTP, \
-         LIBRARY := sctp, \
---- a/jdk/make/lib/SoundLibraries.gmk
-+++ b/jdk/make/lib/SoundLibraries.gmk
-@@ -147,6 +147,10 @@ else
-   ifeq ($(OPENJDK_TARGET_CPU), aarch64)
-       LIBJSOUND_CFLAGS += -DX_ARCH=X_AARCH64
-   endif
-+
-+  ifeq ($(OPENJDK_TARGET_CPU), aarch32)
-+    LIBJSOUND_CFLAGS += -DX_ARCH=X_AARCH32
-+  endif
- endif
- LIBJSOUND_CFLAGS += -DEXTRA_SOUND_JNI_LIBS='"$(EXTRA_SOUND_JNI_LIBS)"'
---- a/jdk/src/share/native/com/sun/media/sound/SoundDefs.h
-+++ b/jdk/src/share/native/com/sun/media/sound/SoundDefs.h
-@@ -46,6 +46,7 @@
- #define X_PPC64         9
- #define X_PPC64LE      10
- #define X_AARCH64      11
-+#define X_AARCH32      12
- // **********************************
- // Make sure you set X_PLATFORM and X_ARCH defines correctly.
---- /dev/null
-+++ b/jdk/src/solaris/bin/aarch32/jvm.cfg
-@@ -0,0 +1,34 @@
-+# Copyright (c) 2015, 2015, Oracle and/or its affiliates. All rights reserved.
-+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
-+#
-+# This code is free software; you can redistribute it and/or modify it
-+# under the terms of the GNU General Public License version 2 only, as
-+# published by the Free Software Foundation.  Oracle designates this
-+# particular file as subject to the "Classpath" exception as provided
-+# by Oracle in the LICENSE file that accompanied this code.
-+#
-+# This code is distributed in the hope that it will be useful, but WITHOUT
-+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-+# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License
-+# version 2 for more details (a copy is included in the LICENSE file that
-+# accompanied this code).
-+#
-+# You should have received a copy of the GNU General Public License version
-+# 2 along with this work; if not, write to the Free Software Foundation,
-+# Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
-+#
-+# Please contact Oracle, 500 Oracle Parkway, Redwood Shores, CA 94065 USA
-+# or visit www.oracle.com if you need additional information or have any
-+# questions.
-+#
-+# List of JVMs that can be used as an option to java, javac, etc.
-+# Order is important -- first in this list is the default JVM.
-+# NOTE that this both this file and its format are UNSUPPORTED and
-+# WILL GO AWAY in a future release.
-+#
-+# You may also select a JVM in an arbitrary location with the
-+# "-XXaltjvm=<jvm_dir>" option, but that too is unsupported
-+# and may not be available in a future release.
-+#
-+-server KNOWN
-+-client IGNORE
index 7ab76bd5ba15b8e8c62177cce0a7a0d9a07308b1..803f97c6ab21ea830391515d468cbef78b63f890 100644 (file)
 # class data version seen with file(1) that this jvm is able to load
 %define                _classdataversion 52.0
 
-%define        ver_u   312
+%define        ver_u   322
 
 Summary:       Open-source implementation of the Java Platform, Standard Edition
 Summary(pl.UTF-8):     Wolnoźródłowa implementacja Java 8 SE
 Name:          openjdk8
 Version:       1.8.0.%{ver_u}
-Release:       2
+Release:       1
 Epoch:         1
 License:       GPL v2
 Group:         Development/Languages/Java
-Source0:       https://hg.openjdk.java.net/jdk8u/jdk8u/archive/jdk8u%{ver_u}-ga.tar.bz2?/%{name}-%{version}.tar.bz2
-# Source0-md5: a44c9a3a7c5bca3860905c24ad21b449
-Source1:       https://hg.openjdk.java.net/jdk8u/jdk8u/corba/archive/jdk8u%{ver_u}-ga.tar.bz2?/%{name}-corba-%{version}.tar.bz2
-# Source1-md5: 26b7d05ce243e7e4c2e9bcc106386b42
-Source2:       https://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/archive/jdk8u%{ver_u}-ga.tar.bz2?/%{name}-hotspot-%{version}.tar.bz2
-# Source2-md5: 9132b24a6a5cfdd0265f369367a60d71
-Source3:       https://hg.openjdk.java.net/jdk8u/jdk8u/jaxp/archive/jdk8u%{ver_u}-ga.tar.bz2?/%{name}-jaxp-%{version}.tar.bz2
-# Source3-md5: 84bfc99cc384863e06e330fc1b04e048
-Source4:       https://hg.openjdk.java.net/jdk8u/jdk8u/jaxws/archive/jdk8u%{ver_u}-ga.tar.bz2?/%{name}-jaxws-%{version}.tar.bz2
-# Source4-md5: e8ce03c81dc9f6252e412dc0f27ddbe0
-Source5:       https://hg.openjdk.java.net/jdk8u/jdk8u/jdk/archive/jdk8u%{ver_u}-ga.tar.bz2?/%{name}-jdk-%{version}.tar.bz2
-# Source5-md5: 22147c9a4ecac8e1f6ea2af02480ebd5
-Source6:       https://hg.openjdk.java.net/jdk8u/jdk8u/langtools/archive/jdk8u%{ver_u}-ga.tar.bz2?/%{name}-langtools-%{version}.tar.bz2
-# Source6-md5: e93f4fa1d9221fe235d74dac0034d052
-Source7:       https://hg.openjdk.java.net/jdk8u/jdk8u/nashorn/archive/jdk8u%{ver_u}-ga.tar.bz2?/%{name}-nashorn-%{version}.tar.bz2
-# Source7-md5: 70462a74254e22e14d4759c4af4fbc2d
-Source8:       https://hg.openjdk.java.net/aarch32-port/jdk8u/hotspot/archive/jdk8u%{ver_u}-b06-aarch32-20210923.tar.bz2?/%{name}-hotspot-aarch32-%{version}.tar.bz2
-# Source8-md5: 718e61ddf0d704495aea330433676848
-Source10:      make-cacerts.sh
+Source0:       https://hg.openjdk.java.net/jdk8u/monojdk8u/archive/jdk8u%{ver_u}-ga.tar.bz2?/%{name}-%{version}.tar.bz2
+# Source0-md5: 921ec6b97002cd68016641d372645b8d
+Source1:       https://hg.openjdk.java.net/aarch32-port/monojdk8u/archive/jdk8u%{ver_u}-ga-aarch32-20220131.tar.bz2?/%{name}-aarch32-%{version}.tar.bz2
+# Source1-md5: 4e7ef5cf5492cc8c591e548904490d40
+Source2:       make-cacerts.sh
 Patch0:                adjust-mflags.patch
 Patch1:                format_strings.patch
 Patch2:                CompileDemos.patch
@@ -54,7 +40,6 @@ Patch7:               system-pcsclite.patch
 Patch8:                x32.patch
 Patch9:                gcc11.patch
 Patch10:       link-with-as-needed.patch
-Patch11:       aarch32.patch
 Patch12:       atomic.patch
 Patch13:       hotspot-disable-werror.patch
 Patch14:       ignore-java-options.patch
@@ -143,7 +128,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jre_arch        aarch64
 %endif
 %ifarch %{arm}
-%define                jre_arch        arm
+%define                jre_arch        aarch32
 %endif
 
 %ifarch %{arm}
@@ -428,17 +413,13 @@ Code examples for OpenJDK.
 Przykłady dla OpenJDK.
 
 %prep
-%setup -qn jdk8u-jdk8u%{ver_u}-ga -a1 -a3 -a4 -a5 -a6 -a7
+%setup -q -c -T
 %ifarch %{arm}
-tar xf %{SOURCE8}
+tar xf %{SOURCE1} --strip-components=1
 %else
-tar xf %{SOURCE2}
+tar xf %{SOURCE0} --strip-components=1
 %endif
 
-for d in *-jdk8u%{ver_u}-*; do
-       mv "$d" "${d%%-jdk8u%{ver_u}-*}"
-done
-
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -451,7 +432,6 @@ done
 %patch9 -p1
 %patch10 -p1
 %ifarch %{arm}
-%patch11 -p1
 %patch12 -p1
 %endif
 %patch13 -p1
@@ -488,6 +468,8 @@ chmod a+x configure
 %configure \
 %ifarch x32
        --with-jvm-variants=zero \
+%else
+       --with-jvm-variants=%{jvm_type} \
 %endif
        --with-boot-jdk="%{java_home}" \
        --with-extra-cflags="%{rpmcppflags} %{rpmcflags}" \
@@ -527,7 +509,7 @@ EOF
 # smoke test
 tmp-bin/java -version
 
-%{?with_cacerts:%{__sh} %{SOURCE10}}
+%{?with_cacerts:%{__sh} %{SOURCE2}}
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.14926 seconds and 4 git commands to generate.