]> git.pld-linux.org Git - packages/openjdk8.git/blobdiff - openjdk8.spec
fix %%files leftover from icedtea7.spec
[packages/openjdk8.git] / openjdk8.spec
index 890179b35300e3e8e965cdc95e7054a5a0fa24d8..ecc08a7936dc2572f7db50ca9afb65ee6585bd33 100644 (file)
@@ -2,7 +2,7 @@
 # TODO:
 #      - fix BuildRequires
 #      - fix build with system giflib
-#      - use other system libs (libjpeg, liblcms, libsctp)
+#      - use other system libs (libsctp?)
 #      - build alternative VM for x32
 #      - include icedtea-sound?
 #      - port PLD-specific changes from icedtea7?
@@ -40,6 +40,7 @@ Source2:      openjdk8-hotspot-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
 Source3:       openjdk8-jaxp-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
 # Source3-md5: 6bd5ae187272a209439d1a95ac6c9025
 Source4:       openjdk8-jaxws-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
+# Source4-md5: 15e6a93009bdc73194e7118988d5ab8d
 Source5:       openjdk8-jdk-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
 # Source5-md5: 74f2cf3815659b83993c4187e7fc4f6b
 Source6:       openjdk8-langtools-jdk8u%{ver_u}-b%{ver_b}.tar.bz2
@@ -50,11 +51,15 @@ Source10:   make-cacerts.sh
 Patch0:                adjust-mflags.patch
 Patch1:                format_strings.patch
 Patch2:                CompileDemos.patch
+Patch3:                libpath.patch
+Patch4:                system-libjpeg.patch
+Patch5:                system-libpng.patch
+Patch6:                system-lcms.patch
+Patch7:                system-pcsclite.patch
 URL:           http://openjdk.java.net/
 BuildRequires: alsa-lib-devel
 BuildRequires: ant
 BuildRequires: autoconf
-BuildRequires: automake
 BuildRequires: bash
 %{?with_cacerts:BuildRequires: ca-certificates-update}
 BuildRequires: cups-devel
@@ -64,8 +69,11 @@ BuildRequires:       gawk
 #BuildRequires:        giflib-devel >= 5.1
 BuildRequires: glibc-misc
 %buildrequires_jdk
+BuildRequires: lcms2-devel
 BuildRequires: libjpeg-devel
+BuildRequires: libpng-devel
 BuildRequires: lsb-release
+BuildRequires: pcsc-lite-devel
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.557
 BuildRequires: unzip
@@ -408,6 +416,11 @@ done
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
 %build
 # Make sure we have /proc mounted - otherwise idlc will fail later.
@@ -416,9 +429,19 @@ if [ ! -f /proc/self/stat ]; then
        exit 1
 fi
 
+cd common/autoconf
+%{__autoconf} -o generated-configure.sh
+cd ../..
+
 mkdir -p build-bin
+
+# use the specified %%use_jdk
 export JAVA_HOME=%{java_home}
 export PATH="$JAVA_HOME/bin:$PATH"
+
+# unset CLASSPATH to be safe, gnustep puts garbage there, which openjdk hates
+unset CLASSPATH
+
 export SHELL=/bin/bash
 
 chmod a+x configure
@@ -428,6 +451,10 @@ chmod a+x configure
        --with-extra-cxxflags="%{rpmcxxflags}" \
        --with-extra-ldflags="%{rpmldflags}" \
        --with-giflib=bundled \
+       --with-libjpeg=system \
+       --with-libpng=system \
+       --with-lcms=system \
+       --with-libpcsclite=system \
        --with-zlib=system
 
 specdir="$(dirname build/*-release/spec.gmk)"
@@ -437,6 +464,7 @@ EOF
 [ -d tmp-bin ] || ln -s "$specdir/jdk/bin" tmp-bin
 
 %{__make} all \
+       -j1 JOBS=%{__jobs} \
        LOG=debug
 
 export PATH="$(pwd)/build-bin:$PATH"
@@ -686,8 +714,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files jre-base
 %defattr(644,root,root,755)
-%doc openjdk.build/j2sdk-image/THIRD_PARTY_README
-%doc openjdk.build/j2sdk-image/ASSEMBLY_EXCEPTION
+%doc THIRD_PARTY_README
+%doc ASSEMBLY_EXCEPTION
 %dir %{_sysconfdir}/%{name}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
 %dir %{dstdir}
@@ -745,11 +773,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2pkcs11.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjaas_unix.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava.so
-%attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjpeg.so
-%attr(755,root,root) %{jredir}/lib/%{jre_arch}/liblcms.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsctp.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsunec.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava_crw_demo.so
+%attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjavajpeg.so
+%attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjavalcms.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjawt.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjdwp.so
 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsdt.so
This page took 0.122776 seconds and 4 git commands to generate.