]> git.pld-linux.org Git - packages/openjdk11.git/commitdiff
up to 11.0.13 auto/th/openjdk11-11.0.13-1
authorJan Palus <atler@pld-linux.org>
Thu, 21 Oct 2021 07:45:40 +0000 (09:45 +0200)
committerJan Palus <atler@pld-linux.org>
Thu, 21 Oct 2021 07:45:40 +0000 (09:45 +0200)
- jdk11 switched exclusively to github

glibc-2.34.patch [deleted file]
libpath.patch
openjdk11.spec

diff --git a/glibc-2.34.patch b/glibc-2.34.patch
deleted file mode 100644 (file)
index 04bb926..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-From f77a1a156f3da9068d012d9227c7ee0fee58f571 Mon Sep 17 00:00:00 2001
-From: David Holmes <dholmes@openjdk.org>
-Date: Sun, 22 Aug 2021 01:13:27 +0000
-Subject: [PATCH] 8272472: StackGuardPages test doesn't build with glibc 2.34
-
-Reviewed-by: shade, stuefe, jiefu
----
- .../jtreg/runtime/StackGuardPages/exeinvoke.c       | 13 +++++++++++--
- 1 file changed, 11 insertions(+), 2 deletions(-)
-
-diff --git a/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c b/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
-index a46f1cef44c..50a37001fbf 100644
---- a/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
-+++ b/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
-@@ -1,5 +1,5 @@
- /*
-- * Copyright (c) 2010, 2020, Oracle and/or its affiliates. All rights reserved.
-+ * Copyright (c) 2010, 2021, Oracle and/or its affiliates. All rights reserved.
-  * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
-  *
-  * This code is free software; you can redistribute it and/or modify it
-@@ -68,8 +68,17 @@ static void handler(int sig, siginfo_t *si, void *unused) {
-   longjmp(context, 1);
- }
-+static char* altstack = NULL;
-+
- void set_signal_handler() {
--  static char altstack[SIGSTKSZ];
-+  if (altstack == NULL) {
-+    // Dynamically allocated in case SIGSTKSZ is not constant
-+    altstack = malloc(SIGSTKSZ);
-+    if (altstack == NULL) {
-+      fprintf(stderr, "Test ERROR. Unable to malloc altstack space\n");
-+      exit(7);
-+    }
-+  }
-   stack_t ss = {
-     .ss_size = SIGSTKSZ,
index 0873ca27b52a8e6d10d3a28eb08ba52d2cd4d2f7..922ef45eaa496e958b183a210ba170c01dadb606 100644 (file)
@@ -1,13 +1,22 @@
 --- jdk9u-jdk-9.0.4+12/src/hotspot/os/linux/os_linux.cpp.orig  2020-08-16 13:46:08.240275890 +0200
 +++ jdk9u-jdk-9.0.4+12/src/hotspot/os/linux/os_linux.cpp       2020-08-16 13:47:54.932632691 +0200
-@@ -289,9 +289,9 @@
+@@ -289,17 +289,10 @@
+   //        1: ...
    //        ...
    //        7: The default directories, normally /lib and /usr/lib.
- #if defined(AMD64) || (defined(_LP64) && defined(SPARC)) || defined(PPC64) || defined(S390)
+-#if defined(AMD64) || (defined(_LP64) && defined(SPARC)) || defined(PPC64) || defined(S390)
 -  #define DEFAULT_LIBPATH "/usr/lib64:/lib64:/lib:/usr/lib"
++#if defined(AMD64) || (defined(_LP64) && defined(SPARC)) || defined(PPC64) || defined(S390) || defined(AARCH64)
 +  #define DEFAULT_LIBPATH "/usr/lib64/java:/usr/lib64:/lib64:/lib:/usr/lib"
  #else
+-#if defined(AARCH64)
+-  // Use 32-bit locations first for AARCH64 (a 64-bit architecture), since some systems
+-  // might not adhere to the FHS and it would be a change in behaviour if we used
+-  // DEFAULT_LIBPATH of other 64-bit architectures which prefer the 64-bit paths.
+-  #define DEFAULT_LIBPATH "/lib:/usr/lib:/usr/lib64:/lib64"
+-#else
 -  #define DEFAULT_LIBPATH "/lib:/usr/lib"
+-#endif // AARCH64
 +  #define DEFAULT_LIBPATH "/usr/lib/java:/lib:/usr/lib"
  #endif
  
index 6cf7f02a0a6730bcc7f79ff9a61ad7dbece4b83b..0d161bddea599cdd757374f98256196c4f0fe59e 100644 (file)
 Summary:       Open-source implementation of the Java Platform, Standard Edition
 Summary(pl.UTF-8):     Wolnoźródłowa implementacja Java 11 SE
 Name:          openjdk11
-Version:       11.0.12
-Release:       5
+Version:       11.0.13
+Release:       1
 License:       GPL v2
 Group:         Development/Languages/Java
-Source0:       https://hg.openjdk.java.net/jdk-updates/jdk11u/archive/jdk-%{version}-ga.tar.bz2?/%{name}-%{version}.tar.bz2
-# Source0-md5: aa4b4199677892fd91de9316398dee6d
+Source0:       https://github.com/openjdk/jdk11u/archive/jdk-%{version}-ga/%{name}-%{version}.tar.gz
+# Source0-md5: 3e9b9485bfa254b334ccbd03a9c9a802
 Source10:      make-cacerts.sh
 Patch0:                libpath.patch
 Patch1:                x32.patch
-Patch2:                glibc-2.34.patch
 URL:           http://openjdk.java.net/
 BuildRequires: /usr/bin/jar
 BuildRequires: alsa-lib-devel
@@ -347,7 +346,6 @@ Przykłady dla OpenJDK.
 
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
 # Make sure we have /proc mounted - otherwise idlc will fail later.
This page took 0.245665 seconds and 4 git commands to generate.