]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- added unicap-c++ patch (workaround for "private" field name being a keyword in...
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 24 Jan 2011 16:08:29 +0000 (16:08 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added tbb support (on bcond)
- BR: eigen 2

Changed files:
    opencv-unicap-c++.patch -> 1.1
    opencv.spec -> 1.24

opencv-unicap-c++.patch [new file with mode: 0644]
opencv.spec

diff --git a/opencv-unicap-c++.patch b/opencv-unicap-c++.patch
new file mode 100644 (file)
index 0000000..30aa8a9
--- /dev/null
@@ -0,0 +1,15 @@
+--- OpenCV-2.2.0/modules/highgui/src/cap_unicap.cpp.orig       2010-12-05 04:35:25.000000000 +0100
++++ OpenCV-2.2.0/modules/highgui/src/cap_unicap.cpp    2011-01-23 21:17:45.126368322 +0100
+@@ -43,10 +43,12 @@
+ #include "precomp.hpp"
+ #include <unistd.h>
++#define private privat
+ #include <unicap.h>
+ extern "C" {
+ #include <ucil.h>
+ }
++#undef private
+ #ifdef NDEBUG
+ #define CV_WARN(message)
index 6a29346453c3a717eca88dfcf7f0d739256d437f..46fd142ccbd699991af574f7409160c1d13d31f9 100644 (file)
@@ -2,6 +2,7 @@
 # Conditional build:
 %bcond_without gstreamer       # GStreamer support
 %bcond_with    pvapi           # PvAPI (AVT GigE cameras) support
+%bcond_with    tbb             # Threading Building Blocks support
 %bcond_with    unicap          # Unicap support (GPL)
 %bcond_with    xine            # XINE support (GPL)
 #
@@ -22,11 +23,13 @@ Source0:    http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}.tar.bz
 Patch0:                %{name}-multilib.patch
 Patch1:                %{name}-cflags.patch
 Patch2:                %{name}-link.patch
+Patch3:                %{name}-unicap-c++.patch
 URL:           http://opencv.willowgarage.com/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 BuildRequires: OpenEXR-devel
 BuildRequires: cmake >= 2.4
 BuildRequires: doxygen
+BuildRequires: eigen >= 2
 BuildRequires: ffmpeg-devel
 %if %{with gstreamer}
 BuildRequires: gstreamer-devel >= 0.10
@@ -53,13 +56,12 @@ BuildRequires:      rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.577
 BuildRequires: sed >= 4.0
 BuildRequires: swig-python
+%{?with_tbb:BuildRequires:     tbb-devel}
 BuildRequires: zlib-devel
 %{?with_xine:BuildRequires:    xine-lib-devel}
 # TODO:
 # - Qt (bcond replacing GTK+?)
-# - tbb (tbb.pc)
 # - cuda (on bcond)
-# - eigen2/eigen3 (Eigen/Core headers)
 # - ipp (libippi)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -128,6 +130,7 @@ Wiązania Pythona do OpenCV.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 install -d build
@@ -146,6 +149,7 @@ cd build
        -DUSE_O3=OFF \
        %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
        %{!?with_pvapi:-DWITH_PVAPI=OFF} \
+       %{?with_tbb:-DWITH_TBB=ON} \
        %{?with_unicap:-DWITH_UNICAP=ON} \
        %{?with_xine:-DWITH_XINE=ON}
 
This page took 0.080792 seconds and 4 git commands to generate.