]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- remove cmake install directory arch dependant hackery
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 9 Mar 2015 14:00:33 +0000 (15:00 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 9 Mar 2015 14:00:33 +0000 (15:00 +0100)
cmake-install-path.patch [new file with mode: 0644]
opencv.spec

diff --git a/cmake-install-path.patch b/cmake-install-path.patch
new file mode 100644 (file)
index 0000000..bd7415d
--- /dev/null
@@ -0,0 +1,16 @@
+--- opencv-2.4.10.1/CMakeLists.txt~    2015-03-09 14:42:05.000000000 +0100
++++ opencv-2.4.10.1/CMakeLists.txt     2015-03-09 14:50:49.355937198 +0100
+@@ -324,12 +324,7 @@
+   endif()
+   set(OPENCV_INCLUDE_INSTALL_PATH "include")
+-  math(EXPR SIZEOF_VOID_P_BITS "8 * ${CMAKE_SIZEOF_VOID_P}")
+-  if(LIB_SUFFIX AND NOT SIZEOF_VOID_P_BITS EQUAL LIB_SUFFIX)
+-    set(OPENCV_CONFIG_INSTALL_PATH lib${LIB_SUFFIX}/cmake/opencv)
+-  else()
+-    set(OPENCV_CONFIG_INSTALL_PATH share/OpenCV)
+-  endif()
++  set(OPENCV_CONFIG_INSTALL_PATH share/OpenCV)
+ endif()
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${OPENCV_LIB_INSTALL_PATH}")
index 30a3d6891ed9ecdad1378a0fff100a5febc1cce7..3ee1a71c1cc0cf1d8f0eaeb270dea7ee361201de 100644 (file)
 # - other modules
 %bcond_without vtk             # VTK library support (opencv_viz module)
 
 # - other modules
 %bcond_without vtk             # VTK library support (opencv_viz module)
 
-%ifarch pentium3 pentium4 %{x8664}
+%ifarch pentium3 pentium4 %{x8664} x32
 %define                with_sse        1
 %endif
 %define                with_sse        1
 %endif
-%ifarch pentium4 %{x8664}
+%ifarch pentium4 %{x8664} x32
 %define                with_sse2       1
 %endif
 Summary:       A library of programming functions mainly aimed at real time computer vision
 %define                with_sse2       1
 %endif
 Summary:       A library of programming functions mainly aimed at real time computer vision
@@ -64,6 +64,7 @@ Patch6:               %{name}-ocl-fft.patch
 Patch7:                java-ant-sourcelevel.patch
 Patch8:                %{name}-shared.patch
 Patch9:                no-sysctl.patch
 Patch7:                java-ant-sourcelevel.patch
 Patch8:                %{name}-shared.patch
 Patch9:                no-sysctl.patch
+Patch10:       cmake-install-path.patch
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel}
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel}
@@ -277,6 +278,7 @@ Wiązania Pythona do OpenCV.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%patch10 -p1
 
 %build
 install -d build
 
 %build
 install -d build
This page took 0.076386 seconds and 4 git commands to generate.