]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- fix header to not use c++ syntax when using C compiler
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 27 Apr 2018 20:18:52 +0000 (22:18 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 27 Apr 2018 20:18:52 +0000 (22:18 +0200)
cplusplus.patch [new file with mode: 0644]
opencv.spec

diff --git a/cplusplus.patch b/cplusplus.patch
new file mode 100644 (file)
index 0000000..eb57b95
--- /dev/null
@@ -0,0 +1,28 @@
+--- opencv-3.4.1/modules/core/include/opencv2/core/cvdef.h~    2018-02-23 09:38:33.000000000 +0100
++++ opencv-3.4.1/modules/core/include/opencv2/core/cvdef.h     2018-04-27 22:17:38.423275013 +0200
+@@ -480,7 +480,7 @@
+ using std::int64_t;
+ using std::uint64_t;
+ }
+-#else
++#elif __cplusplus
+ #include <stdint.h>
+ namespace cv {
+ typedef ::int8_t int8_t;
+@@ -492,6 +492,16 @@
+ typedef ::int64_t int64_t;
+ typedef ::uint64_t uint64_t;
+ }
++#else
++#include <stdint.h>
++typedef int8_t int8_t;
++typedef uint8_t uint8_t;
++typedef int16_t int16_t;
++typedef uint16_t uint16_t;
++typedef int32_t int32_t;
++typedef uint32_t uint32_t;
++typedef int64_t int64_t;
++typedef uint64_t uint64_t;
+ #endif
+ #endif
index 187fe553a81a0891d412b66b6afc5b5a60d237c2..dce783ad598210948df9b81d4f2e5a729f1e4dff 100644 (file)
@@ -101,6 +101,7 @@ Source30:   https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229
 # Source30-md5:        7505c44ca4eb54b4ab1e4777cb96ac05
 Patch0:                ix86-pause.patch
 Patch1:                %{name}-ximea.patch
 # Source30-md5:        7505c44ca4eb54b4ab1e4777cb96ac05
 Patch0:                ix86-pause.patch
 Patch1:                %{name}-ximea.patch
+Patch2:                cplusplus.patch
 Patch3:                cmake-install-path.patch
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 Patch3:                cmake-install-path.patch
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
@@ -327,6 +328,7 @@ Wiązania Pythona 3 do OpenCV.
 
 %patch0 -p1
 %patch1 -p1
 
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 %patch3 -p1
 
 %build
 %patch3 -p1
 
 %build
This page took 0.050648 seconds and 4 git commands to generate.