]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- fix build error caused by sign() macro redefinition auto/th/opencv-3.1.0-7.2
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 13 Dec 2017 08:02:44 +0000 (09:02 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 13 Dec 2017 08:02:44 +0000 (09:02 +0100)
no-redefinition.patch [new file with mode: 0644]
opencv.spec

diff --git a/no-redefinition.patch b/no-redefinition.patch
new file mode 100644 (file)
index 0000000..d242146
--- /dev/null
@@ -0,0 +1,22 @@
+--- opencv-3.1.0/opencv_contrib-3.1.0/modules/tracking/include/opencv2/tracking/onlineMIL.hpp~ 2015-12-17 18:11:31.000000000 +0100
++++ opencv-3.1.0/opencv_contrib-3.1.0/modules/tracking/include/opencv2/tracking/onlineMIL.hpp  2017-12-13 08:59:51.077710225 +0100
+@@ -54,8 +54,6 @@
+ //TODO based on the original implementation
+ //http://vision.ucsd.edu/~bbabenko/project_miltrack.shtml
+-#define  sign(s)  ((s > 0 ) ? 1 : ((s<0) ? -1 : 0))
+-
+ class ClfOnlineStump;
+ class CV_EXPORTS ClfMilBoost
+--- opencv-3.1.0/opencv_contrib-3.1.0/modules/tracking/src/onlineMIL.cpp~      2015-12-17 18:11:31.000000000 +0100
++++ opencv-3.1.0/opencv_contrib-3.1.0/modules/tracking/src/onlineMIL.cpp       2017-12-13 09:00:15.158067835 +0100
+@@ -42,6 +42,8 @@
+ #include "precomp.hpp"
+ #include "opencv2/tracking/onlineMIL.hpp"
++#define  sign(s)  ((s > 0 ) ? 1 : ((s<0) ? -1 : 0))
++
+ template<class T> class SortableElementRev
+ {
+  public:
index cc8e05c1538d66658b920110df5b9c2dc66cf30e..de5099cb861d1bb4fc9e03c28520a61e3fabfc4d 100644 (file)
@@ -53,7 +53,7 @@ Summary:      A library of programming functions mainly aimed at real time computer v
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
 Version:       3.1.0
-Release:       7.1
+Release:       7.2
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
@@ -70,6 +70,7 @@ Patch1:               %{name}-ximea.patch
 Patch2:                java-ant-sourcelevel.patch
 Patch3:                cmake-install-path.patch
 Patch4:                vtk7.patch
+Patch5:                no-redefinition.patch
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel}
@@ -297,6 +298,7 @@ Wiązania Pythona 3 do OpenCV.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 install -d build
This page took 0.177872 seconds and 4 git commands to generate.