]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- one more c vs c++ fix auto/th/opencv-3.4.1-3
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 29 Apr 2018 22:24:06 +0000 (00:24 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 29 Apr 2018 22:24:06 +0000 (00:24 +0200)
- rel 3

cplusplus.patch
opencv.spec

index eb57b953b338631b9e2e40674496e8bbc522efaa..ccac14e087195f8499ac5aacc7419078a35534e6 100644 (file)
  #endif
  #endif
  
  #endif
  #endif
  
+--- opencv-3.4.1/modules/highgui/include/opencv2/highgui/highgui_c.h~  2018-02-23 09:38:33.000000000 +0100
++++ opencv-3.4.1/modules/highgui/include/opencv2/highgui/highgui_c.h   2018-04-30 00:00:01.659113349 +0200
+@@ -136,7 +136,11 @@
+ CVAPI(double) cvGetWindowProperty(const char* name, int prop_id);
+ /* Get window image rectangle coordinates, width and height */
++#ifdef __cplusplus
+ CVAPI(cv::Rect)cvGetWindowImageRect(const char* name);
++#else
++CVAPI(CvRect)cvGetWindowImageRect(const char* name);
++#endif
+ /* display image within window (highgui windows remember their content) */
+ CVAPI(void) cvShowImage( const char* name, const CvArr* image );
index bf2e47480e45c9d1d627fb67ba2008440fceb32f..60a8529e817109324933cf4673e96c37b8aa199d 100644 (file)
@@ -60,7 +60,7 @@ Summary:      A library of programming functions mainly aimed at real time computer v
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
 Version:       3.4.1
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
 Version:       3.4.1
-Release:       2
+Release:       3
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
This page took 0.038234 seconds and 4 git commands to generate.