]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- up to 3.4.1
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 26 Apr 2018 19:45:55 +0000 (21:45 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 26 Apr 2018 19:45:55 +0000 (21:45 +0200)
cmake-install-path.patch
java-ant-sourcelevel.patch [deleted file]
no-redefinition.patch [deleted file]
opencv-cflags.patch [deleted file]
opencv.spec
vtk7.patch [deleted file]

index bd7415dc03dd98c130567c2cd29a4c7f2b82f8f1..930653a810df1695f92da7d1422a36f6de0d591c 100644 (file)
@@ -1,16 +1,18 @@
 --- opencv-2.4.10.1/CMakeLists.txt~    2015-03-09 14:42:05.000000000 +0100
 +++ opencv-2.4.10.1/CMakeLists.txt     2015-03-09 14:50:49.355937198 +0100
-@@ -324,12 +324,7 @@
-   endif()
-   set(OPENCV_INCLUDE_INSTALL_PATH "include")
+@@ -445,14 +445,7 @@
+     ocv_update(OPENCV_JAR_INSTALL_PATH share/OpenCV/java)
+     ocv_update(OPENCV_OTHER_INSTALL_PATH   share/OpenCV)
  
--  math(EXPR SIZEOF_VOID_P_BITS "8 * ${CMAKE_SIZEOF_VOID_P}")
--  if(LIB_SUFFIX AND NOT SIZEOF_VOID_P_BITS EQUAL LIB_SUFFIX)
--    set(OPENCV_CONFIG_INSTALL_PATH lib${LIB_SUFFIX}/cmake/opencv)
--  else()
--    set(OPENCV_CONFIG_INSTALL_PATH share/OpenCV)
--  endif()
+-    if(NOT DEFINED OPENCV_CONFIG_INSTALL_PATH)
+-      math(EXPR SIZEOF_VOID_P_BITS "8 * ${CMAKE_SIZEOF_VOID_P}")
+-      if(LIB_SUFFIX AND NOT SIZEOF_VOID_P_BITS EQUAL LIB_SUFFIX)
+-        ocv_update(OPENCV_CONFIG_INSTALL_PATH ${CMAKE_INSTALL_LIBDIR}${LIB_SUFFIX}/cmake/opencv)
+-      else()
+-        ocv_update(OPENCV_CONFIG_INSTALL_PATH share/OpenCV)
+-      endif()
+-    endif()
 +  set(OPENCV_CONFIG_INSTALL_PATH share/OpenCV)
+   endif()
+   ocv_update(OPENCV_INCLUDE_INSTALL_PATH "include")
  endif()
- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${OPENCV_LIB_INSTALL_PATH}")
diff --git a/java-ant-sourcelevel.patch b/java-ant-sourcelevel.patch
deleted file mode 100644 (file)
index a8907c2..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- opencv-2.4.5/modules/java/build.xml.in~    2013-04-05 12:00:20.000000000 +0300
-+++ opencv-2.4.5/modules/java/build.xml.in     2013-06-21 20:08:55.908749180 +0300
-@@ -6,7 +6,10 @@
-     <!-- This is to make a jar with a source attachment, for e.g. easy -->
-     <!-- navigation in Eclipse. See this question: -->
-     <!-- http://stackoverflow.com/questions/3584968/ant-how-to-compile-jar-that-includes-source-attachment -->
--    <javac sourcepath="" srcdir="src" destdir="src" debug="on" includeantruntime="false" >
-+    <property name="javac.target" value="1.5"/>
-+    <property name="javac.source" value="1.5"/>
-+
-+    <javac sourcepath="" srcdir="src" destdir="src" debug="on" includeantruntime="false" target="${javac.target}" source="${javac.source}">
-       <include name="**/*.java"/>
-       <compilerarg line="-encoding utf-8"/>
-     </javac>
diff --git a/no-redefinition.patch b/no-redefinition.patch
deleted file mode 100644 (file)
index d242146..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- opencv-3.1.0/opencv_contrib-3.1.0/modules/tracking/include/opencv2/tracking/onlineMIL.hpp~ 2015-12-17 18:11:31.000000000 +0100
-+++ opencv-3.1.0/opencv_contrib-3.1.0/modules/tracking/include/opencv2/tracking/onlineMIL.hpp  2017-12-13 08:59:51.077710225 +0100
-@@ -54,8 +54,6 @@
- //TODO based on the original implementation
- //http://vision.ucsd.edu/~bbabenko/project_miltrack.shtml
--#define  sign(s)  ((s > 0 ) ? 1 : ((s<0) ? -1 : 0))
--
- class ClfOnlineStump;
- class CV_EXPORTS ClfMilBoost
---- opencv-3.1.0/opencv_contrib-3.1.0/modules/tracking/src/onlineMIL.cpp~      2015-12-17 18:11:31.000000000 +0100
-+++ opencv-3.1.0/opencv_contrib-3.1.0/modules/tracking/src/onlineMIL.cpp       2017-12-13 09:00:15.158067835 +0100
-@@ -42,6 +42,8 @@
- #include "precomp.hpp"
- #include "opencv2/tracking/onlineMIL.hpp"
-+#define  sign(s)  ((s > 0 ) ? 1 : ((s<0) ? -1 : 0))
-+
- template<class T> class SortableElementRev
- {
-  public:
diff --git a/opencv-cflags.patch b/opencv-cflags.patch
deleted file mode 100644 (file)
index 1ae4215..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- opencv-2.4.11/cmake/OpenCVCompilerOptions.cmake~   2015-05-19 11:39:16.000000000 +0300
-+++ opencv-2.4.11/cmake/OpenCVCompilerOptions.cmake    2015-05-19 11:47:57.851517663 +0300
-@@ -47,6 +47,8 @@
-   endif()
- endmacro()
-+add_extra_compiler_option(-D__STDC_CONSTANT_MACROS)
-+
- if(MINGW)
-   # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=40838
-   # here we are trying to workaround the problem
-@@ -110,10 +110,6 @@
-     add_extra_compiler_option(-Werror)
-   endif()
--  if(X86 AND NOT MINGW64 AND NOT X86_64 AND NOT APPLE)
--    add_extra_compiler_option(-march=i686)
--  endif()
--
-   if(APPLE)
-     add_extra_compiler_option(-Wno-semicolon-before-method-body)
-   endif()
index b8029ebfb779c2b92c62299192ff1e7d2ddfcfdc..356cbabdcb2b29a250d6f7b38e262048e6415eaf 100644 (file)
@@ -59,7 +59,7 @@
 Summary:       A library of programming functions mainly aimed at real time computer vision
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
-Version:       3.4.0
+Version:       3.4.1
 Release:       0.1
 Epoch:         1
 %if %{with unicap} || %{with xine}
@@ -69,15 +69,11 @@ License:    BSD
 %endif
 Group:         Libraries
 Source0:       https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 170732dc760e5f7ddeccbe53ba5d16a6
+# Source0-md5: a0b7a47899e67b3490ea31edc4f6e8e6
 Source1:       https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
-# Source1-md5: 315c3725234ec02fb4f6e55383376d00
-Patch0:                %{name}-cflags.patch
+# Source1-md5: dd0c63f4185ab8a4829d8154ae382266
 Patch1:                %{name}-ximea.patch
-Patch2:                java-ant-sourcelevel.patch
 Patch3:                cmake-install-path.patch
-Patch4:                vtk7.patch
-Patch5:                no-redefinition.patch
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel}
@@ -300,12 +296,8 @@ Wiązania Pythona 3 do OpenCV.
 
 %undos CMakeLists.txt
 
-%patch0 -p1
 %patch1 -p1
-%patch2 -p1
-#%patch3 -p1
-#%patch4 -p1
-#%patch5 -p2 -d opencv_contrib-%{version}
+%patch3 -p1
 
 %build
 install -d build
diff --git a/vtk7.patch b/vtk7.patch
deleted file mode 100644 (file)
index a3a5598..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- opencv-3.1.0/cmake/OpenCVDetectVTK.cmake.orig      2015-12-18 16:02:16.000000000 +0100
-+++ opencv-3.1.0/cmake/OpenCVDetectVTK.cmake   2017-01-24 07:33:14.029499623 +0100
-@@ -3,7 +3,14 @@
- endif()
- # VTK 6.x components
--find_package(VTK QUIET COMPONENTS vtkRenderingOpenGL vtkInteractionStyle vtkRenderingLOD vtkIOPLY vtkFiltersTexture vtkRenderingFreeType vtkIOExport NO_MODULE)
-+find_package(VTK QUIET COMPONENTS vtkInteractionStyle vtkRenderingLOD vtkIOPLY vtkFiltersTexture vtkRenderingFreeType vtkIOExport NO_MODULE)
-+IF(VTK_FOUND)
-+  IF(VTK_RENDERING_BACKEND) #in vtk 7, the rendering backend is exported as a var.
-+    find_package(VTK QUIET COMPONENTS vtkRendering${VTK_RENDERING_BACKEND} vtkInteractionStyle vtkRenderingLOD vtkIOPLY vtkFiltersTexture vtkRenderingFreeType vtkIOExport vtkIOGeometry NO_MODULE)
-+  ELSE(VTK_RENDERING_BACKEND)
-+    find_package(VTK QUIET COMPONENTS vtkRenderingOpenGL vtkInteractionStyle vtkRenderingLOD vtkIOPLY vtkFiltersTexture vtkRenderingFreeType vtkIOExport NO_MODULE)
-+  ENDIF(VTK_RENDERING_BACKEND)
-+ENDIF(VTK_FOUND)
- # VTK 5.x components
- if(NOT VTK_FOUND)
This page took 0.168238 seconds and 4 git commands to generate.