]> git.pld-linux.org Git - packages/opencv.git/blobdiff - opencv.spec
- added opengl bcond
[packages/opencv.git] / opencv.spec
index 9ff0c0ad51f688868ba895f6e09cd7c37310d241..d32f301f0ba12416cfd3c2b9eeaaefa8300f8fa5 100644 (file)
@@ -1,6 +1,9 @@
 #
 # TODO:
+# - OpenCL
+# - Smartek GigEVisionSDK (http://www.smartekvision.com/ ?)
 # - CUDA support (on bcond)
+# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
 #
 # Conditional build:
 # - general options:
@@ -9,6 +12,7 @@
 %bcond_with    sse2            # use SSE2 instructions
 # - highgui options:
 %bcond_without gstreamer       # GStreamer support in highgui
+%bcond_without opengl          # OpenGL support
 %bcond_with    openni          # OpenNI (Natural Interaction) support in highgui
 %bcond_with    pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
 %bcond_with    qt              # Qt backend instead of GTK+ in highgui
@@ -26,8 +30,8 @@
 Summary:       A library of programming functions mainly aimed at real time computer vision
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
-Version:       2.3.1
-Release:       9
+Version:       2.4.3
+Release:       1
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
@@ -35,24 +39,25 @@ License:    GPL (enforced by used libraries), BSD (opencv itself)
 License:       BSD
 %endif
 Group:         Libraries
-Source0:       http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}a.tar.bz2
-# Source0-md5: 82e4b6bfa349777233eea09b075e931e
+Source0:       http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}.tar.bz2
+# Source0-md5: c0a5af4ff9d0d540684c0bf00ef35dbe
 Patch0:                %{name}-cflags.patch
 Patch1:                %{name}-link.patch
 Patch2:                %{name}-unicap-c++.patch
 Patch3:                %{name}-c.patch
 Patch4:                %{name}-gcc.patch
-Patch5:                %{name}-multilib.patch
-Patch6:                %{name}-ximea-linux.patch
+Patch5:                %{name}-ximea.patch
 URL:           http://opencv.willowgarage.com/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 BuildRequires: OpenEXR-devel
-# as of OpenCV 2.3.1 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
+%{?with_opengl:BuildRequires:  OpenGL-devel}
+%{?with_opengl:BuildRequires:  OpenGL-GLU-devel}
+# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
 %{?with_openni:BuildRequires:  OpenNI-devel}
 %{?with_ximea:BuildRequires:   XIMEA-devel}
 BuildRequires: cmake >= 2.4
 BuildRequires: doxygen
-BuildRequires: eigen >= 2
+BuildRequires: eigen3 >= 3
 BuildRequires: ffmpeg-devel >= 0.7
 %if %{with gstreamer}
 BuildRequires: gstreamer-devel >= 0.10
@@ -82,15 +87,14 @@ BuildRequires:      swig-python
 %{?with_xine:BuildRequires:    xine-lib-devel}
 BuildRequires: zlib-devel
 %if %{with qt}
-BuildRequires: OpenGL-devel
 BuildRequires: QtCore-devel >= 4
 BuildRequires: QtGui-devel >= 4
-BuildRequires: QtOpenGL-devel >= 4
+%{?with_opengl:BuildRequires:  QtOpenGL-devel >= 4}
 BuildRequires: qt4-qmake >= 4
 %else
 BuildRequires: gtk+2-devel >= 2.0
+%{?with_opengl:BuildRequires:  gtkglext-devel >= 1.0}
 %endif
-# ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -161,7 +165,6 @@ Wiązania Pythona do OpenCV.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 %build
 install -d build
@@ -172,9 +175,10 @@ cd build
        -DBUILD_NEW_PYTHON_SUPPORT=ON \
        -DUSE_O3=OFF \
        %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
+       %{?with_opengl:-DWITH_OPENGL=ON} \
        %{?with_openni:-DWITH_OPENNI=ON} \
-       %{!?with_pvapi:-DWITH_PVAPI=OFF} \
-       %{?with_qt:-DWITH_QT=ON -DWITH_QT_OPENGL=ON -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
+       %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
+       %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
        %{?with_tbb:-DWITH_TBB=ON} \
        %{?with_unicap:-DWITH_UNICAP=ON} \
        %{!?with_v4l:-DWITH_V4L=OFF} \
@@ -206,7 +210,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/opencv_*
 %attr(755,root,root) %{_libdir}/libopencv_*.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_*.so.2.3
+%attr(755,root,root) %ghost %{_libdir}/libopencv_*.so.2.4
 %dir %{_datadir}/OpenCV
 %doc %{_datadir}/OpenCV/doc
 %{_datadir}/OpenCV/haarcascades
This page took 0.090678 seconds and 4 git commands to generate.