]> git.pld-linux.org Git - packages/opencv.git/blobdiff - opencv.spec
- release 7
[packages/opencv.git] / opencv.spec
index 277d4b5d24d792d963a04cc063b7cba3875f9c7f..c5af60a1c08570693f9bdf04753f71ed4ffff325 100644 (file)
@@ -1,23 +1,33 @@
 #
 # TODO:
 # - CUDA support (on bcond)
-# - OpenNI (http://openni.org/) + PrimeSensor module
-# - XIMEA? cmake file seems to be Win32-specific, but ximea.com has some Linux package
 #
 # Conditional build:
-%bcond_without gstreamer       # GStreamer support
-%bcond_with    pvapi           # PvAPI (AVT GigE cameras) support
-%bcond_with    qt              # Qt backend instead of GTK+
-%bcond_with    tbb             # Threading Building Blocks support
-%bcond_with    unicap          # Unicap support (GPL)
-%bcond_with    v4l             # Video4Linux (even V4L2 support currently relies on V4L1 API)
-%bcond_with    xine            # XINE support (GPL)
+# - general options:
+%bcond_with    tbb             # Threading Building Blocks support (everywhere)
+%bcond_with    sse             # use SSE instructions
+%bcond_with    sse2            # use SSE2 instructions
+# - highgui options:
+%bcond_without gstreamer       # GStreamer support in highgui
+%bcond_with    openni          # OpenNI (Natural Interaction) support in highgui
+%bcond_with    pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
+%bcond_with    qt              # Qt backend instead of GTK+ in highgui
+%bcond_with    unicap          # Unicap support in highgui (GPL)
+%bcond_with    v4l             # Video4Linux in highgui (even V4L2 support currently relies on V4L1 API)
+%bcond_with    ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
+%bcond_with    xine            # XINE support in highgui (GPL)
 #
+%ifarch pentium3 pentium4 %{x8664}
+%define                with_sse        1
+%endif
+%ifarch pentium4 %{x8664}
+%define                with_sse2       1
+%endif
 Summary:       A library of programming functions mainly aimed at real time computer vision
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
 Version:       2.3.1
-Release:       3
+Release:       7
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
@@ -33,9 +43,13 @@ Patch2:              %{name}-unicap-c++.patch
 Patch3:                %{name}-c.patch
 Patch4:                %{name}-gcc.patch
 Patch5:                %{name}-multilib.patch
+Patch6:                %{name}-ximea-linux.patch
 URL:           http://opencv.willowgarage.com/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 BuildRequires: OpenEXR-devel
+# as of OpenCV 2.3.1 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
+%{?with_openni:BuildRequires:  OpenNI-devel}
+%{?with_ximea:BuildRequires:   XIMEA-devel}
 BuildRequires: cmake >= 2.4
 BuildRequires: doxygen
 BuildRequires: eigen >= 2
@@ -147,26 +161,24 @@ Wiązania Pythona do OpenCV.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 %build
 install -d build
 cd build
 %cmake .. \
-%ifarch pentium4 %{x8664}
-       -DENABLE_SSE=ON \
-       -DENABLE_SSE2=ON \
-%else
-       -DENABLE_SSE=OFF \
-       -DENABLE_SSE2=OFF \
-%endif
+       -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
+       -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
        -DBUILD_NEW_PYTHON_SUPPORT=ON \
        -DUSE_O3=OFF \
        %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
+       %{?with_openni:-DWITH_OPENNI=ON} \
        %{!?with_pvapi:-DWITH_PVAPI=OFF} \
        %{?with_qt:-DWITH_QT=ON -DWITH_QT_OPENGL=ON -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
        %{?with_tbb:-DWITH_TBB=ON} \
        %{?with_unicap:-DWITH_UNICAP=ON} \
        %{!?with_v4l:-DWITH_V4L=OFF} \
+       %{?with_ximea:-DWITH_XIMEA=ON} \
        %{?with_xine:-DWITH_XINE=ON}
 
 %{__make}
This page took 0.223391 seconds and 4 git commands to generate.