]> git.pld-linux.org Git - packages/opencv.git/blobdiff - opencv.spec
- release 6 (by relup.sh)
[packages/opencv.git] / opencv.spec
index 30a3d6891ed9ecdad1378a0fff100a5febc1cce7..51ef98923620794fcb1d41448196f4e70841ad1c 100644 (file)
@@ -17,7 +17,7 @@
 %bcond_with    opencl_amdblas  # AMD OpenCL BLAS routines
 %bcond_with    opencl_amdfft   # AMD OpenCL FFT routines
 %bcond_without opengl          # OpenGL support
-%bcond_without gomp            # OpenMP support (available when not using tbb)
+%bcond_without openmp          # OpenMP support (available when not using tbb)
 %bcond_without examples        # Install examples
 # - bindings
 %bcond_without java            # Java binding
 # - other modules
 %bcond_without vtk             # VTK library support (opencv_viz module)
 
-%ifarch pentium3 pentium4 %{x8664}
+%ifarch pentium3 pentium4 %{x8664} x32
 %define                with_sse        1
 %endif
-%ifarch pentium4 %{x8664}
+%ifarch pentium4 %{x8664} x32
 %define                with_sse2       1
 %endif
 Summary:       A library of programming functions mainly aimed at real time computer vision
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
-Version:       2.4.10.1
-Release:       1
+Version:       2.4.11
+Release:       6
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
@@ -53,9 +53,9 @@ License:      BSD
 %endif
 Group:         Libraries
 Source0:       https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: f84af999f45edc829bfda60a13fedbaa
+# Source0-md5: fa06384719cb0be48183b4de972f0b2a
 Patch0:                %{name}-cflags.patch
-Patch1:                %{name}-x86.patch
+Patch1:                %{name}-cmake.patch
 Patch2:                %{name}-unicap-c++.patch
 Patch3:                %{name}-c.patch
 Patch4:                %{name}-gcc.patch
@@ -64,6 +64,7 @@ Patch6:               %{name}-ocl-fft.patch
 Patch7:                java-ant-sourcelevel.patch
 Patch8:                %{name}-shared.patch
 Patch9:                no-sysctl.patch
+Patch10:       cmake-install-path.patch
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel}
@@ -80,7 +81,7 @@ BuildRequires:        cmake >= 2.8
 BuildRequires: doxygen
 BuildRequires: eigen3 >= 3
 %{?with_ffmpeg:BuildRequires:  ffmpeg-devel >= 0.7}
-%{?with_gomp:BuildRequires:    gcc-c++ >= 6:4.2}
+%{?with_openmp:BuildRequires:  gcc-c++ >= 6:4.2}
 %if %{with gstreamer}
 BuildRequires: gstreamer-devel >= 1.0
 BuildRequires: gstreamer-plugins-base-devel >= 1.0
@@ -88,7 +89,7 @@ BuildRequires:        gstreamer-plugins-base-devel >= 1.0
 BuildRequires: jasper-devel
 %{?with_java:BuildRequires:    jdk}
 BuildRequires: libdc1394-devel >= 2
-%{?with_gomp:BuildRequires:    libgomp-devel}
+%{?with_openmp:BuildRequires:  libgomp-devel}
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libraw1394-devel
@@ -277,6 +278,7 @@ Wiązania Pythona do OpenCV.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%patch10 -p1
 
 %build
 install -d build
@@ -313,7 +315,7 @@ fi
        %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
        %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
        %{?with_opengl:-DWITH_OPENGL=ON} \
-       %{?with_gomp:-DWITH_OPENMP=ON} \
+       %{?with_openmp:-DWITH_OPENMP=ON} \
        %{?with_openni:-DWITH_OPENNI=ON} \
        %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
        %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
This page took 0.041285 seconds and 4 git commands to generate.