]> git.pld-linux.org Git - packages/opencv.git/blobdiff - opencv.spec
- release 3
[packages/opencv.git] / opencv.spec
index fca332a68b9514dd3d7e7ba323ca810ecc748a52..277d4b5d24d792d963a04cc063b7cba3875f9c7f 100644 (file)
@@ -1,4 +1,8 @@
-# TODO: CUDA support (on bcond)
+#
+# TODO:
+# - CUDA support (on bcond)
+# - OpenNI (http://openni.org/) + PrimeSensor module
+# - XIMEA? cmake file seems to be Win32-specific, but ximea.com has some Linux package
 #
 # Conditional build:
 %bcond_without gstreamer       # GStreamer support
@@ -12,8 +16,8 @@
 Summary:       A library of programming functions mainly aimed at real time computer vision
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
-Version:       2.2.0
-Release:       9
+Version:       2.3.1
+Release:       3
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
@@ -21,15 +25,14 @@ License:    GPL (enforced by used libraries), BSD (opencv itself)
 License:       BSD
 %endif
 Group:         Libraries
-Source0:       http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}.tar.bz2
-# Source0-md5: 122c9ac793a46854ef2819fedbbd6b1b
-Patch0:                %{name}-multilib.patch
-Patch1:                %{name}-cflags.patch
-Patch2:                %{name}-link.patch
-Patch3:                %{name}-unicap-c++.patch
-Patch4:                %{name}-c.patch
-Patch5:                %{name}-gcc.patch
-Patch6:                %{name}-ffmpeg-0.8.patch
+Source0:       http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}a.tar.bz2
+# Source0-md5: 82e4b6bfa349777233eea09b075e931e
+Patch0:                %{name}-cflags.patch
+Patch1:                %{name}-link.patch
+Patch2:                %{name}-unicap-c++.patch
+Patch3:                %{name}-c.patch
+Patch4:                %{name}-gcc.patch
+Patch5:                %{name}-multilib.patch
 URL:           http://opencv.willowgarage.com/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 BuildRequires: OpenEXR-devel
@@ -58,12 +61,12 @@ BuildRequires:      pkgconfig
 BuildRequires: python-devel
 BuildRequires: python-numpy-devel
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.577
+BuildRequires: rpmbuild(macros) >= 1.606
 BuildRequires: sed >= 4.0
 BuildRequires: swig-python
 %{?with_tbb:BuildRequires:     tbb-devel}
-BuildRequires: zlib-devel
 %{?with_xine:BuildRequires:    xine-lib-devel}
+BuildRequires: zlib-devel
 %if %{with qt}
 BuildRequires: OpenGL-devel
 BuildRequires: QtCore-devel >= 4
@@ -144,14 +147,11 @@ Wiązania Pythona do OpenCV.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 %build
 install -d build
 cd build
 %cmake .. \
-       -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
-       -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
 %ifarch pentium4 %{x8664}
        -DENABLE_SSE=ON \
        -DENABLE_SSE2=ON \
@@ -180,10 +180,9 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
 install build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
 
-%if "%{_lib}" == "lib64"
-# upstream has no lib64 support
-mv $RPM_BUILD_ROOT%{_prefix}/lib/lib*.so* $RPM_BUILD_ROOT%{_libdir}
-%endif
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -195,20 +194,21 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/opencv_*
 %attr(755,root,root) %{_libdir}/libopencv_*.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libopencv_*.so.2.2
-%dir %{_datadir}/opencv
-%doc %{_datadir}/opencv/doc
-%{_datadir}/opencv/haarcascades
-%{_datadir}/opencv/lbpcascades
+%attr(755,root,root) %ghost %{_libdir}/libopencv_*.so.2.3
+%dir %{_datadir}/OpenCV
+%doc %{_datadir}/OpenCV/doc
+%{_datadir}/OpenCV/haarcascades
+%{_datadir}/OpenCV/lbpcascades
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libopencv_*.so
 %{_includedir}/opencv
 %{_includedir}/opencv2
-%{_datadir}/opencv/OpenCVConfig.cmake
+%{_datadir}/OpenCV/OpenCVConfig*.cmake
 %{_pkgconfigdir}/opencv.pc
 
 %files -n python-opencv
 %defattr(644,root,root,755)
-%attr(755,root,root) %{py_sitedir}/cv.so
+%attr(755,root,root) %{py_sitedir}/cv2.so
+%{py_sitedir}/cv.py[co]
This page took 0.149876 seconds and 4 git commands to generate.