]> git.pld-linux.org Git - packages/opencv.git/blobdiff - opencv.spec
- release 3
[packages/opencv.git] / opencv.spec
index a5d7b785570f8a04b5af386a7ec4e92f1b2e520a..277d4b5d24d792d963a04cc063b7cba3875f9c7f 100644 (file)
@@ -1,6 +1,8 @@
 #
-# TODO: - CUDA support (on bcond)
-#      - consider name change to OpenCV
+# TODO:
+# - CUDA support (on bcond)
+# - OpenNI (http://openni.org/) + PrimeSensor module
+# - XIMEA? cmake file seems to be Win32-specific, but ximea.com has some Linux package
 #
 # Conditional build:
 %bcond_without gstreamer       # GStreamer support
@@ -15,7 +17,7 @@ Summary:      A library of programming functions mainly aimed at real time computer v
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
 Version:       2.3.1
-Release:       1
+Release:       3
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
@@ -30,6 +32,7 @@ Patch1:               %{name}-link.patch
 Patch2:                %{name}-unicap-c++.patch
 Patch3:                %{name}-c.patch
 Patch4:                %{name}-gcc.patch
+Patch5:                %{name}-multilib.patch
 URL:           http://opencv.willowgarage.com/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 BuildRequires: OpenEXR-devel
@@ -58,7 +61,7 @@ BuildRequires:        pkgconfig
 BuildRequires: python-devel
 BuildRequires: python-numpy-devel
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.600
+BuildRequires: rpmbuild(macros) >= 1.606
 BuildRequires: sed >= 4.0
 BuildRequires: swig-python
 %{?with_tbb:BuildRequires:     tbb-devel}
@@ -143,13 +146,12 @@ Wiązania Pythona do OpenCV.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 install -d build
 cd build
 %cmake .. \
-       -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
-       -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
 %ifarch pentium4 %{x8664}
        -DENABLE_SSE=ON \
        -DENABLE_SSE2=ON \
@@ -178,6 +180,10 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
 install build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
 
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py_postclean
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -205,4 +211,4 @@ rm -rf $RPM_BUILD_ROOT
 %files -n python-opencv
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/cv2.so
-%{py_sitedir}/cv.py
+%{py_sitedir}/cv.py[co]
This page took 0.09634 seconds and 4 git commands to generate.