]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- drop references to unused sysctl call/headers
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
3 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
4 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
5 #
6 # Conditional build:
7 # - general options:
8 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
9 %bcond_with     sse             # use SSE instructions
10 %bcond_with     sse2            # use SSE2 instructions
11 %bcond_with     sse3            # use SSE3 instructions
12 %bcond_with     ssse3           # use SSSE3 instructions
13 %bcond_with     sse41           # use SSE4.1 instructions
14 %bcond_with     sse42           # use SSE4.2 instructions
15 %bcond_with     avx             # use AVX instructions
16 %bcond_without  opencl          # OpenCL support
17 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
18 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
19 %bcond_without  opengl          # OpenGL support
20 %bcond_without  gomp            # OpenMP support (available when not using tbb)
21 %bcond_without  examples        # Install examples
22 # - bindings
23 %bcond_without  java            # Java binding
24 # - highgui options:
25 %bcond_without  ffmpeg          # FFMpeg support in highgui
26 %bcond_without  gstreamer       # GStreamer support in highgui
27 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
28 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
29 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
30 %bcond_with     unicap          # Unicap support in highgui (GPL)
31 %bcond_without  v4l             # Video4Linux in highgui
32 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
33 %bcond_with     xine            # XINE support in highgui (GPL)
34 # - other modules
35 %bcond_without  vtk             # VTK library support (opencv_viz module)
36
37 %ifarch pentium3 pentium4 %{x8664}
38 %define         with_sse        1
39 %endif
40 %ifarch pentium4 %{x8664}
41 %define         with_sse2       1
42 %endif
43 Summary:        A library of programming functions mainly aimed at real time computer vision
44 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
45 Name:           opencv
46 Version:        2.4.10.1
47 Release:        1
48 Epoch:          1
49 %if %{with unicap} || %{with xine}
50 License:        GPL (enforced by used libraries), BSD (opencv itself)
51 %else
52 License:        BSD
53 %endif
54 Group:          Libraries
55 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
56 # Source0-md5:  f84af999f45edc829bfda60a13fedbaa
57 Patch0:         %{name}-cflags.patch
58 Patch1:         %{name}-x86.patch
59 Patch2:         %{name}-unicap-c++.patch
60 Patch3:         %{name}-c.patch
61 Patch4:         %{name}-gcc.patch
62 Patch5:         %{name}-ximea.patch
63 Patch6:         %{name}-ocl-fft.patch
64 Patch7:         java-ant-sourcelevel.patch
65 Patch8:         %{name}-shared.patch
66 Patch9:         no-sysctl.patch
67 URL:            http://www.opencv.org/
68 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
69 %{?with_opencl:BuildRequires:   OpenCL-devel}
70 BuildRequires:  OpenEXR-devel
71 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
72 %{?with_opengl:BuildRequires:   OpenGL-devel}
73 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
74 %{?with_openni:BuildRequires:   OpenNI-devel}
75 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
76 %{?with_java:BuildRequires:     ant}
77 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
78 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
79 BuildRequires:  cmake >= 2.8
80 BuildRequires:  doxygen
81 BuildRequires:  eigen3 >= 3
82 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
83 %{?with_gomp:BuildRequires:     gcc-c++ >= 6:4.2}
84 %if %{with gstreamer}
85 BuildRequires:  gstreamer-devel >= 1.0
86 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
87 %endif
88 BuildRequires:  jasper-devel
89 %{?with_java:BuildRequires:     jdk}
90 BuildRequires:  libdc1394-devel >= 2
91 %{?with_gomp:BuildRequires:     libgomp-devel}
92 BuildRequires:  libjpeg-devel
93 BuildRequires:  libpng-devel
94 BuildRequires:  libraw1394-devel
95 BuildRequires:  libstdc++-devel
96 BuildRequires:  libtiff-devel
97 BuildRequires:  libtool
98 %if %{with unicap}
99 BuildRequires:  libucil-devel
100 BuildRequires:  libunicap-devel
101 %endif
102 BuildRequires:  libv4l-devel
103 BuildRequires:  pkgconfig
104 BuildRequires:  python >= 2.0
105 BuildRequires:  python-devel >= 2.0
106 BuildRequires:  python-numpy-devel
107 BuildRequires:  rpm-pythonprov
108 BuildRequires:  rpmbuild(macros) >= 1.606
109 BuildRequires:  sed >= 4.0
110 BuildRequires:  sphinx-pdg
111 BuildRequires:  swig-python
112 %{?with_tbb:BuildRequires:      tbb-devel}
113 %if %{with vtk}
114 BuildRequires:  vtk-devel >= 5.8.0
115 BuildRequires:  vtk-java >= 5.8.0
116 BuildRequires:  vtk-tcl >= 5.8.0
117 %endif
118 %{?with_xine:BuildRequires:     xine-lib-devel}
119 BuildRequires:  xorg-lib-libX11-devel
120 BuildRequires:  zlib-devel
121 %if %{with qt}
122 BuildRequires:  QtCore-devel >= 4
123 BuildRequires:  QtGui-devel >= 4
124 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
125 BuildRequires:  qt4-qmake >= 4
126 %else
127 BuildRequires:  gtk+2-devel >= 2.0
128 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
129 %endif
130 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
131 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
132
133 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
134
135 %description
136 OpenCV (Open Source Computer Vision) is a library of programming
137 functions mainly aimed at real time computer vision.
138
139 Example applications of the OpenCV library are:
140 - Human-Computer Interaction (HCI)
141 - Object Identification, Segmentation and Recognition
142 - Face Recognition
143 - Gesture Recognition
144 - Motion Tracking
145 - Ego Motion, Motion Understanding
146 - Structure From Motion (SFM)
147 - Stereo and Multi-Camera Calibration and Depth Computation
148 - Mobile Robotics.
149
150 %description -l pl.UTF-8
151 OpenCV (Open Source Computer Vision) to biblioteka funkcji
152 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
153
154 Przykładowe zastosowania biblioteki OpenCV to
155 - interakcje człowiek-komputer (HCI)
156 - identyfikacja, segmentacja i rozpoznawanie obiektów
157 - rozpoznawanie twarzy
158 - rozpoznawanie gestów
159 - śledzenie ruchu
160 - rozumienie ruchu
161 - SFM (Structure From Motion)
162 - kalibracja dwu- i wielokamerowa, obliczanie głębi
163 - robotyka ruchu.
164
165 %package core
166 Summary:        OpenCV core libraries
167 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
168 Group:          Libraries
169 Conflicts:      opencv < 2.4.6.2-1
170
171 %description core
172 This package contains the OpenCV C/C++ core libraries.
173
174 %description core -l pl.UTF-8
175 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
176
177 %package viz
178 Summary:        OpenCV viz library (VTK support)
179 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
180 Group:          Libraries
181 Requires:       %{name} = %{epoch}:%{version}-%{release}
182
183 %description viz
184 OpenCV viz library (VTK support).
185
186 %description viz -l pl.UTF-8
187 Biblioteka OpenCV viz (obsługa VTK).
188
189 %package devel
190 Summary:        Header files for OpenCV library
191 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
192 Group:          Development/Libraries
193 Requires:       %{name} = %{epoch}:%{version}-%{release}
194 %if %{with vtk}
195 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
196 %endif
197 Obsoletes:      opencv-static
198
199 %description devel
200 Header files for OpenCV library.
201
202 %description devel -l pl.UTF-8
203 Pliki nagłówkowe biblioteki OpenCV.
204
205 %package doc
206 Summary:        Manual for OpenCV
207 Summary(fr.UTF-8):      Documentation pour OpenCV
208 Summary(it.UTF-8):      Documentazione di OpenCV
209 Summary(pl.UTF-8):      Podręcznik dla OpenCV
210 Group:          Documentation
211 # noarch subpackages only when building with rpm5
212 %if "%{_rpmversion}" >= "5"
213 BuildArch:      noarch
214 %endif
215
216 %description doc
217 Documentation for OpenCV.
218
219 %description doc -l fr.UTF-8
220 Documentation pour OpenCV.
221
222 %description doc -l it.UTF-8
223 Documentazione di OpenCV.
224
225 %description doc -l pl.UTF-8
226 Dokumentacja do OpenCV.
227
228 %package examples
229 Summary:        OpenCV code examples
230 Group:          Documentation
231 %if "%{_rpmversion}" >= "5"
232 BuildArch:      noarch
233 %endif
234
235 %description examples
236 OpenCV code examples.
237
238 %package -n java-opencv
239 Summary:        OpenCV Java bindings
240 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
241 Group:          Libraries/Java
242 Requires:       %{name} = %{epoch}:%{version}-%{release}
243 Requires:       jre
244
245 %description -n java-opencv
246 OpenCV Java bindings.
247
248 %description -n java-opencv -l pl.UTF-8
249 Wiązania Javy do OpenCV.
250
251 %package -n python-opencv
252 Summary:        OpenCV Python bindings
253 Summary(pl.UTF-8):      Wiązania Pythona do OpenCV
254 Group:          Libraries/Python
255 Requires:       %{name} = %{epoch}:%{version}-%{release}
256 Requires:       python-libs
257
258 %description -n python-opencv
259 OpenCV Python bindings.
260
261 %description -n python-opencv -l pl.UTF-8
262 Wiązania Pythona do OpenCV.
263
264 %prep
265 %setup -q
266
267 %undos CMakeLists.txt
268 %undos modules/gpu/CMakeLists.txt
269
270 %patch0 -p1
271 %patch1 -p1
272 %patch2 -p1
273 %patch3 -p1
274 %patch4 -p1
275 %patch5 -p1
276 %patch6 -p1
277 %patch7 -p1
278 %patch8 -p1
279 %patch9 -p1
280
281 %build
282 install -d build
283 cd build
284
285 # handle cmake & ccache
286 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
287 if [[ "%{__cc}" = *ccache* ]]; then
288         cc="%{__cc}"
289         cxx="%{__cxx}"
290         ccache="
291         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
292         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
293         "
294 fi
295
296 %cmake .. \
297         $ccache \
298         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
299         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
300         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
301         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
302         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
303         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
304         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
305         -DBUILD_NEW_PYTHON_SUPPORT=ON \
306 %if %{with examples}
307         -DINSTALL_C_EXAMPLES=ON \
308         -DINSTALL_PYTHON_EXAMPLES=ON \
309 %endif
310         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
311         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
312         %{?with_opencl:-DWITH_OPENCL=ON} \
313         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
314         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
315         %{?with_opengl:-DWITH_OPENGL=ON} \
316         %{?with_gomp:-DWITH_OPENMP=ON} \
317         %{?with_openni:-DWITH_OPENNI=ON} \
318         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
319         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
320         %{?with_tbb:-DWITH_TBB=ON} \
321         %{?with_unicap:-DWITH_UNICAP=ON} \
322         %{!?with_v4l:-DWITH_V4L=OFF} \
323         %{?with_vtk:-DWITH_VTK=ON} \
324         %{?with_ximea:-DWITH_XIMEA=ON} \
325         %{?with_xine:-DWITH_XINE=ON}
326
327 %{__make}
328
329 %install
330 rm -rf $RPM_BUILD_ROOT
331 %{__make} -C build install \
332         DESTDIR=$RPM_BUILD_ROOT
333
334 # see -doc package
335 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
336 %if %{with examples}
337 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
338 mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
339 %endif
340
341 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
342 cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
343
344 # disable completeness check incompatible with split packaging
345 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
346
347 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
348 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
349 %py_postclean
350
351 %if %{with java}
352 # move to proper directories, create symlink
353 install -d $RPM_BUILD_ROOT%{_javadir}
354 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
355 sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
356         $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
357 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
358 rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
359 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
360 %endif
361
362 %clean
363 rm -rf $RPM_BUILD_ROOT
364
365 %post   -p /sbin/ldconfig
366 %postun -p /sbin/ldconfig
367
368 %post   core -p /sbin/ldconfig
369 %postun core -p /sbin/ldconfig
370
371 %post   viz -p /sbin/ldconfig
372 %postun viz -p /sbin/ldconfig
373
374 %post   -n java-opencv -p /sbin/ldconfig
375 %postun -n java-opencv -p /sbin/ldconfig
376
377 %files
378 %defattr(644,root,root,755)
379 %attr(755,root,root) %{_bindir}/opencv_createsamples
380 %attr(755,root,root) %{_bindir}/opencv_haartraining
381 %attr(755,root,root) %{_bindir}/opencv_performance
382 %attr(755,root,root) %{_bindir}/opencv_traincascade
383 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
384 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
385 %attr(755,root,root) %{_libdir}/libopencv_contrib.so.*.*.*
386 %attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
387 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
388 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
389 %attr(755,root,root) %{_libdir}/libopencv_gpu.so.*.*.*
390 %attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
391 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
392 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
393 %attr(755,root,root) %{_libdir}/libopencv_legacy.so.*.*.*
394 %attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
395 %attr(755,root,root) %{_libdir}/libopencv_nonfree.so.*.*.*
396 %attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
397 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
398 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
399 %if %{with opencl}
400 %attr(755,root,root) %{_libdir}/libopencv_ocl.so.*.*.*
401 %attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
402 %endif
403 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
404 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
405 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
406 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
407 %attr(755,root,root) %{_libdir}/libopencv_ts.so.*.*.*
408 %attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
409 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
410 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
411 %dir %{_datadir}/OpenCV
412 %{_datadir}/OpenCV/haarcascades
413 %{_datadir}/OpenCV/lbpcascades
414
415 %files core
416 %defattr(644,root,root,755)
417 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
418 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
419 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
420 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
421 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
422 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
423 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
424 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
425 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
426 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
427 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
428 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
429
430 %if %{with vtk}
431 %files viz
432 %defattr(644,root,root,755)
433 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
434 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
435 %endif
436
437 %files devel
438 %defattr(644,root,root,755)
439 # core
440 %attr(755,root,root) %{_libdir}/libopencv_core.so
441 %attr(755,root,root) %{_libdir}/libopencv_flann.so
442 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so
443 %attr(755,root,root) %{_libdir}/libopencv_ml.so
444 %attr(755,root,root) %{_libdir}/libopencv_photo.so
445 %attr(755,root,root) %{_libdir}/libopencv_video.so
446 # GUI/extensions (base package)
447 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so
448 %attr(755,root,root) %{_libdir}/libopencv_contrib.so
449 %attr(755,root,root) %{_libdir}/libopencv_features2d.so
450 %attr(755,root,root) %{_libdir}/libopencv_gpu.so
451 %attr(755,root,root) %{_libdir}/libopencv_highgui.so
452 %attr(755,root,root) %{_libdir}/libopencv_legacy.so
453 %attr(755,root,root) %{_libdir}/libopencv_nonfree.so
454 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so
455 %if %{with opencl}
456 %attr(755,root,root) %{_libdir}/libopencv_ocl.so
457 %endif
458 %attr(755,root,root) %{_libdir}/libopencv_stitching.so
459 %attr(755,root,root) %{_libdir}/libopencv_superres.so
460 %attr(755,root,root) %{_libdir}/libopencv_ts.so
461 %attr(755,root,root) %{_libdir}/libopencv_videostab.so
462 # viz
463 %if %{with vtk}
464 %attr(755,root,root) %{_libdir}/libopencv_viz.so
465 %endif
466 %{_includedir}/opencv
467 %{_includedir}/opencv2
468 %{_datadir}/OpenCV/OpenCV*.cmake
469 %{_pkgconfigdir}/opencv.pc
470
471 %files doc
472 %defattr(644,root,root,755)
473 # TODO: probably could rebuild them and package via make install
474 %doc doc/*
475
476 %if %{with examples}
477 %files examples
478 %defattr(644,root,root,755)
479 %{_examplesdir}/%{name}-%{version}
480 %endif
481
482 %if %{with java}
483 %files -n java-opencv
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
486 %{_javadir}/opencv-%{jver}.jar
487 %{_javadir}/opencv.jar
488 %endif
489
490 %files -n python-opencv
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{py_sitedir}/cv2.so
493 %{py_sitedir}/cv.py[co]
This page took 0.076253 seconds and 4 git commands to generate.