]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
workaround for ccache builds
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
3 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
4 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
5 # - GUI: VTK support
6 # - Use GCD NO
7 # - Use Concurrency NO
8 # - Use C= (CSTRIPES): NO
9 #   C/C++ Examples: NO
10 #
11 # Conditional build:
12 # - general options:
13 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
14 %bcond_with     sse             # use SSE instructions
15 %bcond_with     sse2            # use SSE2 instructions
16 %bcond_with     sse3            # use SSE3 instructions
17 %bcond_with     ssse3           # use SSSE3 instructions
18 %bcond_with     sse41           # use SSE4.1 instructions
19 %bcond_with     sse42           # use SSE4.2 instructions
20 %bcond_with     avx             # use AVX instructions
21 %bcond_without  opencl          # OpenCL support
22 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
23 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
24 %bcond_without  opengl          # OpenGL support
25 %bcond_without  gomp            # OpenMP support
26 %bcond_without  examples        # Install examples
27 # - bindings
28 %bcond_without  java            # Java binding
29 # - highgui options:
30 %bcond_without  ffmpeg          # FFMpeg support in highgui
31 %bcond_without  gstreamer       # GStreamer support in highgui
32 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
33 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
34 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
35 %bcond_with     unicap          # Unicap support in highgui (GPL)
36 %bcond_without  v4l             # Video4Linux in highgui
37 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
38 %bcond_with     xine            # XINE support in highgui (GPL)
39
40 %ifarch pentium3 pentium4 %{x8664}
41 %define         with_sse        1
42 %endif
43 %ifarch pentium4 %{x8664}
44 %define         with_sse2       1
45 %endif
46 Summary:        A library of programming functions mainly aimed at real time computer vision
47 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
48 Name:           opencv
49 Version:        2.4.9
50 Release:        1
51 Epoch:          1
52 %if %{with unicap} || %{with xine}
53 License:        GPL (enforced by used libraries), BSD (opencv itself)
54 %else
55 License:        BSD
56 %endif
57 Group:          Libraries
58 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
59 # Source0-md5:  cc0a8307403ff471f554197401ec0eb9
60 Patch0:         %{name}-cflags.patch
61 Patch1:         %{name}-link.patch
62 Patch2:         %{name}-unicap-c++.patch
63 Patch3:         %{name}-c.patch
64 Patch4:         %{name}-gcc.patch
65 Patch5:         %{name}-ximea.patch
66 Patch6:         %{name}-ocl-fft.patch
67 Patch7:         java-ant-sourcelevel.patch
68 Patch8:         %{name}-shared.patch
69 URL:            http://www.opencv.org/
70 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
71 %{?with_opencl:BuildRequires:   OpenCL-devel}
72 BuildRequires:  OpenEXR-devel
73 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
74 %{?with_opengl:BuildRequires:   OpenGL-devel}
75 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
76 %{?with_openni:BuildRequires:   OpenNI-devel}
77 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
78 %{?with_java:BuildRequires:     ant}
79 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
80 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
81 BuildRequires:  cmake >= 2.8
82 BuildRequires:  doxygen
83 BuildRequires:  eigen3 >= 3
84 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
85 %{?with_gomp:BuildRequires:     gcc-c++ >= 6:4.2}
86 %if %{with gstreamer}
87 BuildRequires:  gstreamer-devel >= 0.10
88 BuildRequires:  gstreamer-plugins-base-devel >= 0.10
89 %endif
90 BuildRequires:  jasper-devel
91 %{?with_java:BuildRequires:     jdk}
92 BuildRequires:  libdc1394-devel
93 %{?with_gomp:BuildRequires:     libgomp-devel}
94 BuildRequires:  libjpeg-devel
95 BuildRequires:  libpng-devel
96 BuildRequires:  libraw1394-devel
97 BuildRequires:  libstdc++-devel
98 BuildRequires:  libtiff-devel
99 BuildRequires:  libtool
100 %if %{with unicap}
101 BuildRequires:  libucil-devel
102 BuildRequires:  libunicap-devel
103 %endif
104 BuildRequires:  libv4l-devel
105 BuildRequires:  pkgconfig
106 BuildRequires:  python
107 BuildRequires:  python-devel
108 BuildRequires:  python-numpy-devel
109 BuildRequires:  rpm-pythonprov
110 BuildRequires:  rpmbuild(macros) >= 1.606
111 BuildRequires:  sed >= 4.0
112 BuildRequires:  swig-python
113 %{?with_tbb:BuildRequires:      tbb-devel}
114 %{?with_xine:BuildRequires:     xine-lib-devel}
115 BuildRequires:  zlib-devel
116 %if %{with qt}
117 BuildRequires:  QtCore-devel >= 4
118 BuildRequires:  QtGui-devel >= 4
119 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
120 BuildRequires:  qt4-qmake >= 4
121 %else
122 BuildRequires:  gtk+2-devel >= 2.0
123 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
124 %endif
125 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
126 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
127
128 %define         sover   %(v=%{version}; k=${v#?.?.?}; echo ${v%$k})
129
130 %description
131 OpenCV (Open Source Computer Vision) is a library of programming
132 functions mainly aimed at real time computer vision.
133
134 Example applications of the OpenCV library are:
135 - Human-Computer Interaction (HCI)
136 - Object Identification, Segmentation and Recognition
137 - Face Recognition
138 - Gesture Recognition
139 - Motion Tracking
140 - Ego Motion, Motion Understanding
141 - Structure From Motion (SFM)
142 - Stereo and Multi-Camera Calibration and Depth Computation
143 - Mobile Robotics.
144
145 %description -l pl.UTF-8
146 OpenCV (Open Source Computer Vision) to biblioteka funkcji
147 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
148
149 Przykładowe zastosowania biblioteki OpenCV to
150 - interakcje człowiek-komputer (HCI)
151 - identyfikacja, segmentacja i rozpoznawanie obiektów
152 - rozpoznawanie twarzy
153 - rozpoznawanie gestów
154 - śledzenie ruchu
155 - rozumienie ruchu
156 - SFM (Structure From Motion)
157 - kalibracja dwu- i wielokamerowa, obliczanie głębi
158 - robotyka ruchu.
159
160 %package core
161 Summary:        OpenCV core libraries
162 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
163 Group:          Libraries
164 Conflicts:      opencv < 2.4.6.2-1
165
166 %description core
167 This package contains the OpenCV C/C++ core libraries.
168
169 %description core -l pl.UTF-8
170 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
171
172 %package devel
173 Summary:        Header files for OpenCV library
174 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
175 Group:          Development/Libraries
176 Requires:       %{name} = %{epoch}:%{version}-%{release}
177 Obsoletes:      opencv-static
178
179 %description devel
180 Header files for OpenCV library.
181
182 %description devel -l pl.UTF-8
183 Pliki nagłówkowe biblioteki OpenCV.
184
185 %package doc
186 Summary:        Manual for OpenCV
187 Summary(fr.UTF-8):      Documentation pour OpenCV
188 Summary(it.UTF-8):      Documentazione di OpenCV
189 Summary(pl.UTF-8):      Podręcznik dla OpenCV
190 Group:          Documentation
191 # noarch subpackages only when building with rpm5
192 %if "%{_rpmversion}" >= "5"
193 BuildArch:      noarch
194 %endif
195
196 %description doc
197 Documentation for OpenCV.
198
199 %description doc -l fr.UTF-8
200 Documentation pour OpenCV.
201
202 %description doc -l it.UTF-8
203 Documentazione di OpenCV.
204
205 %description doc -l pl.UTF-8
206 Dokumentacja do OpenCV.
207
208 %package examples
209 Summary:        OpenCV code examples
210 Group:          Documentation
211 %if "%{_rpmversion}" >= "5"
212 BuildArch:      noarch
213 %endif
214
215 %description examples
216 OpenCV code examples.
217
218 %package -n java-opencv
219 Summary:        OpenCV Java bindings
220 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
221 Group:          Libraries/Java
222 Requires:       %{name} = %{epoch}:%{version}-%{release}
223 Requires:       jre
224
225 %description -n java-opencv
226 OpenCV Java bindings.
227
228 %description -n java-opencv -l pl.UTF-8
229 Wiązania Javy do OpenCV.
230
231 %package -n python-opencv
232 Summary:        OpenCV Python bindings
233 Summary(pl.UTF-8):      Wiązania Pythona do OpenCV
234 Group:          Libraries/Python
235 Requires:       %{name} = %{epoch}:%{version}-%{release}
236 Requires:       python-libs
237
238 %description -n python-opencv
239 OpenCV Python bindings.
240
241 %description -n python-opencv -l pl.UTF-8
242 Wiązania Pythona do OpenCV.
243
244 %prep
245 %setup -q
246
247 %undos CMakeLists.txt
248 %undos modules/gpu/CMakeLists.txt
249
250 %patch0 -p1
251 %patch1 -p1
252 %patch2 -p1
253 %patch3 -p1
254 %patch4 -p1
255 %patch5 -p1
256 %patch6 -p1
257 %patch7 -p1
258 %patch8 -p1
259
260 %build
261 install -d build
262 cd build
263
264 # handle cmake & ccache
265 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
266 if [[ "%{__cc}" = *ccache* ]]; then
267         cc="%{__cc}"
268         cxx="%{__cxx}"
269         ccache="
270         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
271         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
272         "
273 fi
274
275 %cmake .. \
276         $ccache \
277         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
278         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
279         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
280         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
281         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
282         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
283         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
284         -DBUILD_NEW_PYTHON_SUPPORT=ON \
285 %if %{with examples}
286         -DINSTALL_C_EXAMPLES=ON \
287         -DINSTALL_PYTHON_EXAMPLES=ON \
288 %endif
289         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
290         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
291         %{?with_opencl:-DWITH_OPENCL=ON} \
292         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
293         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
294         %{?with_opengl:-DWITH_OPENGL=ON} \
295         %{?with_gomp:-DWITH_OPENMP=ON} \
296         %{?with_openni:-DWITH_OPENNI=ON} \
297         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
298         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
299         %{?with_tbb:-DWITH_TBB=ON} \
300         %{?with_unicap:-DWITH_UNICAP=ON} \
301         %{!?with_v4l:-DWITH_V4L=OFF} \
302         %{?with_ximea:-DWITH_XIMEA=ON} \
303         %{?with_xine:-DWITH_XINE=ON}
304
305 %{__make}
306
307 %install
308 rm -rf $RPM_BUILD_ROOT
309 %{__make} -C build install \
310         DESTDIR=$RPM_BUILD_ROOT
311
312 # see -doc package
313 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
314 %if %{with examples}
315 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
316 mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
317 %endif
318
319 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
320 cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
321
322 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
323 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
324 %py_postclean
325
326 %if %{with java}
327 # move to proper directories, create symlink
328 install -d $RPM_BUILD_ROOT%{_javadir}
329 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
330 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
331 rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
332 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
333 %endif
334
335 %clean
336 rm -rf $RPM_BUILD_ROOT
337
338 %post   -p /sbin/ldconfig
339 %postun -p /sbin/ldconfig
340
341 %post   core -p /sbin/ldconfig
342 %postun core -p /sbin/ldconfig
343
344 %post   -n java-opencv -p /sbin/ldconfig
345 %postun -n java-opencv -p /sbin/ldconfig
346
347 %files
348 %defattr(644,root,root,755)
349 %attr(755,root,root) %{_bindir}/opencv_createsamples
350 %attr(755,root,root) %{_bindir}/opencv_haartraining
351 %attr(755,root,root) %{_bindir}/opencv_performance
352 %attr(755,root,root) %{_bindir}/opencv_traincascade
353 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.%{sover}
354 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
355 %attr(755,root,root) %{_libdir}/libopencv_contrib.so.%{sover}
356 %attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
357 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.%{sover}
358 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
359 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.%{sover}
360 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
361 %attr(755,root,root) %{_libdir}/libopencv_legacy.so.%{sover}
362 %attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
363 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.%{sover}
364 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
365 %if %{with opencl}
366 %attr(755,root,root) %{_libdir}/libopencv_ocl.so.%{sover}
367 %attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
368 %endif
369 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.%{sover}
370 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
371 %attr(755,root,root) %{_libdir}/libopencv_ts.so.%{sover}
372 %attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
373 %attr(755,root,root) %{_libdir}/libopencv_superres.so.%{sover}
374 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
375 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.%{sover}
376 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
377 %attr(755,root,root) %{_libdir}/libopencv_gpu.so.%{sover}
378 %attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
379 %attr(755,root,root) %{_libdir}/libopencv_nonfree.so.%{sover}
380 %attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
381 %dir %{_datadir}/OpenCV
382 %{_datadir}/OpenCV/haarcascades
383 %{_datadir}/OpenCV/lbpcascades
384
385 %files core
386 %defattr(644,root,root,755)
387 %attr(755,root,root) %{_libdir}/libopencv_core.so.%{sover}
388 %ghost %{_libdir}/libopencv_core.so.2.4
389 %attr(755,root,root) %{_libdir}/libopencv_flann.so.%{sover}
390 %ghost %{_libdir}/libopencv_flann.so.2.4
391 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.%{sover}
392 %ghost %{_libdir}/libopencv_imgproc.so.2.4
393 %attr(755,root,root) %{_libdir}/libopencv_ml.so.%{sover}
394 %ghost %{_libdir}/libopencv_ml.so.2.4
395 %attr(755,root,root) %{_libdir}/libopencv_photo.so.%{sover}
396 %ghost %{_libdir}/libopencv_photo.so.2.4
397 %attr(755,root,root) %{_libdir}/libopencv_video.so.%{sover}
398 %ghost %{_libdir}/libopencv_video.so.2.4
399
400 %files devel
401 %defattr(644,root,root,755)
402 %attr(755,root,root) %{_libdir}/libopencv_*.so
403 %if %{with java}
404 %exclude %{_libdir}/libopencv_java249.so
405 %endif
406 %{_includedir}/opencv
407 %{_includedir}/opencv2
408 %{_datadir}/OpenCV/OpenCV*.cmake
409 %{_pkgconfigdir}/opencv.pc
410
411 %files doc
412 %defattr(644,root,root,755)
413 # TODO: probably could rebuild them and package via make install
414 %doc doc/*
415
416 %if %{with examples}
417 %files examples
418 %defattr(644,root,root,755)
419 %{_examplesdir}/%{name}-%{version}
420 %endif
421
422 %if %{with java}
423 %files -n java-opencv
424 %defattr(644,root,root,755)
425 %attr(755,root,root) %{_libdir}/libopencv_java249.so
426 %{_javadir}/opencv-249.jar
427 %{_javadir}/opencv.jar
428 %endif
429
430 %files -n python-opencv
431 %defattr(644,root,root,755)
432 %attr(755,root,root) %{py_sitedir}/cv2.so
433 %{py_sitedir}/cv.py[co]
This page took 0.054516 seconds and 4 git commands to generate.