]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- updated to 2.4.10.1
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
3 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
4 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
5 #
6 # Conditional build:
7 # - general options:
8 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
9 %bcond_with     sse             # use SSE instructions
10 %bcond_with     sse2            # use SSE2 instructions
11 %bcond_with     sse3            # use SSE3 instructions
12 %bcond_with     ssse3           # use SSSE3 instructions
13 %bcond_with     sse41           # use SSE4.1 instructions
14 %bcond_with     sse42           # use SSE4.2 instructions
15 %bcond_with     avx             # use AVX instructions
16 %bcond_without  opencl          # OpenCL support
17 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
18 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
19 %bcond_without  opengl          # OpenGL support
20 %bcond_without  gomp            # OpenMP support (available when not using tbb)
21 %bcond_without  examples        # Install examples
22 # - bindings
23 %bcond_without  java            # Java binding
24 # - highgui options:
25 %bcond_without  ffmpeg          # FFMpeg support in highgui
26 %bcond_without  gstreamer       # GStreamer support in highgui
27 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
28 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
29 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
30 %bcond_with     unicap          # Unicap support in highgui (GPL)
31 %bcond_without  v4l             # Video4Linux in highgui
32 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
33 %bcond_with     xine            # XINE support in highgui (GPL)
34 # - other modules
35 %bcond_without  vtk             # VTK library support (opencv_viz module)
36
37 %ifarch pentium3 pentium4 %{x8664}
38 %define         with_sse        1
39 %endif
40 %ifarch pentium4 %{x8664}
41 %define         with_sse2       1
42 %endif
43 Summary:        A library of programming functions mainly aimed at real time computer vision
44 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
45 Name:           opencv
46 Version:        2.4.10.1
47 Release:        1
48 Epoch:          1
49 %if %{with unicap} || %{with xine}
50 License:        GPL (enforced by used libraries), BSD (opencv itself)
51 %else
52 License:        BSD
53 %endif
54 Group:          Libraries
55 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
56 # Source0-md5:  f84af999f45edc829bfda60a13fedbaa
57 Patch0:         %{name}-cflags.patch
58 Patch1:         %{name}-x86.patch
59 Patch2:         %{name}-unicap-c++.patch
60 Patch3:         %{name}-c.patch
61 Patch4:         %{name}-gcc.patch
62 Patch5:         %{name}-ximea.patch
63 Patch6:         %{name}-ocl-fft.patch
64 Patch7:         java-ant-sourcelevel.patch
65 Patch8:         %{name}-shared.patch
66 URL:            http://www.opencv.org/
67 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
68 %{?with_opencl:BuildRequires:   OpenCL-devel}
69 BuildRequires:  OpenEXR-devel
70 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
71 %{?with_opengl:BuildRequires:   OpenGL-devel}
72 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
73 %{?with_openni:BuildRequires:   OpenNI-devel}
74 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
75 %{?with_java:BuildRequires:     ant}
76 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
77 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
78 BuildRequires:  cmake >= 2.8
79 BuildRequires:  doxygen
80 BuildRequires:  eigen3 >= 3
81 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
82 %{?with_gomp:BuildRequires:     gcc-c++ >= 6:4.2}
83 %if %{with gstreamer}
84 BuildRequires:  gstreamer-devel >= 1.0
85 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
86 %endif
87 BuildRequires:  jasper-devel
88 %{?with_java:BuildRequires:     jdk}
89 BuildRequires:  libdc1394-devel >= 2
90 %{?with_gomp:BuildRequires:     libgomp-devel}
91 BuildRequires:  libjpeg-devel
92 BuildRequires:  libpng-devel
93 BuildRequires:  libraw1394-devel
94 BuildRequires:  libstdc++-devel
95 BuildRequires:  libtiff-devel
96 BuildRequires:  libtool
97 %if %{with unicap}
98 BuildRequires:  libucil-devel
99 BuildRequires:  libunicap-devel
100 %endif
101 BuildRequires:  libv4l-devel
102 BuildRequires:  pkgconfig
103 BuildRequires:  python >= 2.0
104 BuildRequires:  python-devel >= 2.0
105 BuildRequires:  python-numpy-devel
106 BuildRequires:  rpm-pythonprov
107 BuildRequires:  rpmbuild(macros) >= 1.606
108 BuildRequires:  sed >= 4.0
109 BuildRequires:  sphinx-pdg
110 BuildRequires:  swig-python
111 %{?with_tbb:BuildRequires:      tbb-devel}
112 %if %{with vtk}
113 BuildRequires:  vtk-devel >= 5.8.0
114 BuildRequires:  vtk-java >= 5.8.0
115 BuildRequires:  vtk-tcl >= 5.8.0
116 %endif
117 %{?with_xine:BuildRequires:     xine-lib-devel}
118 BuildRequires:  xorg-lib-libX11-devel
119 BuildRequires:  zlib-devel
120 %if %{with qt}
121 BuildRequires:  QtCore-devel >= 4
122 BuildRequires:  QtGui-devel >= 4
123 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
124 BuildRequires:  qt4-qmake >= 4
125 %else
126 BuildRequires:  gtk+2-devel >= 2.0
127 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
128 %endif
129 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
130 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
131
132 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
133
134 %description
135 OpenCV (Open Source Computer Vision) is a library of programming
136 functions mainly aimed at real time computer vision.
137
138 Example applications of the OpenCV library are:
139 - Human-Computer Interaction (HCI)
140 - Object Identification, Segmentation and Recognition
141 - Face Recognition
142 - Gesture Recognition
143 - Motion Tracking
144 - Ego Motion, Motion Understanding
145 - Structure From Motion (SFM)
146 - Stereo and Multi-Camera Calibration and Depth Computation
147 - Mobile Robotics.
148
149 %description -l pl.UTF-8
150 OpenCV (Open Source Computer Vision) to biblioteka funkcji
151 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
152
153 Przykładowe zastosowania biblioteki OpenCV to
154 - interakcje człowiek-komputer (HCI)
155 - identyfikacja, segmentacja i rozpoznawanie obiektów
156 - rozpoznawanie twarzy
157 - rozpoznawanie gestów
158 - śledzenie ruchu
159 - rozumienie ruchu
160 - SFM (Structure From Motion)
161 - kalibracja dwu- i wielokamerowa, obliczanie głębi
162 - robotyka ruchu.
163
164 %package core
165 Summary:        OpenCV core libraries
166 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
167 Group:          Libraries
168 Conflicts:      opencv < 2.4.6.2-1
169
170 %description core
171 This package contains the OpenCV C/C++ core libraries.
172
173 %description core -l pl.UTF-8
174 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
175
176 %package viz
177 Summary:        OpenCV viz library (VTK support)
178 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
179 Group:          Libraries
180 Requires:       %{name} = %{epoch}:%{version}-%{release}
181
182 %description viz
183 OpenCV viz library (VTK support).
184
185 %description viz -l pl.UTF-8
186 Biblioteka OpenCV viz (obsługa VTK).
187
188 %package devel
189 Summary:        Header files for OpenCV library
190 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
191 Group:          Development/Libraries
192 Requires:       %{name} = %{epoch}:%{version}-%{release}
193 %if %{with vtk}
194 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
195 %endif
196 Obsoletes:      opencv-static
197
198 %description devel
199 Header files for OpenCV library.
200
201 %description devel -l pl.UTF-8
202 Pliki nagłówkowe biblioteki OpenCV.
203
204 %package doc
205 Summary:        Manual for OpenCV
206 Summary(fr.UTF-8):      Documentation pour OpenCV
207 Summary(it.UTF-8):      Documentazione di OpenCV
208 Summary(pl.UTF-8):      Podręcznik dla OpenCV
209 Group:          Documentation
210 # noarch subpackages only when building with rpm5
211 %if "%{_rpmversion}" >= "5"
212 BuildArch:      noarch
213 %endif
214
215 %description doc
216 Documentation for OpenCV.
217
218 %description doc -l fr.UTF-8
219 Documentation pour OpenCV.
220
221 %description doc -l it.UTF-8
222 Documentazione di OpenCV.
223
224 %description doc -l pl.UTF-8
225 Dokumentacja do OpenCV.
226
227 %package examples
228 Summary:        OpenCV code examples
229 Group:          Documentation
230 %if "%{_rpmversion}" >= "5"
231 BuildArch:      noarch
232 %endif
233
234 %description examples
235 OpenCV code examples.
236
237 %package -n java-opencv
238 Summary:        OpenCV Java bindings
239 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
240 Group:          Libraries/Java
241 Requires:       %{name} = %{epoch}:%{version}-%{release}
242 Requires:       jre
243
244 %description -n java-opencv
245 OpenCV Java bindings.
246
247 %description -n java-opencv -l pl.UTF-8
248 Wiązania Javy do OpenCV.
249
250 %package -n python-opencv
251 Summary:        OpenCV Python bindings
252 Summary(pl.UTF-8):      Wiązania Pythona do OpenCV
253 Group:          Libraries/Python
254 Requires:       %{name} = %{epoch}:%{version}-%{release}
255 Requires:       python-libs
256
257 %description -n python-opencv
258 OpenCV Python bindings.
259
260 %description -n python-opencv -l pl.UTF-8
261 Wiązania Pythona do OpenCV.
262
263 %prep
264 %setup -q
265
266 %undos CMakeLists.txt
267 %undos modules/gpu/CMakeLists.txt
268
269 %patch0 -p1
270 %patch1 -p1
271 %patch2 -p1
272 %patch3 -p1
273 %patch4 -p1
274 %patch5 -p1
275 %patch6 -p1
276 %patch7 -p1
277 %patch8 -p1
278
279 %build
280 install -d build
281 cd build
282
283 # handle cmake & ccache
284 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
285 if [[ "%{__cc}" = *ccache* ]]; then
286         cc="%{__cc}"
287         cxx="%{__cxx}"
288         ccache="
289         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
290         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
291         "
292 fi
293
294 %cmake .. \
295         $ccache \
296         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
297         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
298         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
299         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
300         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
301         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
302         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
303         -DBUILD_NEW_PYTHON_SUPPORT=ON \
304 %if %{with examples}
305         -DINSTALL_C_EXAMPLES=ON \
306         -DINSTALL_PYTHON_EXAMPLES=ON \
307 %endif
308         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
309         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
310         %{?with_opencl:-DWITH_OPENCL=ON} \
311         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
312         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
313         %{?with_opengl:-DWITH_OPENGL=ON} \
314         %{?with_gomp:-DWITH_OPENMP=ON} \
315         %{?with_openni:-DWITH_OPENNI=ON} \
316         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
317         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
318         %{?with_tbb:-DWITH_TBB=ON} \
319         %{?with_unicap:-DWITH_UNICAP=ON} \
320         %{!?with_v4l:-DWITH_V4L=OFF} \
321         %{?with_vtk:-DWITH_VTK=ON} \
322         %{?with_ximea:-DWITH_XIMEA=ON} \
323         %{?with_xine:-DWITH_XINE=ON}
324
325 %{__make}
326
327 %install
328 rm -rf $RPM_BUILD_ROOT
329 %{__make} -C build install \
330         DESTDIR=$RPM_BUILD_ROOT
331
332 # see -doc package
333 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
334 %if %{with examples}
335 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
336 mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
337 %endif
338
339 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
340 cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
341
342 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
343 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
344 %py_postclean
345
346 %if %{with java}
347 # move to proper directories, create symlink
348 install -d $RPM_BUILD_ROOT%{_javadir}
349 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
350 sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
351         $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
352 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
353 rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
354 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
355 %endif
356
357 %clean
358 rm -rf $RPM_BUILD_ROOT
359
360 %post   -p /sbin/ldconfig
361 %postun -p /sbin/ldconfig
362
363 %post   core -p /sbin/ldconfig
364 %postun core -p /sbin/ldconfig
365
366 %post   viz -p /sbin/ldconfig
367 %postun viz -p /sbin/ldconfig
368
369 %post   -n java-opencv -p /sbin/ldconfig
370 %postun -n java-opencv -p /sbin/ldconfig
371
372 %files
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{_bindir}/opencv_createsamples
375 %attr(755,root,root) %{_bindir}/opencv_haartraining
376 %attr(755,root,root) %{_bindir}/opencv_performance
377 %attr(755,root,root) %{_bindir}/opencv_traincascade
378 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
379 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
380 %attr(755,root,root) %{_libdir}/libopencv_contrib.so.*.*.*
381 %attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
382 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
383 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
384 %attr(755,root,root) %{_libdir}/libopencv_gpu.so.*.*.*
385 %attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
386 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
387 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
388 %attr(755,root,root) %{_libdir}/libopencv_legacy.so.*.*.*
389 %attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
390 %attr(755,root,root) %{_libdir}/libopencv_nonfree.so.*.*.*
391 %attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
392 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
393 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
394 %if %{with opencl}
395 %attr(755,root,root) %{_libdir}/libopencv_ocl.so.*.*.*
396 %attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
397 %endif
398 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
399 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
400 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
401 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
402 %attr(755,root,root) %{_libdir}/libopencv_ts.so.*.*.*
403 %attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
404 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
405 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
406 %dir %{_datadir}/OpenCV
407 %{_datadir}/OpenCV/haarcascades
408 %{_datadir}/OpenCV/lbpcascades
409
410 %files core
411 %defattr(644,root,root,755)
412 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
413 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
414 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
415 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
416 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
417 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
418 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
419 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
420 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
421 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
422 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
423 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
424
425 %if %{with vtk}
426 %files viz
427 %defattr(644,root,root,755)
428 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
429 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
430 %endif
431
432 %files devel
433 %defattr(644,root,root,755)
434 # core
435 %attr(755,root,root) %{_libdir}/libopencv_core.so
436 %attr(755,root,root) %{_libdir}/libopencv_flann.so
437 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so
438 %attr(755,root,root) %{_libdir}/libopencv_ml.so
439 %attr(755,root,root) %{_libdir}/libopencv_photo.so
440 %attr(755,root,root) %{_libdir}/libopencv_video.so
441 # GUI/extensions (base package)
442 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so
443 %attr(755,root,root) %{_libdir}/libopencv_contrib.so
444 %attr(755,root,root) %{_libdir}/libopencv_features2d.so
445 %attr(755,root,root) %{_libdir}/libopencv_gpu.so
446 %attr(755,root,root) %{_libdir}/libopencv_highgui.so
447 %attr(755,root,root) %{_libdir}/libopencv_legacy.so
448 %attr(755,root,root) %{_libdir}/libopencv_nonfree.so
449 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so
450 %if %{with opencl}
451 %attr(755,root,root) %{_libdir}/libopencv_ocl.so
452 %endif
453 %attr(755,root,root) %{_libdir}/libopencv_stitching.so
454 %attr(755,root,root) %{_libdir}/libopencv_superres.so
455 %attr(755,root,root) %{_libdir}/libopencv_ts.so
456 %attr(755,root,root) %{_libdir}/libopencv_videostab.so
457 # viz
458 %if %{with vtk}
459 %attr(755,root,root) %{_libdir}/libopencv_viz.so
460 %endif
461 %{_includedir}/opencv
462 %{_includedir}/opencv2
463 %{_datadir}/OpenCV/OpenCV*.cmake
464 %{_pkgconfigdir}/opencv.pc
465
466 %files doc
467 %defattr(644,root,root,755)
468 # TODO: probably could rebuild them and package via make install
469 %doc doc/*
470
471 %if %{with examples}
472 %files examples
473 %defattr(644,root,root,755)
474 %{_examplesdir}/%{name}-%{version}
475 %endif
476
477 %if %{with java}
478 %files -n java-opencv
479 %defattr(644,root,root,755)
480 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
481 %{_javadir}/opencv-%{jver}.jar
482 %{_javadir}/opencv.jar
483 %endif
484
485 %files -n python-opencv
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{py_sitedir}/cv2.so
488 %{py_sitedir}/cv.py[co]
This page took 0.085615 seconds and 4 git commands to generate.