]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
e53d97c1bdcc859046f8aec0fde1c954e6443cd7
[packages/opencv.git] / opencv.spec
1 #
2 # TODO: - CUDA support (on bcond)
3 #       - consider name change to OpenCV
4 #
5 # Conditional build:
6 %bcond_without  gstreamer       # GStreamer support
7 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support
8 %bcond_with     qt              # Qt backend instead of GTK+
9 %bcond_with     tbb             # Threading Building Blocks support
10 %bcond_with     unicap          # Unicap support (GPL)
11 %bcond_with     v4l             # Video4Linux (even V4L2 support currently relies on V4L1 API)
12 %bcond_with     xine            # XINE support (GPL)
13 #
14 Summary:        A library of programming functions mainly aimed at real time computer vision
15 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
16 Name:           opencv
17 Version:        2.3.1
18 Release:        1
19 Epoch:          1
20 %if %{with unicap} || %{with xine}
21 License:        GPL (enforced by used libraries), BSD (opencv itself)
22 %else
23 License:        BSD
24 %endif
25 Group:          Libraries
26 Source0:        http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}a.tar.bz2
27 # Source0-md5:  82e4b6bfa349777233eea09b075e931e
28 Patch0:         %{name}-cflags.patch
29 Patch1:         %{name}-link.patch
30 Patch2:         %{name}-unicap-c++.patch
31 Patch3:         %{name}-c.patch
32 Patch4:         %{name}-gcc.patch
33 URL:            http://opencv.willowgarage.com/
34 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
35 BuildRequires:  OpenEXR-devel
36 BuildRequires:  cmake >= 2.4
37 BuildRequires:  doxygen
38 BuildRequires:  eigen >= 2
39 BuildRequires:  ffmpeg-devel >= 0.7
40 %if %{with gstreamer}
41 BuildRequires:  gstreamer-devel >= 0.10
42 BuildRequires:  gstreamer-plugins-base-devel >= 0.10
43 %endif
44 BuildRequires:  jasper-devel
45 BuildRequires:  libdc1394-devel
46 BuildRequires:  libjpeg-devel
47 BuildRequires:  libpng-devel
48 BuildRequires:  libraw1394-devel
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  libtiff-devel
51 BuildRequires:  libtool
52 %if %{with unicap}
53 BuildRequires:  libucil-devel
54 BuildRequires:  libunicap-devel
55 %endif
56 BuildRequires:  libv4l-devel
57 BuildRequires:  pkgconfig
58 BuildRequires:  python-devel
59 BuildRequires:  python-numpy-devel
60 BuildRequires:  rpm-pythonprov
61 BuildRequires:  rpmbuild(macros) >= 1.600
62 BuildRequires:  sed >= 4.0
63 BuildRequires:  swig-python
64 %{?with_tbb:BuildRequires:      tbb-devel}
65 %{?with_xine:BuildRequires:     xine-lib-devel}
66 BuildRequires:  zlib-devel
67 %if %{with qt}
68 BuildRequires:  OpenGL-devel
69 BuildRequires:  QtCore-devel >= 4
70 BuildRequires:  QtGui-devel >= 4
71 BuildRequires:  QtOpenGL-devel >= 4
72 BuildRequires:  qt4-qmake >= 4
73 %else
74 BuildRequires:  gtk+2-devel >= 2.0
75 %endif
76 # ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 OpenCV (Open Source Computer Vision) is a library of programming
81 functions mainly aimed at real time computer vision.
82
83 Example applications of the OpenCV library are:
84 - Human-Computer Interaction (HCI)
85 - Object Identification, Segmentation and Recognition
86 - Face Recognition
87 - Gesture Recognition
88 - Motion Tracking
89 - Ego Motion, Motion Understanding
90 - Structure From Motion (SFM)
91 - Stereo and Multi-Camera Calibration and Depth Computation
92 - Mobile Robotics.
93
94 %description -l pl.UTF-8
95 OpenCV (Open Source Computer Vision) to biblioteka funkcji
96 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
97
98 Przykładowe zastosowania biblioteki OpenCV to
99 - interakcje człowiek-komputer (HCI)
100 - identyfikacja, segmentacja i rozpoznawanie obiektów
101 - rozpoznawanie twarzy
102 - rozpoznawanie gestów
103 - śledzenie ruchu
104 - rozumienie ruchu
105 - SFM (Structure From Motion)
106 - kalibracja dwu- i wielokamerowa, obliczanie głębi
107 - robotyka ruchu.
108
109 %package devel
110 Summary:        Header files for OpenCV library
111 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
112 Group:          Development/Libraries
113 Requires:       %{name} = %{epoch}:%{version}-%{release}
114 Obsoletes:      opencv-static
115
116 %description devel
117 Header files for OpenCV library.
118
119 %description devel -l pl.UTF-8
120 Pliki nagłówkowe biblioteki OpenCV.
121
122 %package -n python-opencv
123 Summary:        OpenCV Python bindings
124 Summary(pl.UTF-8):      Wiązania Pythona do OpenCV
125 Group:          Libraries/Python
126 Requires:       %{name} = %{epoch}:%{version}-%{release}
127 %pyrequires_eq  python-libs
128
129 %description -n python-opencv
130 OpenCV Python bindings.
131
132 %description -n python-opencv -l pl.UTF-8
133 Wiązania Pythona do OpenCV.
134
135 %prep
136 %setup -q -n OpenCV-%{version}
137
138 %undos CMakeLists.txt
139 %undos modules/gpu/CMakeLists.txt
140
141 %patch0 -p1
142 %patch1 -p1
143 %patch2 -p1
144 %patch3 -p1
145 %patch4 -p1
146
147 %build
148 install -d build
149 cd build
150 %cmake .. \
151         -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
152         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
153 %ifarch pentium4 %{x8664}
154         -DENABLE_SSE=ON \
155         -DENABLE_SSE2=ON \
156 %else
157         -DENABLE_SSE=OFF \
158         -DENABLE_SSE2=OFF \
159 %endif
160         -DBUILD_NEW_PYTHON_SUPPORT=ON \
161         -DUSE_O3=OFF \
162         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
163         %{!?with_pvapi:-DWITH_PVAPI=OFF} \
164         %{?with_qt:-DWITH_QT=ON -DWITH_QT_OPENGL=ON -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
165         %{?with_tbb:-DWITH_TBB=ON} \
166         %{?with_unicap:-DWITH_UNICAP=ON} \
167         %{!?with_v4l:-DWITH_V4L=OFF} \
168         %{?with_xine:-DWITH_XINE=ON}
169
170 %{__make}
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174
175 %{__make} -C build install \
176         DESTDIR=$RPM_BUILD_ROOT
177
178 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
179 install build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
180
181 %if "%{_lib}" == "lib64"
182 # upstream has no lib64 support
183 mv $RPM_BUILD_ROOT%{_prefix}/lib/lib*.so* $RPM_BUILD_ROOT%{_libdir}
184 %endif
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %post   -p /sbin/ldconfig
190 %postun -p /sbin/ldconfig
191
192 %files
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_bindir}/opencv_*
195 %attr(755,root,root) %{_libdir}/libopencv_*.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libopencv_*.so.2.3
197 %dir %{_datadir}/OpenCV
198 %doc %{_datadir}/OpenCV/doc
199 %{_datadir}/OpenCV/haarcascades
200 %{_datadir}/OpenCV/lbpcascades
201
202 %files devel
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/libopencv_*.so
205 %{_includedir}/opencv
206 %{_includedir}/opencv2
207 %{_datadir}/OpenCV/OpenCVConfig*.cmake
208 %{_pkgconfigdir}/opencv.pc
209
210 %files -n python-opencv
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{py_sitedir}/cv2.so
213 %{py_sitedir}/cv.py
This page took 0.040748 seconds and 2 git commands to generate.