]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- add missing header, rel 5
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - contrib subpackage(s)
3 # - contrib BRs:
4 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7 #   opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8 #   opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9 #   opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
10 # unpackaged (3.4.0)
11 #/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12 #/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13 #/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14 #/usr/share/OpenCV/valgrind.supp
15 #/usr/share/OpenCV/valgrind_3rdparty.supp
16
17 #
18 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
19 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
20 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
21 #
22 # Conditional build:
23 # - general options:
24 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
25 %bcond_with     sse             # use SSE instructions
26 %bcond_with     sse2            # use SSE2 instructions
27 %bcond_with     sse3            # use SSE3 instructions
28 %bcond_with     ssse3           # use SSSE3 instructions
29 %bcond_with     sse41           # use SSE4.1 instructions
30 %bcond_with     sse42           # use SSE4.2 instructions
31 %bcond_with     avx             # use AVX instructions
32 %bcond_without  opencl          # OpenCL support
33 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
34 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
35 %bcond_without  opengl          # OpenGL support
36 %bcond_without  openmp          # OpenMP support (available when not using tbb)
37 %bcond_without  examples        # Install examples
38 # - bindings
39 %bcond_without  java            # Java binding
40 # - highgui options:
41 %bcond_without  ffmpeg          # FFMpeg support in highgui
42 %bcond_without  gstreamer       # GStreamer support in highgui
43 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
44 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
45 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
46 %bcond_with     unicap          # Unicap support in highgui (GPL)
47 %bcond_without  v4l             # Video4Linux in highgui
48 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
49 %bcond_with     xine            # XINE support in highgui (GPL)
50 # - other modules
51 %bcond_without  vtk             # VTK library support (opencv_viz module)
52
53 %ifarch pentium3 pentium4 %{x8664} x32
54 %define         with_sse        1
55 %endif
56 %ifarch pentium4 %{x8664} x32
57 %define         with_sse2       1
58 %endif
59 Summary:        A library of programming functions mainly aimed at real time computer vision
60 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
61 Name:           opencv
62 Version:        4.5.1
63 Release:        5
64 Epoch:          1
65 %if %{with unicap} || %{with xine}
66 License:        GPL (enforced by used libraries), BSD (opencv itself)
67 %else
68 License:        BSD
69 %endif
70 Group:          Libraries
71 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
72 # Source0-md5:  2205d3169238ec1f184438a96de68513
73 Source1:        https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
74 # Source1-md5:  19a31bf7271978ab426112dbf5d1b83f
75 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76 Source10:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77 # Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78 Source11:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79 # Source11-md5: 232c966b13651bd0e46a1497b0852191
80 Source12:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81 # Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82 Source13:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83 # Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84 Source14:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85 # Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86 Source15:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87 # Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88 Source16:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89 # Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91 Source20:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92 # Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93 Source21:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94 # Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95 Source22:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96 # Source22-md5: 7cd47228edec52b6d82f46511af325c5
97 Source23:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98 # Source23-md5: 151805e03568c9f490a5e3a872777b75
99 # See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
100 Source30:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101 # Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
102 # See opencv-4.5.1/modules/gapi/CMakeLists.txt
103 Source40:       https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
104 # Source40-md5: b624b995ec9c439cbc2e9e6ee940d3a2
105 Patch0:         %{name}-ximea.patch
106 Patch1:         python-install.patch
107 Patch2:         pkgconfig-paths.patch
108 Patch3:         no-cxx-in-c-header.patch
109 Patch4:         gcc11.patch
110 URL:            http://www.opencv.org/
111 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
112 %{?with_opencl:BuildRequires:   OpenCL-devel}
113 BuildRequires:  Mesa-khrplatform-devel
114 BuildRequires:  OpenEXR-devel
115 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
116 %{?with_opengl:BuildRequires:   OpenGL-devel}
117 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
118 %{?with_openni:BuildRequires:   OpenNI-devel}
119 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
120 %{?with_java:BuildRequires:     ant}
121 BuildRequires:  boost-devel
122 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
123 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
124 BuildRequires:  cmake >= 2.8
125 BuildRequires:  doxygen
126 BuildRequires:  eigen3 >= 3
127 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
128 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
129 BuildRequires:  gflags-devel
130 BuildRequires:  gl2ps-devel
131 BuildRequires:  glog-devel
132 %if %{with gstreamer}
133 BuildRequires:  gstreamer-devel >= 1.0
134 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
135 %endif
136 BuildRequires:  jasper-devel
137 %{?with_java:BuildRequires:     jdk}
138 BuildRequires:  libdc1394-devel >= 2
139 %{?with_openmp:BuildRequires:   libgomp-devel}
140 BuildRequires:  libjpeg-devel
141 BuildRequires:  libpng-devel
142 BuildRequires:  libraw1394-devel
143 BuildRequires:  libstdc++-devel
144 BuildRequires:  libtiff-devel
145 BuildRequires:  libtool
146 %if %{with unicap}
147 BuildRequires:  libucil-devel
148 BuildRequires:  libunicap-devel
149 %endif
150 BuildRequires:  libv4l-devel
151 BuildRequires:  ogre-devel
152 BuildRequires:  pkgconfig
153 BuildRequires:  hdf5-devel
154 BuildRequires:  protobuf-devel
155 BuildRequires:  python >= 2.0
156 BuildRequires:  python-devel >= 2.0
157 BuildRequires:  python-numpy-devel
158 BuildRequires:  python3 >= 1:3.2
159 BuildRequires:  python3-devel >= 1:3.2
160 BuildRequires:  python3-numpy-devel
161 BuildRequires:  rpm-pythonprov
162 BuildRequires:  rpmbuild(macros) >= 1.606
163 BuildRequires:  sed >= 4.0
164 BuildRequires:  sphinx-pdg
165 BuildRequires:  swig-python
166 %{?with_tbb:BuildRequires:      tbb-devel}
167 %if %{with vtk}
168 BuildRequires:  vtk-devel >= 5.8.0
169 BuildRequires:  vtk-java >= 5.8.0
170 BuildRequires:  vtk-python3-devel >= 5.8.0
171 %endif
172 %{?with_xine:BuildRequires:     xine-lib-devel}
173 BuildRequires:  xorg-lib-libX11-devel
174 BuildRequires:  zlib-devel
175 %if %{with qt}
176 BuildRequires:  QtCore-devel >= 4
177 BuildRequires:  QtGui-devel >= 4
178 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
179 BuildRequires:  qt4-qmake >= 4
180 %else
181 BuildRequires:  gtk+2-devel >= 2.0
182 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
183 %endif
184 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
185 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
186
187 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
188 %define         sover   %(echo %{version} | cut -d. -f1-2)
189
190 %description
191 OpenCV (Open Source Computer Vision) is a library of programming
192 functions mainly aimed at real time computer vision.
193
194 Example applications of the OpenCV library are:
195 - Human-Computer Interaction (HCI)
196 - Object Identification, Segmentation and Recognition
197 - Face Recognition
198 - Gesture Recognition
199 - Motion Tracking
200 - Ego Motion, Motion Understanding
201 - Structure From Motion (SFM)
202 - Stereo and Multi-Camera Calibration and Depth Computation
203 - Mobile Robotics.
204
205 %description -l pl.UTF-8
206 OpenCV (Open Source Computer Vision) to biblioteka funkcji
207 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
208
209 Przykładowe zastosowania biblioteki OpenCV to
210 - interakcje człowiek-komputer (HCI)
211 - identyfikacja, segmentacja i rozpoznawanie obiektów
212 - rozpoznawanie twarzy
213 - rozpoznawanie gestów
214 - śledzenie ruchu
215 - rozumienie ruchu
216 - SFM (Structure From Motion)
217 - kalibracja dwu- i wielokamerowa, obliczanie głębi
218 - robotyka ruchu.
219
220 %package core
221 Summary:        OpenCV core libraries
222 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
223 Group:          Libraries
224 Conflicts:      opencv < 2.4.6.2-1
225
226 %description core
227 This package contains the OpenCV C/C++ core libraries.
228
229 %description core -l pl.UTF-8
230 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
231
232 %package viz
233 Summary:        OpenCV viz library (VTK support)
234 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
235 Group:          Libraries
236 Requires:       %{name} = %{epoch}:%{version}-%{release}
237
238 %description viz
239 OpenCV viz library (VTK support).
240
241 %description viz -l pl.UTF-8
242 Biblioteka OpenCV viz (obsługa VTK).
243
244 %package devel
245 Summary:        Header files for OpenCV library
246 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
247 Group:          Development/Libraries
248 Requires:       %{name} = %{epoch}:%{version}-%{release}
249 %if %{with vtk}
250 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
251 %endif
252 Obsoletes:      opencv-static
253
254 %description devel
255 Header files for OpenCV library.
256
257 %description devel -l pl.UTF-8
258 Pliki nagłówkowe biblioteki OpenCV.
259
260 %package doc
261 Summary:        Manual for OpenCV
262 Summary(fr.UTF-8):      Documentation pour OpenCV
263 Summary(it.UTF-8):      Documentazione di OpenCV
264 Summary(pl.UTF-8):      Podręcznik dla OpenCV
265 Group:          Documentation
266 # noarch subpackages only when building with rpm5
267 BuildArch:      noarch
268
269 %description doc
270 Documentation for OpenCV.
271
272 %description doc -l fr.UTF-8
273 Documentation pour OpenCV.
274
275 %description doc -l it.UTF-8
276 Documentazione di OpenCV.
277
278 %description doc -l pl.UTF-8
279 Dokumentacja do OpenCV.
280
281 %package examples
282 Summary:        OpenCV code examples
283 Group:          Documentation
284 BuildArch:      noarch
285
286 %description examples
287 OpenCV code examples.
288
289 %package -n java-opencv
290 Summary:        OpenCV Java bindings
291 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
292 Group:          Libraries/Java
293 Requires:       %{name} = %{epoch}:%{version}-%{release}
294 Requires:       jre
295
296 %description -n java-opencv
297 OpenCV Java bindings.
298
299 %description -n java-opencv -l pl.UTF-8
300 Wiązania Javy do OpenCV.
301
302 %package -n python-opencv
303 Summary:        OpenCV Python 2 bindings
304 Summary(pl.UTF-8):      Wiązania Pythona 2 do OpenCV
305 Group:          Libraries/Python
306 Requires:       %{name} = %{epoch}:%{version}-%{release}
307 Requires:       python-libs
308
309 %description -n python-opencv
310 OpenCV Python 2 bindings.
311
312 %description -n python-opencv -l pl.UTF-8
313 Wiązania Pythona 2 do OpenCV.
314
315 %package -n python3-opencv
316 Summary:        OpenCV Python 3 bindings
317 Summary(pl.UTF-8):      Wiązania Pythona 3 do OpenCV
318 Group:          Libraries/Python
319 Requires:       %{name} = %{epoch}:%{version}-%{release}
320 Requires:       python3-libs
321
322 %description -n python3-opencv
323 OpenCV Python 3 bindings.
324
325 %description -n python3-opencv -l pl.UTF-8
326 Wiązania Pythona 3 do OpenCV.
327
328 %prep
329 %setup -q -a1
330
331 %undos CMakeLists.txt
332
333 %patch0 -p1
334 %patch1 -p1
335 %patch2 -p1
336 %patch3 -p1
337 %patch4 -p1
338
339 cache_file() {
340         f="$1"
341         d="$2"
342         md5="$(md5sum "$f" | awk '{print $1}')"
343         file="$(basename "$f")"
344         mkdir -p ".cache/$d"
345         ln -s --relative "$f" ".cache/$d/$md5-$file"
346 }
347 for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
348         cache_file $f xfeatures2d/boostdesc
349 done
350 for f in %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}; do
351         cache_file $f xfeatures2d/vgg
352 done
353 cache_file %{SOURCE30} data
354 cache_file %{SOURCE40} ade
355
356 %build
357 mkdir -p build
358 cd build
359
360 # handle cmake & ccache
361 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
362 if [[ "%{__cc}" = *ccache* ]]; then
363         cc="%{__cc}"
364         cxx="%{__cxx}"
365         ccache="
366         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
367         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
368         "
369 fi
370
371 %cmake .. \
372         $ccache \
373         -DENABLE_PRECOMPILED_HEADERS=OFF \
374         -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
375         -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
376         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
377         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
378         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
379         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
380         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
381         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
382         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
383         -DBUILD_NEW_PYTHON_SUPPORT=ON \
384         -DOPENCV_GENERATE_PKGCONFIG:BOOL=ON \
385 %if %{with examples}
386         -DINSTALL_C_EXAMPLES=ON \
387         -DINSTALL_PYTHON_EXAMPLES=ON \
388 %endif
389         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
390         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
391         %{?with_opencl:-DWITH_OPENCL=ON} \
392         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
393         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
394         %{?with_opengl:-DWITH_OPENGL=ON} \
395         %{?with_openmp:-DWITH_OPENMP=ON} \
396         %{?with_openni:-DWITH_OPENNI=ON} \
397         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
398         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
399         %{?with_tbb:-DWITH_TBB=ON} \
400         %{?with_unicap:-DWITH_UNICAP=ON} \
401         %{!?with_v4l:-DWITH_V4L=OFF} \
402         %{?with_vtk:-DWITH_VTK=ON} \
403         %{?with_ximea:-DWITH_XIMEA=ON} \
404         %{?with_xine:-DWITH_XINE=ON} \
405         -DWITH_IPP=OFF
406
407 %{__make}
408
409 %install
410 rm -rf $RPM_BUILD_ROOT
411 %{__make} -C build install \
412         DESTDIR=$RPM_BUILD_ROOT
413
414 %if %{with examples}
415 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
416 mv $RPM_BUILD_ROOT%{_datadir}/opencv4/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
417 %endif
418
419 # disable completeness check incompatible with split packaging
420 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules.cmake
421
422 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
423 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
424 %py_postclean
425
426 %if %{with java}
427 # move to proper directories, create symlink
428 install -d $RPM_BUILD_ROOT%{_javadir}
429 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
430 sed -i -e 's#/share/java/opencv4/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
431         $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules-pld.cmake
432 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
433 rmdir $RPM_BUILD_ROOT%{_javadir}/opencv4
434 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
435 %endif
436
437 %clean
438 rm -rf $RPM_BUILD_ROOT
439
440 %post   -p /sbin/ldconfig
441 %postun -p /sbin/ldconfig
442
443 %post   core -p /sbin/ldconfig
444 %postun core -p /sbin/ldconfig
445
446 %post   viz -p /sbin/ldconfig
447 %postun viz -p /sbin/ldconfig
448
449 %post   -n java-opencv -p /sbin/ldconfig
450 %postun -n java-opencv -p /sbin/ldconfig
451
452 %files
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_bindir}/opencv_annotation
455 #%attr(755,root,root) %{_bindir}/opencv_createsamples
456 %attr(755,root,root) %{_bindir}/opencv_interactive-calibration
457 #%attr(755,root,root) %{_bindir}/opencv_traincascade
458 %attr(755,root,root) %{_bindir}/opencv_version
459 %attr(755,root,root) %{_bindir}/opencv_visualisation
460 %attr(755,root,root) %{_bindir}/setup_vars_opencv4.sh
461 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
462 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
463 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
464 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
465 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
466 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
467 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
468 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
469 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
470 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
471 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
472 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
473 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
474 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
475 # contrib modules
476 %attr(755,root,root) %{_bindir}/opencv_waldboost_detector
477 %attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
478 %attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
479 %attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
480 %attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
481 %attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
482 %attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
483 %attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
484 %attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
485 %attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
486 %attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
487 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
488 %attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
489 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
490 %attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
491 %attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
492 %attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
493 %attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
494 %attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
495 %attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
496 %attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
497 %attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
498 %attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
499 %attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
500 %attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
501 %attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
502 %attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
503 %attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
504 %attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
505 %attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
506 %attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
507 %attr(755,root,root) %ghost %{_libdir}/libopencv_ovis.so.%{sover}
508 %attr(755,root,root) %{_libdir}/libopencv_ovis.so.*.*.*
509 %attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
510 %attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
511 %attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
512 %attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
513 %attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
514 %attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
515 %attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
516 %attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
517 %attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
518 %attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
519 %attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
520 %attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
521 %attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
522 %attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
523 %attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
524 %attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
525 %attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
526 %attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
527 %attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
528 %attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
529 %attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
530 %attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
531 %attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
532 %attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
533 %attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
534 %attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
535 %attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
536 %attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
537 %attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
538 %attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
539 %attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
540 %attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
541 %attr(755,root,root) %ghost %{_libdir}/libopencv_alphamat.so.%{sover}
542 %attr(755,root,root) %{_libdir}/libopencv_alphamat.so.*.*.*
543 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_superres.so.%{sover}
544 %attr(755,root,root) %{_libdir}/libopencv_dnn_superres.so.*.*.*
545 %attr(755,root,root) %ghost %{_libdir}/libopencv_gapi.so.%{sover}
546 %attr(755,root,root) %{_libdir}/libopencv_gapi.so.*.*.*
547 %attr(755,root,root) %ghost %{_libdir}/libopencv_intensity_transform.so.%{sover}
548 %attr(755,root,root) %{_libdir}/libopencv_intensity_transform.so.*.*.*
549 %attr(755,root,root) %ghost %{_libdir}/libopencv_mcc.so.%{sover}
550 %attr(755,root,root) %{_libdir}/libopencv_mcc.so.*.*.*
551 %attr(755,root,root) %ghost %{_libdir}/libopencv_quality.so.%{sover}
552 %attr(755,root,root) %{_libdir}/libopencv_quality.so.*.*.*
553 %attr(755,root,root) %ghost %{_libdir}/libopencv_rapid.so.%{sover}
554 %attr(755,root,root) %{_libdir}/libopencv_rapid.so.*.*.*
555
556 %dir %{_datadir}/opencv4
557 %{_datadir}/opencv4/haarcascades
558 %{_datadir}/opencv4/lbpcascades
559 %{_datadir}/opencv4/quality
560
561 %files core
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
564 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
565 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
566 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
567 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
569 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
570 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
571 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
572 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
573 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
574 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
575 %attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
576 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
577 %attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
578 %attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
579 %attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
580 %attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
581
582 %if %{with vtk}
583 %files viz
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
586 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
587 %endif
588
589 %files devel
590 %defattr(644,root,root,755)
591 # core
592 %{_libdir}/libopencv_core.so
593 %{_libdir}/libopencv_flann.so
594 %{_libdir}/libopencv_imgproc.so
595 %{_libdir}/libopencv_ml.so
596 %{_libdir}/libopencv_photo.so
597 %{_libdir}/libopencv_video.so
598 # GUI/extensions (base package)
599 %{_libdir}/libopencv_calib3d.so
600 %{_libdir}/libopencv_features2d.so
601 %{_libdir}/libopencv_highgui.so
602 %{_libdir}/libopencv_objdetect.so
603 %{_libdir}/libopencv_stitching.so
604 %{_libdir}/libopencv_superres.so
605 %{_libdir}/libopencv_videostab.so
606 %{_libdir}/libopencv_imgcodecs.so
607 %{_libdir}/libopencv_shape.so
608 %{_libdir}/libopencv_videoio.so
609 # contrib
610 %{_libdir}/libopencv_aruco.so
611 %{_libdir}/libopencv_bgsegm.so
612 %{_libdir}/libopencv_bioinspired.so
613 %{_libdir}/libopencv_ccalib.so
614 %{_libdir}/libopencv_datasets.so
615 %{_libdir}/libopencv_dnn.so
616 %{_libdir}/libopencv_dnn_objdetect.so
617 %{_libdir}/libopencv_dpm.so
618 %{_libdir}/libopencv_face.so
619 %{_libdir}/libopencv_freetype.so
620 %{_libdir}/libopencv_fuzzy.so
621 %{_libdir}/libopencv_hdf.so
622 %{_libdir}/libopencv_hfs.so
623 %{_libdir}/libopencv_img_hash.so
624 %{_libdir}/libopencv_line_descriptor.so
625 %{_libdir}/libopencv_optflow.so
626 %{_libdir}/libopencv_ovis.so
627 %{_libdir}/libopencv_phase_unwrapping.so
628 %{_libdir}/libopencv_plot.so
629 %{_libdir}/libopencv_reg.so
630 %{_libdir}/libopencv_rgbd.so
631 %{_libdir}/libopencv_saliency.so
632 %{_libdir}/libopencv_sfm.so
633 %{_libdir}/libopencv_stereo.so
634 %{_libdir}/libopencv_structured_light.so
635 %{_libdir}/libopencv_surface_matching.so
636 %{_libdir}/libopencv_text.so
637 %{_libdir}/libopencv_tracking.so
638 %{_libdir}/libopencv_xfeatures2d.so
639 %{_libdir}/libopencv_ximgproc.so
640 %{_libdir}/libopencv_xobjdetect.so
641 %{_libdir}/libopencv_xphoto.so
642 %{_libdir}/libopencv_alphamat.so
643 %{_libdir}/libopencv_dnn_superres.so
644 %{_libdir}/libopencv_gapi.so
645 %{_libdir}/libopencv_intensity_transform.so
646 %{_libdir}/libopencv_mcc.so
647 %{_libdir}/libopencv_quality.so
648 %{_libdir}/libopencv_rapid.so
649 # viz
650 %if %{with vtk}
651 %{_libdir}/libopencv_viz.so
652 %endif
653 %{_includedir}/opencv4
654 %dir %{_libdir}/cmake/opencv4
655 %{_libdir}/cmake/opencv4/OpenCV*.cmake
656 %{_pkgconfigdir}/opencv4.pc
657
658 %files doc
659 %defattr(644,root,root,755)
660 # TODO: probably could rebuild them and package via make install
661 %doc doc/*
662
663 %if %{with examples}
664 %files examples
665 %defattr(644,root,root,755)
666 %{_examplesdir}/%{name}-%{version}
667 %endif
668
669 %if %{with java}
670 %files -n java-opencv
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
673 %{_javadir}/opencv-%{jver}.jar
674 %{_javadir}/opencv.jar
675 %endif
676
677 %files -n python-opencv
678 %defattr(644,root,root,755)
679 %dir %{py_sitedir}/cv2
680 %dir %{py_sitedir}/cv2/python-*
681 %attr(755,root,root) %{py_sitedir}/cv2/python-*/cv2.so
682 %{py_sitedir}/cv2/*.py[co]
683
684 %files -n python3-opencv
685 %defattr(644,root,root,755)
686 %dir %{py3_sitedir}/cv2
687 %dir %{py3_sitedir}/cv2/python-*
688 %attr(755,root,root) %{py3_sitedir}/cv2/python-*/cv2.cpython-*.so
689 %{py3_sitedir}/cv2/*.py
This page took 0.111408 seconds and 3 git commands to generate.