]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- release 4 (by relup.sh)
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - contrib subpackage(s)
3 # - contrib BRs:
4 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7 #   opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8 #   opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9 #   opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
10 # unpackaged (3.4.0)
11 #/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12 #/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13 #/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14 #/usr/share/OpenCV/valgrind.supp
15 #/usr/share/OpenCV/valgrind_3rdparty.supp
16
17 #
18 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
19 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
20 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
21 #
22 # Conditional build:
23 # - general options:
24 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
25 %bcond_with     sse             # use SSE instructions
26 %bcond_with     sse2            # use SSE2 instructions
27 %bcond_with     sse3            # use SSE3 instructions
28 %bcond_with     ssse3           # use SSSE3 instructions
29 %bcond_with     sse41           # use SSE4.1 instructions
30 %bcond_with     sse42           # use SSE4.2 instructions
31 %bcond_with     avx             # use AVX instructions
32 %bcond_without  opencl          # OpenCL support
33 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
34 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
35 %bcond_without  opengl          # OpenGL support
36 %bcond_without  openmp          # OpenMP support (available when not using tbb)
37 %bcond_without  examples        # Install examples
38 # - bindings
39 %bcond_without  java            # Java binding
40 # - highgui options:
41 %bcond_without  ffmpeg          # FFMpeg support in highgui
42 %bcond_without  gstreamer       # GStreamer support in highgui
43 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
44 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
45 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
46 %bcond_with     unicap          # Unicap support in highgui (GPL)
47 %bcond_without  v4l             # Video4Linux in highgui
48 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
49 %bcond_with     xine            # XINE support in highgui (GPL)
50 # - other modules
51 %bcond_without  vtk             # VTK library support (opencv_viz module)
52
53 %ifarch pentium3 pentium4 %{x8664} x32
54 %define         with_sse        1
55 %endif
56 %ifarch pentium4 %{x8664} x32
57 %define         with_sse2       1
58 %endif
59 Summary:        A library of programming functions mainly aimed at real time computer vision
60 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
61 Name:           opencv
62 Version:        3.4.1
63 Release:        4
64 Epoch:          1
65 %if %{with unicap} || %{with xine}
66 License:        GPL (enforced by used libraries), BSD (opencv itself)
67 %else
68 License:        BSD
69 %endif
70 Group:          Libraries
71 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
72 # Source0-md5:  a0b7a47899e67b3490ea31edc4f6e8e6
73 Source1:        https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
74 # Source1-md5:  dd0c63f4185ab8a4829d8154ae382266
75 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76 Source10:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77 # Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78 Source11:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79 # Source11-md5: 232c966b13651bd0e46a1497b0852191
80 Source12:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81 # Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82 Source13:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83 # Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84 Source14:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85 # Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86 Source15:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87 # Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88 Source16:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89 # Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91 Source20:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92 # Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93 Source21:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94 # Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95 Source22:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96 # Source22-md5: 7cd47228edec52b6d82f46511af325c5
97 Source23:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98 # Source23-md5: 151805e03568c9f490a5e3a872777b75
99 # See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
100 Source30:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101 # Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
102 Patch0:         ix86-pause.patch
103 Patch1:         %{name}-ximea.patch
104 Patch2:         cplusplus.patch
105 Patch3:         cmake-install-path.patch
106 URL:            http://www.opencv.org/
107 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
108 %{?with_opencl:BuildRequires:   OpenCL-devel}
109 BuildRequires:  OpenEXR-devel
110 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
111 %{?with_opengl:BuildRequires:   OpenGL-devel}
112 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
113 %{?with_openni:BuildRequires:   OpenNI-devel}
114 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
115 %{?with_java:BuildRequires:     ant}
116 BuildRequires:  boost-devel
117 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
118 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
119 BuildRequires:  cmake >= 2.8
120 BuildRequires:  doxygen
121 BuildRequires:  eigen3 >= 3
122 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
123 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
124 BuildRequires:  gflags-devel
125 BuildRequires:  gl2ps-devel
126 BuildRequires:  glog-devel
127 %if %{with gstreamer}
128 BuildRequires:  gstreamer-devel >= 1.0
129 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
130 %endif
131 BuildRequires:  jasper-devel
132 %{?with_java:BuildRequires:     jdk}
133 BuildRequires:  libdc1394-devel >= 2
134 %{?with_openmp:BuildRequires:   libgomp-devel}
135 BuildRequires:  libjpeg-devel
136 BuildRequires:  libpng-devel
137 BuildRequires:  libraw1394-devel
138 BuildRequires:  libstdc++-devel
139 BuildRequires:  libtiff-devel
140 BuildRequires:  libtool
141 %if %{with unicap}
142 BuildRequires:  libucil-devel
143 BuildRequires:  libunicap-devel
144 %endif
145 BuildRequires:  libv4l-devel
146 BuildRequires:  pkgconfig
147 BuildRequires:  python >= 2.0
148 BuildRequires:  python-devel >= 2.0
149 BuildRequires:  python-numpy-devel
150 BuildRequires:  python3 >= 1:3.2
151 BuildRequires:  python3-devel >= 1:3.2
152 BuildRequires:  python3-numpy-devel
153 BuildRequires:  rpm-pythonprov
154 BuildRequires:  rpmbuild(macros) >= 1.606
155 BuildRequires:  sed >= 4.0
156 BuildRequires:  sphinx-pdg
157 BuildRequires:  swig-python
158 %{?with_tbb:BuildRequires:      tbb-devel}
159 %if %{with vtk}
160 BuildRequires:  vtk-devel >= 5.8.0
161 BuildRequires:  vtk-java >= 5.8.0
162 BuildRequires:  vtk-tcl >= 5.8.0
163 %endif
164 %{?with_xine:BuildRequires:     xine-lib-devel}
165 BuildRequires:  xorg-lib-libX11-devel
166 BuildRequires:  zlib-devel
167 %if %{with qt}
168 BuildRequires:  QtCore-devel >= 4
169 BuildRequires:  QtGui-devel >= 4
170 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
171 BuildRequires:  qt4-qmake >= 4
172 %else
173 BuildRequires:  gtk+2-devel >= 2.0
174 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
175 %endif
176 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
177 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
178
179 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
180 %define         sover   %(echo %{version} | cut -d. -f1-2)
181
182 %description
183 OpenCV (Open Source Computer Vision) is a library of programming
184 functions mainly aimed at real time computer vision.
185
186 Example applications of the OpenCV library are:
187 - Human-Computer Interaction (HCI)
188 - Object Identification, Segmentation and Recognition
189 - Face Recognition
190 - Gesture Recognition
191 - Motion Tracking
192 - Ego Motion, Motion Understanding
193 - Structure From Motion (SFM)
194 - Stereo and Multi-Camera Calibration and Depth Computation
195 - Mobile Robotics.
196
197 %description -l pl.UTF-8
198 OpenCV (Open Source Computer Vision) to biblioteka funkcji
199 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
200
201 Przykładowe zastosowania biblioteki OpenCV to
202 - interakcje człowiek-komputer (HCI)
203 - identyfikacja, segmentacja i rozpoznawanie obiektów
204 - rozpoznawanie twarzy
205 - rozpoznawanie gestów
206 - śledzenie ruchu
207 - rozumienie ruchu
208 - SFM (Structure From Motion)
209 - kalibracja dwu- i wielokamerowa, obliczanie głębi
210 - robotyka ruchu.
211
212 %package core
213 Summary:        OpenCV core libraries
214 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
215 Group:          Libraries
216 Conflicts:      opencv < 2.4.6.2-1
217
218 %description core
219 This package contains the OpenCV C/C++ core libraries.
220
221 %description core -l pl.UTF-8
222 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
223
224 %package viz
225 Summary:        OpenCV viz library (VTK support)
226 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
227 Group:          Libraries
228 Requires:       %{name} = %{epoch}:%{version}-%{release}
229
230 %description viz
231 OpenCV viz library (VTK support).
232
233 %description viz -l pl.UTF-8
234 Biblioteka OpenCV viz (obsługa VTK).
235
236 %package devel
237 Summary:        Header files for OpenCV library
238 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
239 Group:          Development/Libraries
240 Requires:       %{name} = %{epoch}:%{version}-%{release}
241 %if %{with vtk}
242 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
243 %endif
244 Obsoletes:      opencv-static
245
246 %description devel
247 Header files for OpenCV library.
248
249 %description devel -l pl.UTF-8
250 Pliki nagłówkowe biblioteki OpenCV.
251
252 %package doc
253 Summary:        Manual for OpenCV
254 Summary(fr.UTF-8):      Documentation pour OpenCV
255 Summary(it.UTF-8):      Documentazione di OpenCV
256 Summary(pl.UTF-8):      Podręcznik dla OpenCV
257 Group:          Documentation
258 # noarch subpackages only when building with rpm5
259 %if "%{_rpmversion}" >= "5"
260 BuildArch:      noarch
261 %endif
262
263 %description doc
264 Documentation for OpenCV.
265
266 %description doc -l fr.UTF-8
267 Documentation pour OpenCV.
268
269 %description doc -l it.UTF-8
270 Documentazione di OpenCV.
271
272 %description doc -l pl.UTF-8
273 Dokumentacja do OpenCV.
274
275 %package examples
276 Summary:        OpenCV code examples
277 Group:          Documentation
278 %if "%{_rpmversion}" >= "5"
279 BuildArch:      noarch
280 %endif
281
282 %description examples
283 OpenCV code examples.
284
285 %package -n java-opencv
286 Summary:        OpenCV Java bindings
287 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
288 Group:          Libraries/Java
289 Requires:       %{name} = %{epoch}:%{version}-%{release}
290 Requires:       jre
291
292 %description -n java-opencv
293 OpenCV Java bindings.
294
295 %description -n java-opencv -l pl.UTF-8
296 Wiązania Javy do OpenCV.
297
298 %package -n python-opencv
299 Summary:        OpenCV Python 2 bindings
300 Summary(pl.UTF-8):      Wiązania Pythona 2 do OpenCV
301 Group:          Libraries/Python
302 Requires:       %{name} = %{epoch}:%{version}-%{release}
303 Requires:       python-libs
304
305 %description -n python-opencv
306 OpenCV Python 2 bindings.
307
308 %description -n python-opencv -l pl.UTF-8
309 Wiązania Pythona 2 do OpenCV.
310
311 %package -n python3-opencv
312 Summary:        OpenCV Python 3 bindings
313 Summary(pl.UTF-8):      Wiązania Pythona 3 do OpenCV
314 Group:          Libraries/Python
315 Requires:       %{name} = %{epoch}:%{version}-%{release}
316 Requires:       python3-libs
317
318 %description -n python3-opencv
319 OpenCV Python 3 bindings.
320
321 %description -n python3-opencv -l pl.UTF-8
322 Wiązania Pythona 3 do OpenCV.
323
324 %prep
325 %setup -q -a1
326
327 %undos CMakeLists.txt
328
329 %patch0 -p1
330 %patch1 -p1
331 %patch2 -p1
332 %patch3 -p1
333
334 %build
335 install -d build/{share/OpenCV/testdata/cv/face,downloads/xfeatures2d}
336 cd build
337
338 install %{SOURCE30} share/OpenCV/testdata/cv/face/
339 install %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16} downloads/xfeatures2d/
340 install %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} downloads/xfeatures2d/
341
342 # handle cmake & ccache
343 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
344 if [[ "%{__cc}" = *ccache* ]]; then
345         cc="%{__cc}"
346         cxx="%{__cxx}"
347         ccache="
348         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
349         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
350         "
351 fi
352
353 %cmake .. \
354         $ccache \
355         -DENABLE_PRECOMPILED_HEADERS=OFF \
356         -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
357         -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
358         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
359         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
360         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
361         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
362         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
363         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
364         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
365         -DBUILD_NEW_PYTHON_SUPPORT=ON \
366 %if %{with examples}
367         -DINSTALL_C_EXAMPLES=ON \
368         -DINSTALL_PYTHON_EXAMPLES=ON \
369 %endif
370         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
371         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
372         %{?with_opencl:-DWITH_OPENCL=ON} \
373         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
374         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
375         %{?with_opengl:-DWITH_OPENGL=ON} \
376         %{?with_openmp:-DWITH_OPENMP=ON} \
377         %{?with_openni:-DWITH_OPENNI=ON} \
378         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
379         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
380         %{?with_tbb:-DWITH_TBB=ON} \
381         %{?with_unicap:-DWITH_UNICAP=ON} \
382         %{!?with_v4l:-DWITH_V4L=OFF} \
383         %{?with_vtk:-DWITH_VTK=ON} \
384         %{?with_ximea:-DWITH_XIMEA=ON} \
385         %{?with_xine:-DWITH_XINE=ON} \
386         -DWITH_IPP=OFF
387
388 %{__make}
389
390 %install
391 rm -rf $RPM_BUILD_ROOT
392 %{__make} -C build install \
393         DESTDIR=$RPM_BUILD_ROOT
394
395 %if %{with examples}
396 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
397 mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
398 %endif
399
400 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
401 cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
402
403 # disable completeness check incompatible with split packaging
404 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
405
406 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
407 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
408 %py_postclean
409
410 %if %{with java}
411 # move to proper directories, create symlink
412 install -d $RPM_BUILD_ROOT%{_javadir}
413 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
414 sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
415         $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
416 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
417 rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
418 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
419 %endif
420
421 %clean
422 rm -rf $RPM_BUILD_ROOT
423
424 %post   -p /sbin/ldconfig
425 %postun -p /sbin/ldconfig
426
427 %post   core -p /sbin/ldconfig
428 %postun core -p /sbin/ldconfig
429
430 %post   viz -p /sbin/ldconfig
431 %postun viz -p /sbin/ldconfig
432
433 %post   -n java-opencv -p /sbin/ldconfig
434 %postun -n java-opencv -p /sbin/ldconfig
435
436 %files
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_bindir}/opencv_annotation
439 %attr(755,root,root) %{_bindir}/opencv_createsamples
440 %attr(755,root,root) %{_bindir}/opencv_interactive-calibration
441 %attr(755,root,root) %{_bindir}/opencv_traincascade
442 %attr(755,root,root) %{_bindir}/opencv_version
443 %attr(755,root,root) %{_bindir}/opencv_visualisation
444 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
445 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
446 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
447 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
448 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
449 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
450 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
451 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
452 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
453 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
454 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
455 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
456 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
457 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
458 # contrib modules
459 %attr(755,root,root) %{_bindir}/opencv_waldboost_detector
460 %attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
461 %attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
462 %attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
463 %attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
464 %attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
465 %attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
466 %attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
467 %attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
468 %attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
469 %attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
470 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
471 %attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
472 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
473 %attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
474 %attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
475 %attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
476 %attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
477 %attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
478 %attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
479 %attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
480 %attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
481 %attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
482 %attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
483 %attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
484 %attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
485 %attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
486 %attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
487 %attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
488 %attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
489 %attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
490 %attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
491 %attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
492 %attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
493 %attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
494 %attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
495 %attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
496 %attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
497 %attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
498 %attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
499 %attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
500 %attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
501 %attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
502 %attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
503 %attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
504 %attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
505 %attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
506 %attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
507 %attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
508 %attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
509 %attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
510 %attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
511 %attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
512 %attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
513 %attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
514 %attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
515 %attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
516 %attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
517 %attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
518 %attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
519 %attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
520 %attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
521 %attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
522
523 %dir %{_datadir}/OpenCV
524 %{_datadir}/OpenCV/haarcascades
525 %{_datadir}/OpenCV/lbpcascades
526
527 %files core
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
530 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
531 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
532 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
533 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
534 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
535 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
536 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
537 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
539 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
541 %attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
542 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
543 %attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
544 %attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
545 %attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
546 %attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
547
548 %if %{with vtk}
549 %files viz
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
552 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
553 %endif
554
555 %files devel
556 %defattr(644,root,root,755)
557 # core
558 %attr(755,root,root) %{_libdir}/libopencv_core.so
559 %attr(755,root,root) %{_libdir}/libopencv_flann.so
560 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so
561 %attr(755,root,root) %{_libdir}/libopencv_ml.so
562 %attr(755,root,root) %{_libdir}/libopencv_photo.so
563 %attr(755,root,root) %{_libdir}/libopencv_video.so
564 # GUI/extensions (base package)
565 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so
566 %attr(755,root,root) %{_libdir}/libopencv_features2d.so
567 %attr(755,root,root) %{_libdir}/libopencv_highgui.so
568 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so
569 %attr(755,root,root) %{_libdir}/libopencv_stitching.so
570 %attr(755,root,root) %{_libdir}/libopencv_superres.so
571 %attr(755,root,root) %{_libdir}/libopencv_videostab.so
572 %attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so
573 %attr(755,root,root) %{_libdir}/libopencv_shape.so
574 %attr(755,root,root) %{_libdir}/libopencv_videoio.so
575 # contrib
576 %attr(755,root,root) %{_libdir}/libopencv_aruco.so
577 %attr(755,root,root) %{_libdir}/libopencv_bgsegm.so
578 %attr(755,root,root) %{_libdir}/libopencv_bioinspired.so
579 %attr(755,root,root) %{_libdir}/libopencv_ccalib.so
580 %attr(755,root,root) %{_libdir}/libopencv_datasets.so
581 %attr(755,root,root) %{_libdir}/libopencv_dnn.so
582 %attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so
583 %attr(755,root,root) %{_libdir}/libopencv_dpm.so
584 %attr(755,root,root) %{_libdir}/libopencv_face.so
585 %attr(755,root,root) %{_libdir}/libopencv_freetype.so
586 %attr(755,root,root) %{_libdir}/libopencv_fuzzy.so
587 %attr(755,root,root) %{_libdir}/libopencv_hdf.so
588 %attr(755,root,root) %{_libdir}/libopencv_hfs.so
589 %attr(755,root,root) %{_libdir}/libopencv_img_hash.so
590 %attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so
591 %attr(755,root,root) %{_libdir}/libopencv_optflow.so
592 %attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so
593 %attr(755,root,root) %{_libdir}/libopencv_plot.so
594 %attr(755,root,root) %{_libdir}/libopencv_reg.so
595 %attr(755,root,root) %{_libdir}/libopencv_rgbd.so
596 %attr(755,root,root) %{_libdir}/libopencv_saliency.so
597 %attr(755,root,root) %{_libdir}/libopencv_sfm.so
598 %attr(755,root,root) %{_libdir}/libopencv_stereo.so
599 %attr(755,root,root) %{_libdir}/libopencv_structured_light.so
600 %attr(755,root,root) %{_libdir}/libopencv_surface_matching.so
601 %attr(755,root,root) %{_libdir}/libopencv_text.so
602 %attr(755,root,root) %{_libdir}/libopencv_tracking.so
603 %attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so
604 %attr(755,root,root) %{_libdir}/libopencv_ximgproc.so
605 %attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so
606 %attr(755,root,root) %{_libdir}/libopencv_xphoto.so
607 #%{_libdir}/libopencv_ts.a
608 # viz
609 %if %{with vtk}
610 %attr(755,root,root) %{_libdir}/libopencv_viz.so
611 %endif
612 %{_includedir}/opencv
613 %{_includedir}/opencv2
614 %{_datadir}/OpenCV/OpenCV*.cmake
615 %{_pkgconfigdir}/opencv.pc
616
617 %files doc
618 %defattr(644,root,root,755)
619 # TODO: probably could rebuild them and package via make install
620 %doc doc/*
621
622 %if %{with examples}
623 %files examples
624 %defattr(644,root,root,755)
625 %{_examplesdir}/%{name}-%{version}
626 %endif
627
628 %if %{with java}
629 %files -n java-opencv
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
632 %{_javadir}/opencv-%{jver}.jar
633 %{_javadir}/opencv.jar
634 %endif
635
636 %files -n python-opencv
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{py_sitedir}/cv2.so
639
640 %files -n python3-opencv
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{py3_sitedir}/cv2.cpython-*.so
This page took 0.082907 seconds and 3 git commands to generate.