]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
1accacf7cfe84c6682c3089184b27b0861566fad
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
3 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
4 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
5 #
6 # Conditional build:
7 # - general options:
8 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
9 %bcond_with     sse             # use SSE instructions
10 %bcond_with     sse2            # use SSE2 instructions
11 %bcond_with     sse3            # use SSE3 instructions
12 %bcond_with     ssse3           # use SSSE3 instructions
13 %bcond_with     sse41           # use SSE4.1 instructions
14 %bcond_with     sse42           # use SSE4.2 instructions
15 %bcond_with     avx             # use AVX instructions
16 %bcond_without  opencl          # OpenCL support
17 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
18 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
19 %bcond_without  opengl          # OpenGL support
20 %bcond_without  openmp          # OpenMP support (available when not using tbb)
21 %bcond_without  examples        # Install examples
22 # - bindings
23 %bcond_without  java            # Java binding
24 # - highgui options:
25 %bcond_without  ffmpeg          # FFMpeg support in highgui
26 %bcond_without  gstreamer       # GStreamer support in highgui
27 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
28 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
29 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
30 %bcond_with     unicap          # Unicap support in highgui (GPL)
31 %bcond_without  v4l             # Video4Linux in highgui
32 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
33 %bcond_with     xine            # XINE support in highgui (GPL)
34 # - other modules
35 %bcond_without  vtk             # VTK library support (opencv_viz module)
36
37 %ifarch pentium3 pentium4 %{x8664} x32
38 %define         with_sse        1
39 %endif
40 %ifarch pentium4 %{x8664} x32
41 %define         with_sse2       1
42 %endif
43 Summary:        A library of programming functions mainly aimed at real time computer vision
44 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
45 Name:           opencv
46 Version:        2.4.12.3
47 Release:        1
48 Epoch:          1
49 %if %{with unicap} || %{with xine}
50 License:        GPL (enforced by used libraries), BSD (opencv itself)
51 %else
52 License:        BSD
53 %endif
54 Group:          Libraries
55 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
56 # Source0-md5:  2496a4a4caf8fecfbfc294fbe6a814b0
57 Patch0:         %{name}-cflags.patch
58 Patch1:         %{name}-cmake.patch
59 Patch2:         %{name}-unicap-c++.patch
60 Patch3:         %{name}-c.patch
61 Patch4:         %{name}-gcc.patch
62 Patch5:         %{name}-ximea.patch
63 Patch6:         %{name}-ocl-fft.patch
64 Patch7:         java-ant-sourcelevel.patch
65 Patch8:         %{name}-shared.patch
66 Patch9:         no-sysctl.patch
67 Patch10:        cmake-install-path.patch
68 URL:            http://www.opencv.org/
69 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
70 %{?with_opencl:BuildRequires:   OpenCL-devel}
71 BuildRequires:  OpenEXR-devel
72 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
73 %{?with_opengl:BuildRequires:   OpenGL-devel}
74 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
75 %{?with_openni:BuildRequires:   OpenNI-devel}
76 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
77 %{?with_java:BuildRequires:     ant}
78 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
79 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
80 BuildRequires:  cmake >= 2.8
81 BuildRequires:  doxygen
82 BuildRequires:  eigen3 >= 3
83 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
84 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
85 BuildRequires:  gl2ps-devel
86 %if %{with gstreamer}
87 BuildRequires:  gstreamer-devel >= 1.0
88 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
89 %endif
90 BuildRequires:  jasper-devel
91 %{?with_java:BuildRequires:     jdk}
92 BuildRequires:  libdc1394-devel >= 2
93 %{?with_openmp:BuildRequires:   libgomp-devel}
94 BuildRequires:  libjpeg-devel
95 BuildRequires:  libpng-devel
96 BuildRequires:  libraw1394-devel
97 BuildRequires:  libstdc++-devel
98 BuildRequires:  libtiff-devel
99 BuildRequires:  libtool
100 %if %{with unicap}
101 BuildRequires:  libucil-devel
102 BuildRequires:  libunicap-devel
103 %endif
104 BuildRequires:  libv4l-devel
105 BuildRequires:  pkgconfig
106 BuildRequires:  python >= 2.0
107 BuildRequires:  python-devel >= 2.0
108 BuildRequires:  python-numpy-devel
109 BuildRequires:  rpm-pythonprov
110 BuildRequires:  rpmbuild(macros) >= 1.606
111 BuildRequires:  sed >= 4.0
112 BuildRequires:  sphinx-pdg
113 BuildRequires:  swig-python
114 %{?with_tbb:BuildRequires:      tbb-devel}
115 %if %{with vtk}
116 BuildRequires:  vtk-devel >= 5.8.0
117 BuildRequires:  vtk-java >= 5.8.0
118 BuildRequires:  vtk-tcl >= 5.8.0
119 %endif
120 %{?with_xine:BuildRequires:     xine-lib-devel}
121 BuildRequires:  xorg-lib-libX11-devel
122 BuildRequires:  zlib-devel
123 %if %{with qt}
124 BuildRequires:  QtCore-devel >= 4
125 BuildRequires:  QtGui-devel >= 4
126 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
127 BuildRequires:  qt4-qmake >= 4
128 %else
129 BuildRequires:  gtk+2-devel >= 2.0
130 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
131 %endif
132 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
133 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
134
135 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
136
137 %description
138 OpenCV (Open Source Computer Vision) is a library of programming
139 functions mainly aimed at real time computer vision.
140
141 Example applications of the OpenCV library are:
142 - Human-Computer Interaction (HCI)
143 - Object Identification, Segmentation and Recognition
144 - Face Recognition
145 - Gesture Recognition
146 - Motion Tracking
147 - Ego Motion, Motion Understanding
148 - Structure From Motion (SFM)
149 - Stereo and Multi-Camera Calibration and Depth Computation
150 - Mobile Robotics.
151
152 %description -l pl.UTF-8
153 OpenCV (Open Source Computer Vision) to biblioteka funkcji
154 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
155
156 Przykładowe zastosowania biblioteki OpenCV to
157 - interakcje człowiek-komputer (HCI)
158 - identyfikacja, segmentacja i rozpoznawanie obiektów
159 - rozpoznawanie twarzy
160 - rozpoznawanie gestów
161 - śledzenie ruchu
162 - rozumienie ruchu
163 - SFM (Structure From Motion)
164 - kalibracja dwu- i wielokamerowa, obliczanie głębi
165 - robotyka ruchu.
166
167 %package core
168 Summary:        OpenCV core libraries
169 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
170 Group:          Libraries
171 Conflicts:      opencv < 2.4.6.2-1
172
173 %description core
174 This package contains the OpenCV C/C++ core libraries.
175
176 %description core -l pl.UTF-8
177 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
178
179 %package viz
180 Summary:        OpenCV viz library (VTK support)
181 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
182 Group:          Libraries
183 Requires:       %{name} = %{epoch}:%{version}-%{release}
184
185 %description viz
186 OpenCV viz library (VTK support).
187
188 %description viz -l pl.UTF-8
189 Biblioteka OpenCV viz (obsługa VTK).
190
191 %package devel
192 Summary:        Header files for OpenCV library
193 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
194 Group:          Development/Libraries
195 Requires:       %{name} = %{epoch}:%{version}-%{release}
196 %if %{with vtk}
197 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
198 %endif
199 Obsoletes:      opencv-static
200
201 %description devel
202 Header files for OpenCV library.
203
204 %description devel -l pl.UTF-8
205 Pliki nagłówkowe biblioteki OpenCV.
206
207 %package doc
208 Summary:        Manual for OpenCV
209 Summary(fr.UTF-8):      Documentation pour OpenCV
210 Summary(it.UTF-8):      Documentazione di OpenCV
211 Summary(pl.UTF-8):      Podręcznik dla OpenCV
212 Group:          Documentation
213 # noarch subpackages only when building with rpm5
214 %if "%{_rpmversion}" >= "5"
215 BuildArch:      noarch
216 %endif
217
218 %description doc
219 Documentation for OpenCV.
220
221 %description doc -l fr.UTF-8
222 Documentation pour OpenCV.
223
224 %description doc -l it.UTF-8
225 Documentazione di OpenCV.
226
227 %description doc -l pl.UTF-8
228 Dokumentacja do OpenCV.
229
230 %package examples
231 Summary:        OpenCV code examples
232 Group:          Documentation
233 %if "%{_rpmversion}" >= "5"
234 BuildArch:      noarch
235 %endif
236
237 %description examples
238 OpenCV code examples.
239
240 %package -n java-opencv
241 Summary:        OpenCV Java bindings
242 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
243 Group:          Libraries/Java
244 Requires:       %{name} = %{epoch}:%{version}-%{release}
245 Requires:       jre
246
247 %description -n java-opencv
248 OpenCV Java bindings.
249
250 %description -n java-opencv -l pl.UTF-8
251 Wiązania Javy do OpenCV.
252
253 %package -n python-opencv
254 Summary:        OpenCV Python bindings
255 Summary(pl.UTF-8):      Wiązania Pythona do OpenCV
256 Group:          Libraries/Python
257 Requires:       %{name} = %{epoch}:%{version}-%{release}
258 Requires:       python-libs
259
260 %description -n python-opencv
261 OpenCV Python bindings.
262
263 %description -n python-opencv -l pl.UTF-8
264 Wiązania Pythona do OpenCV.
265
266 %prep
267 %setup -q
268
269 %undos CMakeLists.txt
270 %undos modules/gpu/CMakeLists.txt
271
272 %patch0 -p1
273 %patch1 -p1
274 %patch2 -p1
275 %patch3 -p1
276 %patch4 -p1
277 %patch5 -p1
278 %patch6 -p1
279 %patch7 -p1
280 %patch8 -p1
281 %patch9 -p1
282 %patch10 -p1
283
284 %build
285 install -d build
286 cd build
287
288 # handle cmake & ccache
289 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
290 if [[ "%{__cc}" = *ccache* ]]; then
291         cc="%{__cc}"
292         cxx="%{__cxx}"
293         ccache="
294         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
295         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
296         "
297 fi
298
299 %cmake .. \
300         $ccache \
301         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
302         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
303         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
304         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
305         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
306         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
307         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
308         -DBUILD_NEW_PYTHON_SUPPORT=ON \
309 %if %{with examples}
310         -DINSTALL_C_EXAMPLES=ON \
311         -DINSTALL_PYTHON_EXAMPLES=ON \
312 %endif
313         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
314         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
315         %{?with_opencl:-DWITH_OPENCL=ON} \
316         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
317         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
318         %{?with_opengl:-DWITH_OPENGL=ON} \
319         %{?with_openmp:-DWITH_OPENMP=ON} \
320         %{?with_openni:-DWITH_OPENNI=ON} \
321         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
322         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
323         %{?with_tbb:-DWITH_TBB=ON} \
324         %{?with_unicap:-DWITH_UNICAP=ON} \
325         %{!?with_v4l:-DWITH_V4L=OFF} \
326         %{?with_vtk:-DWITH_VTK=ON} \
327         %{?with_ximea:-DWITH_XIMEA=ON} \
328         %{?with_xine:-DWITH_XINE=ON}
329
330 %{__make}
331
332 %install
333 rm -rf $RPM_BUILD_ROOT
334 %{__make} -C build install \
335         DESTDIR=$RPM_BUILD_ROOT
336
337 # see -doc package
338 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
339 %if %{with examples}
340 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
341 mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
342 %endif
343
344 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
345 cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
346
347 # disable completeness check incompatible with split packaging
348 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
349
350 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
351 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
352 %py_postclean
353
354 %if %{with java}
355 # move to proper directories, create symlink
356 install -d $RPM_BUILD_ROOT%{_javadir}
357 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
358 sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
359         $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
360 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
361 rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
362 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
363 %endif
364
365 %clean
366 rm -rf $RPM_BUILD_ROOT
367
368 %post   -p /sbin/ldconfig
369 %postun -p /sbin/ldconfig
370
371 %post   core -p /sbin/ldconfig
372 %postun core -p /sbin/ldconfig
373
374 %post   viz -p /sbin/ldconfig
375 %postun viz -p /sbin/ldconfig
376
377 %post   -n java-opencv -p /sbin/ldconfig
378 %postun -n java-opencv -p /sbin/ldconfig
379
380 %files
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_bindir}/opencv_annotation
383 %attr(755,root,root) %{_bindir}/opencv_createsamples
384 %attr(755,root,root) %{_bindir}/opencv_haartraining
385 %attr(755,root,root) %{_bindir}/opencv_performance
386 %attr(755,root,root) %{_bindir}/opencv_traincascade
387 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
388 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
389 %attr(755,root,root) %{_libdir}/libopencv_contrib.so.*.*.*
390 %attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
391 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
392 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
393 %attr(755,root,root) %{_libdir}/libopencv_gpu.so.*.*.*
394 %attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
395 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
396 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
397 %attr(755,root,root) %{_libdir}/libopencv_legacy.so.*.*.*
398 %attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
399 %attr(755,root,root) %{_libdir}/libopencv_nonfree.so.*.*.*
400 %attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
401 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
402 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
403 %if %{with opencl}
404 %attr(755,root,root) %{_libdir}/libopencv_ocl.so.*.*.*
405 %attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
406 %endif
407 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
408 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
409 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
410 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
411 %attr(755,root,root) %{_libdir}/libopencv_ts.so.*.*.*
412 %attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
413 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
414 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
415 %dir %{_datadir}/OpenCV
416 %{_datadir}/OpenCV/haarcascades
417 %{_datadir}/OpenCV/lbpcascades
418
419 %files core
420 %defattr(644,root,root,755)
421 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
422 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
423 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
424 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
425 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
426 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
427 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
428 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
429 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
430 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
431 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
432 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
433
434 %if %{with vtk}
435 %files viz
436 %defattr(644,root,root,755)
437 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
438 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
439 %endif
440
441 %files devel
442 %defattr(644,root,root,755)
443 # core
444 %attr(755,root,root) %{_libdir}/libopencv_core.so
445 %attr(755,root,root) %{_libdir}/libopencv_flann.so
446 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so
447 %attr(755,root,root) %{_libdir}/libopencv_ml.so
448 %attr(755,root,root) %{_libdir}/libopencv_photo.so
449 %attr(755,root,root) %{_libdir}/libopencv_video.so
450 # GUI/extensions (base package)
451 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so
452 %attr(755,root,root) %{_libdir}/libopencv_contrib.so
453 %attr(755,root,root) %{_libdir}/libopencv_features2d.so
454 %attr(755,root,root) %{_libdir}/libopencv_gpu.so
455 %attr(755,root,root) %{_libdir}/libopencv_highgui.so
456 %attr(755,root,root) %{_libdir}/libopencv_legacy.so
457 %attr(755,root,root) %{_libdir}/libopencv_nonfree.so
458 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so
459 %if %{with opencl}
460 %attr(755,root,root) %{_libdir}/libopencv_ocl.so
461 %endif
462 %attr(755,root,root) %{_libdir}/libopencv_stitching.so
463 %attr(755,root,root) %{_libdir}/libopencv_superres.so
464 %attr(755,root,root) %{_libdir}/libopencv_ts.so
465 %attr(755,root,root) %{_libdir}/libopencv_videostab.so
466 # viz
467 %if %{with vtk}
468 %attr(755,root,root) %{_libdir}/libopencv_viz.so
469 %endif
470 %{_includedir}/opencv
471 %{_includedir}/opencv2
472 %{_datadir}/OpenCV/OpenCV*.cmake
473 %{_pkgconfigdir}/opencv.pc
474
475 %files doc
476 %defattr(644,root,root,755)
477 # TODO: probably could rebuild them and package via make install
478 %doc doc/*
479
480 %if %{with examples}
481 %files examples
482 %defattr(644,root,root,755)
483 %{_examplesdir}/%{name}-%{version}
484 %endif
485
486 %if %{with java}
487 %files -n java-opencv
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
490 %{_javadir}/opencv-%{jver}.jar
491 %{_javadir}/opencv.jar
492 %endif
493
494 %files -n python-opencv
495 %defattr(644,root,root,755)
496 %attr(755,root,root) %{py_sitedir}/cv2.so
497 %{py_sitedir}/cv.py[co]
This page took 0.106126 seconds and 2 git commands to generate.