]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
0776ce1d130c112f2f5219474030cd61605ea8c2
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - contrib subpackage(s)
3 # - contrib BRs:
4 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7 #   opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8 #   opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9 #   opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
10 # unpackaged (3.4.0)
11 #/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12 #/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13 #/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14 #/usr/share/OpenCV/valgrind.supp
15 #/usr/share/OpenCV/valgrind_3rdparty.supp
16
17 #
18 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
19 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
20 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
21 #
22 # Conditional build:
23 # - general options:
24 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
25 %bcond_with     sse             # use SSE instructions
26 %bcond_with     sse2            # use SSE2 instructions
27 %bcond_with     sse3            # use SSE3 instructions
28 %bcond_with     ssse3           # use SSSE3 instructions
29 %bcond_with     sse41           # use SSE4.1 instructions
30 %bcond_with     sse42           # use SSE4.2 instructions
31 %bcond_with     avx             # use AVX instructions
32 %bcond_without  opencl          # OpenCL support
33 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
34 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
35 %bcond_without  opengl          # OpenGL support
36 %bcond_without  openmp          # OpenMP support (available when not using tbb)
37 %bcond_without  examples        # Install examples
38 # - bindings
39 %bcond_without  java            # Java binding
40 # - highgui options:
41 %bcond_without  ffmpeg          # FFMpeg support in highgui
42 %bcond_without  gstreamer       # GStreamer support in highgui
43 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
44 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
45 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
46 %bcond_with     unicap          # Unicap support in highgui (GPL)
47 %bcond_without  v4l             # Video4Linux in highgui
48 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
49 %bcond_with     xine            # XINE support in highgui (GPL)
50 # - other modules
51 %bcond_without  vtk             # VTK library support (opencv_viz module)
52
53 %ifarch pentium3 pentium4 %{x8664} x32
54 %define         with_sse        1
55 %endif
56 %ifarch pentium4 %{x8664} x32
57 %define         with_sse2       1
58 %endif
59 Summary:        A library of programming functions mainly aimed at real time computer vision
60 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
61 Name:           opencv
62 Version:        3.4.1
63 Release:        0.1
64 Epoch:          1
65 %if %{with unicap} || %{with xine}
66 License:        GPL (enforced by used libraries), BSD (opencv itself)
67 %else
68 License:        BSD
69 %endif
70 Group:          Libraries
71 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
72 # Source0-md5:  a0b7a47899e67b3490ea31edc4f6e8e6
73 Source1:        https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
74 # Source1-md5:  dd0c63f4185ab8a4829d8154ae382266
75 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76 Source10:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77 # Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78 Source11:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79 # Source11-md5: 232c966b13651bd0e46a1497b0852191
80 Source12:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81 # Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82 Source13:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83 # Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84 Source14:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85 # Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86 Source15:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87 # Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88 Source16:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89 # Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91 Source20:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92 # Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93 Source21:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94 # Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95 Source22:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96 # Source22-md5: 7cd47228edec52b6d82f46511af325c5
97 Source23:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98 # Source23-md5: 151805e03568c9f490a5e3a872777b75
99 Source30:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
100 # Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
101 Patch0:         ix86-pause.patch
102 Patch1:         %{name}-ximea.patch
103 Patch3:         cmake-install-path.patch
104 URL:            http://www.opencv.org/
105 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
106 %{?with_opencl:BuildRequires:   OpenCL-devel}
107 BuildRequires:  OpenEXR-devel
108 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
109 %{?with_opengl:BuildRequires:   OpenGL-devel}
110 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
111 %{?with_openni:BuildRequires:   OpenNI-devel}
112 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
113 %{?with_java:BuildRequires:     ant}
114 BuildRequires:  boost-devel
115 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
116 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
117 BuildRequires:  cmake >= 2.8
118 BuildRequires:  doxygen
119 BuildRequires:  eigen3 >= 3
120 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
121 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
122 BuildRequires:  gflags-devel
123 BuildRequires:  gl2ps-devel
124 BuildRequires:  glog-devel
125 %if %{with gstreamer}
126 BuildRequires:  gstreamer-devel >= 1.0
127 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
128 %endif
129 BuildRequires:  jasper-devel
130 %{?with_java:BuildRequires:     jdk}
131 BuildRequires:  libdc1394-devel >= 2
132 %{?with_openmp:BuildRequires:   libgomp-devel}
133 BuildRequires:  libjpeg-devel
134 BuildRequires:  libpng-devel
135 BuildRequires:  libraw1394-devel
136 BuildRequires:  libstdc++-devel
137 BuildRequires:  libtiff-devel
138 BuildRequires:  libtool
139 %if %{with unicap}
140 BuildRequires:  libucil-devel
141 BuildRequires:  libunicap-devel
142 %endif
143 BuildRequires:  libv4l-devel
144 BuildRequires:  pkgconfig
145 BuildRequires:  python >= 2.0
146 BuildRequires:  python-devel >= 2.0
147 BuildRequires:  python-numpy-devel
148 BuildRequires:  python3 >= 1:3.2
149 BuildRequires:  python3-devel >= 1:3.2
150 BuildRequires:  python3-numpy-devel
151 BuildRequires:  rpm-pythonprov
152 BuildRequires:  rpmbuild(macros) >= 1.606
153 BuildRequires:  sed >= 4.0
154 BuildRequires:  sphinx-pdg
155 BuildRequires:  swig-python
156 %{?with_tbb:BuildRequires:      tbb-devel}
157 %if %{with vtk}
158 BuildRequires:  vtk-devel >= 5.8.0
159 BuildRequires:  vtk-java >= 5.8.0
160 BuildRequires:  vtk-tcl >= 5.8.0
161 %endif
162 %{?with_xine:BuildRequires:     xine-lib-devel}
163 BuildRequires:  xorg-lib-libX11-devel
164 BuildRequires:  zlib-devel
165 %if %{with qt}
166 BuildRequires:  QtCore-devel >= 4
167 BuildRequires:  QtGui-devel >= 4
168 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
169 BuildRequires:  qt4-qmake >= 4
170 %else
171 BuildRequires:  gtk+2-devel >= 2.0
172 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
173 %endif
174 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
175 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
176
177 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
178 %define         sover   %(echo %{version} | cut -d. -f1-2)
179
180 %description
181 OpenCV (Open Source Computer Vision) is a library of programming
182 functions mainly aimed at real time computer vision.
183
184 Example applications of the OpenCV library are:
185 - Human-Computer Interaction (HCI)
186 - Object Identification, Segmentation and Recognition
187 - Face Recognition
188 - Gesture Recognition
189 - Motion Tracking
190 - Ego Motion, Motion Understanding
191 - Structure From Motion (SFM)
192 - Stereo and Multi-Camera Calibration and Depth Computation
193 - Mobile Robotics.
194
195 %description -l pl.UTF-8
196 OpenCV (Open Source Computer Vision) to biblioteka funkcji
197 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
198
199 Przykładowe zastosowania biblioteki OpenCV to
200 - interakcje człowiek-komputer (HCI)
201 - identyfikacja, segmentacja i rozpoznawanie obiektów
202 - rozpoznawanie twarzy
203 - rozpoznawanie gestów
204 - śledzenie ruchu
205 - rozumienie ruchu
206 - SFM (Structure From Motion)
207 - kalibracja dwu- i wielokamerowa, obliczanie głębi
208 - robotyka ruchu.
209
210 %package core
211 Summary:        OpenCV core libraries
212 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
213 Group:          Libraries
214 Conflicts:      opencv < 2.4.6.2-1
215
216 %description core
217 This package contains the OpenCV C/C++ core libraries.
218
219 %description core -l pl.UTF-8
220 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
221
222 %package viz
223 Summary:        OpenCV viz library (VTK support)
224 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
225 Group:          Libraries
226 Requires:       %{name} = %{epoch}:%{version}-%{release}
227
228 %description viz
229 OpenCV viz library (VTK support).
230
231 %description viz -l pl.UTF-8
232 Biblioteka OpenCV viz (obsługa VTK).
233
234 %package devel
235 Summary:        Header files for OpenCV library
236 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
237 Group:          Development/Libraries
238 Requires:       %{name} = %{epoch}:%{version}-%{release}
239 %if %{with vtk}
240 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
241 %endif
242 Obsoletes:      opencv-static
243
244 %description devel
245 Header files for OpenCV library.
246
247 %description devel -l pl.UTF-8
248 Pliki nagłówkowe biblioteki OpenCV.
249
250 %package doc
251 Summary:        Manual for OpenCV
252 Summary(fr.UTF-8):      Documentation pour OpenCV
253 Summary(it.UTF-8):      Documentazione di OpenCV
254 Summary(pl.UTF-8):      Podręcznik dla OpenCV
255 Group:          Documentation
256 # noarch subpackages only when building with rpm5
257 %if "%{_rpmversion}" >= "5"
258 BuildArch:      noarch
259 %endif
260
261 %description doc
262 Documentation for OpenCV.
263
264 %description doc -l fr.UTF-8
265 Documentation pour OpenCV.
266
267 %description doc -l it.UTF-8
268 Documentazione di OpenCV.
269
270 %description doc -l pl.UTF-8
271 Dokumentacja do OpenCV.
272
273 %package examples
274 Summary:        OpenCV code examples
275 Group:          Documentation
276 %if "%{_rpmversion}" >= "5"
277 BuildArch:      noarch
278 %endif
279
280 %description examples
281 OpenCV code examples.
282
283 %package -n java-opencv
284 Summary:        OpenCV Java bindings
285 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
286 Group:          Libraries/Java
287 Requires:       %{name} = %{epoch}:%{version}-%{release}
288 Requires:       jre
289
290 %description -n java-opencv
291 OpenCV Java bindings.
292
293 %description -n java-opencv -l pl.UTF-8
294 Wiązania Javy do OpenCV.
295
296 %package -n python-opencv
297 Summary:        OpenCV Python 2 bindings
298 Summary(pl.UTF-8):      Wiązania Pythona 2 do OpenCV
299 Group:          Libraries/Python
300 Requires:       %{name} = %{epoch}:%{version}-%{release}
301 Requires:       python-libs
302
303 %description -n python-opencv
304 OpenCV Python 2 bindings.
305
306 %description -n python-opencv -l pl.UTF-8
307 Wiązania Pythona 2 do OpenCV.
308
309 %package -n python3-opencv
310 Summary:        OpenCV Python 3 bindings
311 Summary(pl.UTF-8):      Wiązania Pythona 3 do OpenCV
312 Group:          Libraries/Python
313 Requires:       %{name} = %{epoch}:%{version}-%{release}
314 Requires:       python3-libs
315
316 %description -n python3-opencv
317 OpenCV Python 3 bindings.
318
319 %description -n python3-opencv -l pl.UTF-8
320 Wiązania Pythona 3 do OpenCV.
321
322 %prep
323 %setup -q -a1
324
325 %undos CMakeLists.txt
326
327 %patch0 -p1
328 %patch1 -p1
329 %patch3 -p1
330
331 %build
332 install -d build/{share/OpenCV/testdata/cv/face,downloads/xfeatures2d}
333 cd build
334
335 install %{SOURCE30} share/OpenCV/testdata/cv/face/
336 install %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16} downloads/xfeatures2d/
337 install %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} downloads/xfeatures2d/
338
339 # handle cmake & ccache
340 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
341 if [[ "%{__cc}" = *ccache* ]]; then
342         cc="%{__cc}"
343         cxx="%{__cxx}"
344         ccache="
345         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
346         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
347         "
348 fi
349
350 %cmake .. \
351         $ccache \
352         -DENABLE_PRECOMPILED_HEADERS=OFF \
353         -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
354         -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
355         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
356         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
357         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
358         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
359         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
360         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
361         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
362         -DBUILD_NEW_PYTHON_SUPPORT=ON \
363 %if %{with examples}
364         -DINSTALL_C_EXAMPLES=ON \
365         -DINSTALL_PYTHON_EXAMPLES=ON \
366 %endif
367         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
368         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
369         %{?with_opencl:-DWITH_OPENCL=ON} \
370         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
371         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
372         %{?with_opengl:-DWITH_OPENGL=ON} \
373         %{?with_openmp:-DWITH_OPENMP=ON} \
374         %{?with_openni:-DWITH_OPENNI=ON} \
375         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
376         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
377         %{?with_tbb:-DWITH_TBB=ON} \
378         %{?with_unicap:-DWITH_UNICAP=ON} \
379         %{!?with_v4l:-DWITH_V4L=OFF} \
380         %{?with_vtk:-DWITH_VTK=ON} \
381         %{?with_ximea:-DWITH_XIMEA=ON} \
382         %{?with_xine:-DWITH_XINE=ON} \
383         -DWITH_IPP=OFF
384
385 %{__make}
386
387 %install
388 rm -rf $RPM_BUILD_ROOT
389 %{__make} -C build install \
390         DESTDIR=$RPM_BUILD_ROOT
391
392 %if %{with examples}
393 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
394 mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
395 %endif
396
397 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
398 cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
399
400 # disable completeness check incompatible with split packaging
401 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
402
403 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
404 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
405 %py_postclean
406
407 %if %{with java}
408 # move to proper directories, create symlink
409 install -d $RPM_BUILD_ROOT%{_javadir}
410 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
411 sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
412         $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
413 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
414 rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
415 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
416 %endif
417
418 %clean
419 rm -rf $RPM_BUILD_ROOT
420
421 %post   -p /sbin/ldconfig
422 %postun -p /sbin/ldconfig
423
424 %post   core -p /sbin/ldconfig
425 %postun core -p /sbin/ldconfig
426
427 %post   viz -p /sbin/ldconfig
428 %postun viz -p /sbin/ldconfig
429
430 %post   -n java-opencv -p /sbin/ldconfig
431 %postun -n java-opencv -p /sbin/ldconfig
432
433 %files
434 %defattr(644,root,root,755)
435 %attr(755,root,root) %{_bindir}/opencv_annotation
436 %attr(755,root,root) %{_bindir}/opencv_createsamples
437 %attr(755,root,root) %{_bindir}/opencv_interactive-calibration
438 %attr(755,root,root) %{_bindir}/opencv_traincascade
439 %attr(755,root,root) %{_bindir}/opencv_version
440 %attr(755,root,root) %{_bindir}/opencv_visualisation
441 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
442 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
443 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
444 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
445 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
446 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
447 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
448 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
449 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
450 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
451 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
452 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
453 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
454 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
455 # contrib modules
456 %attr(755,root,root) %{_bindir}/opencv_waldboost_detector
457 %attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
458 %attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
459 %attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
460 %attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
461 %attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
462 %attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
463 %attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
464 %attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
465 %attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
466 %attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
467 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
468 %attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
469 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
470 %attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
471 %attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
472 %attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
473 %attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
474 %attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
475 %attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
476 %attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
477 %attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
478 %attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
479 %attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
480 %attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
481 %attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
482 %attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
483 %attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
484 %attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
485 %attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
486 %attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
487 %attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
488 %attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
489 %attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
490 %attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
491 %attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
492 %attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
493 %attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
494 %attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
495 %attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
496 %attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
497 %attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
498 %attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
499 %attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
500 %attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
501 %attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
502 %attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
503 %attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
504 %attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
505 %attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
506 %attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
507 %attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
508 %attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
509 %attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
510 %attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
511 %attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
512 %attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
513 %attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
514 %attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
515 %attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
516 %attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
517 %attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
518 %attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
519
520 %dir %{_datadir}/OpenCV
521 %{_datadir}/OpenCV/haarcascades
522 %{_datadir}/OpenCV/lbpcascades
523
524 %files core
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
527 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
528 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
529 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
530 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
531 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
532 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
533 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
534 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
535 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
536 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
537 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
538 %attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
539 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
540 %attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
541 %attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
542 %attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
543 %attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
544
545 %if %{with vtk}
546 %files viz
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
549 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
550 %endif
551
552 %files devel
553 %defattr(644,root,root,755)
554 # core
555 %attr(755,root,root) %{_libdir}/libopencv_core.so
556 %attr(755,root,root) %{_libdir}/libopencv_flann.so
557 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so
558 %attr(755,root,root) %{_libdir}/libopencv_ml.so
559 %attr(755,root,root) %{_libdir}/libopencv_photo.so
560 %attr(755,root,root) %{_libdir}/libopencv_video.so
561 # GUI/extensions (base package)
562 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so
563 %attr(755,root,root) %{_libdir}/libopencv_features2d.so
564 %attr(755,root,root) %{_libdir}/libopencv_highgui.so
565 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so
566 %attr(755,root,root) %{_libdir}/libopencv_stitching.so
567 %attr(755,root,root) %{_libdir}/libopencv_superres.so
568 %attr(755,root,root) %{_libdir}/libopencv_videostab.so
569 %attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so
570 %attr(755,root,root) %{_libdir}/libopencv_shape.so
571 %attr(755,root,root) %{_libdir}/libopencv_videoio.so
572 # contrib
573 %attr(755,root,root) %{_libdir}/libopencv_aruco.so
574 %attr(755,root,root) %{_libdir}/libopencv_bgsegm.so
575 %attr(755,root,root) %{_libdir}/libopencv_bioinspired.so
576 %attr(755,root,root) %{_libdir}/libopencv_ccalib.so
577 %attr(755,root,root) %{_libdir}/libopencv_datasets.so
578 %attr(755,root,root) %{_libdir}/libopencv_dnn.so
579 %attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so
580 %attr(755,root,root) %{_libdir}/libopencv_dpm.so
581 %attr(755,root,root) %{_libdir}/libopencv_face.so
582 %attr(755,root,root) %{_libdir}/libopencv_freetype.so
583 %attr(755,root,root) %{_libdir}/libopencv_fuzzy.so
584 %attr(755,root,root) %{_libdir}/libopencv_hdf.so
585 %attr(755,root,root) %{_libdir}/libopencv_hfs.so
586 %attr(755,root,root) %{_libdir}/libopencv_img_hash.so
587 %attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so
588 %attr(755,root,root) %{_libdir}/libopencv_optflow.so
589 %attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so
590 %attr(755,root,root) %{_libdir}/libopencv_plot.so
591 %attr(755,root,root) %{_libdir}/libopencv_reg.so
592 %attr(755,root,root) %{_libdir}/libopencv_rgbd.so
593 %attr(755,root,root) %{_libdir}/libopencv_saliency.so
594 %attr(755,root,root) %{_libdir}/libopencv_sfm.so
595 %attr(755,root,root) %{_libdir}/libopencv_stereo.so
596 %attr(755,root,root) %{_libdir}/libopencv_structured_light.so
597 %attr(755,root,root) %{_libdir}/libopencv_surface_matching.so
598 %attr(755,root,root) %{_libdir}/libopencv_text.so
599 %attr(755,root,root) %{_libdir}/libopencv_tracking.so
600 %attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so
601 %attr(755,root,root) %{_libdir}/libopencv_ximgproc.so
602 %attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so
603 %attr(755,root,root) %{_libdir}/libopencv_xphoto.so
604 #%{_libdir}/libopencv_ts.a
605 # viz
606 %if %{with vtk}
607 %attr(755,root,root) %{_libdir}/libopencv_viz.so
608 %endif
609 %{_includedir}/opencv
610 %{_includedir}/opencv2
611 %{_datadir}/OpenCV/OpenCV*.cmake
612 %{_pkgconfigdir}/opencv.pc
613
614 %files doc
615 %defattr(644,root,root,755)
616 # TODO: probably could rebuild them and package via make install
617 %doc doc/*
618
619 %if %{with examples}
620 %files examples
621 %defattr(644,root,root,755)
622 %{_examplesdir}/%{name}-%{version}
623 %endif
624
625 %if %{with java}
626 %files -n java-opencv
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
629 %{_javadir}/opencv-%{jver}.jar
630 %{_javadir}/opencv.jar
631 %endif
632
633 %files -n python-opencv
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{py_sitedir}/cv2.so
636
637 %files -n python3-opencv
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{py3_sitedir}/cv2.cpython-*.so
This page took 0.066001 seconds and 2 git commands to generate.