]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- drop references to unused sysctl call/headers
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
2acd8ac1 2# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 3# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 4# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 5#
0c2d6b7d 6# Conditional build:
a55ba198
JB
7# - general options:
8%bcond_with tbb # Threading Building Blocks support (everywhere)
9%bcond_with sse # use SSE instructions
10%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
11%bcond_with sse3 # use SSE3 instructions
12%bcond_with ssse3 # use SSSE3 instructions
13%bcond_with sse41 # use SSE4.1 instructions
14%bcond_with sse42 # use SSE4.2 instructions
15%bcond_with avx # use AVX instructions
8d5385eb
JB
16%bcond_without opencl # OpenCL support
17%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
18%bcond_with opencl_amdfft # AMD OpenCL FFT routines
19%bcond_without opengl # OpenGL support
cf32945e 20%bcond_without gomp # OpenMP support (available when not using tbb)
200823d5 21%bcond_without examples # Install examples
b07433c6
JB
22# - bindings
23%bcond_without java # Java binding
a55ba198 24# - highgui options:
b3920a9d 25%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
26%bcond_without gstreamer # GStreamer support in highgui
27%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 28%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 29%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 30%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 31%bcond_without v4l # Video4Linux in highgui
a55ba198 32%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 33%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
34# - other modules
35%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 36
1c9fe580
JB
37%ifarch pentium3 pentium4 %{x8664}
38%define with_sse 1
39%endif
40%ifarch pentium4 %{x8664}
41%define with_sse2 1
42%endif
901927d3 43Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 44Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 45Name: opencv
158e0ccc
JB
46Version: 2.4.10.1
47Release: 1
901927d3 48Epoch: 1
d5e56e66
JB
49%if %{with unicap} || %{with xine}
50License: GPL (enforced by used libraries), BSD (opencv itself)
51%else
901927d3 52License: BSD
d5e56e66 53%endif
901927d3 54Group: Libraries
200823d5 55Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
158e0ccc 56# Source0-md5: f84af999f45edc829bfda60a13fedbaa
452b38e1 57Patch0: %{name}-cflags.patch
158e0ccc 58Patch1: %{name}-x86.patch
452b38e1 59Patch2: %{name}-unicap-c++.patch
60Patch3: %{name}-c.patch
61Patch4: %{name}-gcc.patch
809ce413 62Patch5: %{name}-ximea.patch
6994c4f7 63Patch6: %{name}-ocl-fft.patch
a4737151 64Patch7: java-ant-sourcelevel.patch
da5d1e09 65Patch8: %{name}-shared.patch
f9e8f4ea 66Patch9: no-sysctl.patch
200823d5 67URL: http://www.opencv.org/
d5e56e66 68%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 69%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 70BuildRequires: OpenEXR-devel
5df3cf1b 71%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 72%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 73# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 74%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 75%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 76%{?with_java:BuildRequires: ant}
ef4af528
JB
77%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
78%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 79BuildRequires: cmake >= 2.8
0c2d6b7d 80BuildRequires: doxygen
809ce413 81BuildRequires: eigen3 >= 3
b3920a9d 82%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
da5d1e09 83%{?with_gomp:BuildRequires: gcc-c++ >= 6:4.2}
0c2d6b7d 84%if %{with gstreamer}
158e0ccc
JB
85BuildRequires: gstreamer-devel >= 1.0
86BuildRequires: gstreamer-plugins-base-devel >= 1.0
0c2d6b7d 87%endif
901927d3 88BuildRequires: jasper-devel
b07433c6 89%{?with_java:BuildRequires: jdk}
158e0ccc 90BuildRequires: libdc1394-devel >= 2
da5d1e09 91%{?with_gomp:BuildRequires: libgomp-devel}
901927d3
AM
92BuildRequires: libjpeg-devel
93BuildRequires: libpng-devel
94BuildRequires: libraw1394-devel
0c2d6b7d 95BuildRequires: libstdc++-devel
901927d3 96BuildRequires: libtiff-devel
148338c5 97BuildRequires: libtool
d5e56e66
JB
98%if %{with unicap}
99BuildRequires: libucil-devel
100BuildRequires: libunicap-devel
101%endif
0c2d6b7d 102BuildRequires: libv4l-devel
af6d2888 103BuildRequires: pkgconfig
158e0ccc
JB
104BuildRequires: python >= 2.0
105BuildRequires: python-devel >= 2.0
0c2d6b7d 106BuildRequires: python-numpy-devel
901927d3 107BuildRequires: rpm-pythonprov
8d499a62 108BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 109BuildRequires: sed >= 4.0
158e0ccc 110BuildRequires: sphinx-pdg
996927aa 111BuildRequires: swig-python
f8e040cc 112%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
113%if %{with vtk}
114BuildRequires: vtk-devel >= 5.8.0
fba97d16 115BuildRequires: vtk-java >= 5.8.0
ae3d975d
AM
116BuildRequires: vtk-tcl >= 5.8.0
117%endif
901927d3 118%{?with_xine:BuildRequires: xine-lib-devel}
158e0ccc 119BuildRequires: xorg-lib-libX11-devel
452b38e1 120BuildRequires: zlib-devel
4afb606b 121%if %{with qt}
4afb606b
JB
122BuildRequires: QtCore-devel >= 4
123BuildRequires: QtGui-devel >= 4
5df3cf1b 124%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
125BuildRequires: qt4-qmake >= 4
126%else
127BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 128%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 129%endif
da5d1e09 130Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
131BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
132
158e0ccc 133%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
933de752 134
901927d3
AM
135%description
136OpenCV (Open Source Computer Vision) is a library of programming
137functions mainly aimed at real time computer vision.
138
0c2d6b7d
JB
139Example applications of the OpenCV library are:
140- Human-Computer Interaction (HCI)
141- Object Identification, Segmentation and Recognition
142- Face Recognition
143- Gesture Recognition
144- Motion Tracking
145- Ego Motion, Motion Understanding
146- Structure From Motion (SFM)
147- Stereo and Multi-Camera Calibration and Depth Computation
148- Mobile Robotics.
149
150%description -l pl.UTF-8
151OpenCV (Open Source Computer Vision) to biblioteka funkcji
152przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
153
154Przykładowe zastosowania biblioteki OpenCV to
155- interakcje człowiek-komputer (HCI)
156- identyfikacja, segmentacja i rozpoznawanie obiektów
157- rozpoznawanie twarzy
158- rozpoznawanie gestów
159- śledzenie ruchu
160- rozumienie ruchu
161- SFM (Structure From Motion)
162- kalibracja dwu- i wielokamerowa, obliczanie głębi
163- robotyka ruchu.
901927d3 164
933de752
ER
165%package core
166Summary: OpenCV core libraries
da5d1e09 167Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 168Group: Libraries
da5d1e09 169Conflicts: opencv < 2.4.6.2-1
933de752
ER
170
171%description core
172This package contains the OpenCV C/C++ core libraries.
173
da5d1e09
JB
174%description core -l pl.UTF-8
175Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
176
cf32945e
JB
177%package viz
178Summary: OpenCV viz library (VTK support)
179Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
180Group: Libraries
181Requires: %{name} = %{epoch}:%{version}-%{release}
182
183%description viz
184OpenCV viz library (VTK support).
185
186%description viz -l pl.UTF-8
187Biblioteka OpenCV viz (obsługa VTK).
188
901927d3 189%package devel
0c2d6b7d
JB
190Summary: Header files for OpenCV library
191Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
192Group: Development/Libraries
193Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
194%if %{with vtk}
195Requires: %{name}-viz = %{epoch}:%{version}-%{release}
196%endif
0c2d6b7d 197Obsoletes: opencv-static
901927d3
AM
198
199%description devel
0c2d6b7d 200Header files for OpenCV library.
901927d3 201
0c2d6b7d
JB
202%description devel -l pl.UTF-8
203Pliki nagłówkowe biblioteki OpenCV.
901927d3 204
9141b1e2
ER
205%package doc
206Summary: Manual for OpenCV
207Summary(fr.UTF-8): Documentation pour OpenCV
208Summary(it.UTF-8): Documentazione di OpenCV
209Summary(pl.UTF-8): Podręcznik dla OpenCV
210Group: Documentation
211# noarch subpackages only when building with rpm5
212%if "%{_rpmversion}" >= "5"
213BuildArch: noarch
214%endif
215
216%description doc
217Documentation for OpenCV.
218
219%description doc -l fr.UTF-8
220Documentation pour OpenCV.
221
222%description doc -l it.UTF-8
223Documentazione di OpenCV.
224
225%description doc -l pl.UTF-8
226Dokumentacja do OpenCV.
227
200823d5
ER
228%package examples
229Summary: OpenCV code examples
230Group: Documentation
231%if "%{_rpmversion}" >= "5"
232BuildArch: noarch
233%endif
234
235%description examples
236OpenCV code examples.
237
b07433c6
JB
238%package -n java-opencv
239Summary: OpenCV Java bindings
240Summary(pl.UTF-8): Wiązania Javy do OpenCV
241Group: Libraries/Java
242Requires: %{name} = %{epoch}:%{version}-%{release}
243Requires: jre
244
245%description -n java-opencv
246OpenCV Java bindings.
247
248%description -n java-opencv -l pl.UTF-8
249Wiązania Javy do OpenCV.
250
901927d3
AM
251%package -n python-opencv
252Summary: OpenCV Python bindings
0c2d6b7d
JB
253Summary(pl.UTF-8): Wiązania Pythona do OpenCV
254Group: Libraries/Python
cd1f0136 255Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 256Requires: python-libs
901927d3
AM
257
258%description -n python-opencv
259OpenCV Python bindings.
260
0c2d6b7d
JB
261%description -n python-opencv -l pl.UTF-8
262Wiązania Pythona do OpenCV.
263
901927d3 264%prep
25269a76 265%setup -q
54551f29 266
da67222a 267%undos CMakeLists.txt
1376dffe 268%undos modules/gpu/CMakeLists.txt
54551f29 269
1376dffe 270%patch0 -p1
271%patch1 -p1
29d82ddf 272%patch2 -p1
f8e040cc 273%patch3 -p1
75b912e9 274%patch4 -p1
809ce413 275%patch5 -p1
6994c4f7 276%patch6 -p1
a4737151 277%patch7 -p1
da5d1e09 278%patch8 -p1
f9e8f4ea 279%patch9 -p1
148338c5 280
901927d3 281%build
95daeb66
AM
282install -d build
283cd build
ea26b025
ER
284
285# handle cmake & ccache
286# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
287if [[ "%{__cc}" = *ccache* ]]; then
288 cc="%{__cc}"
289 cxx="%{__cxx}"
290 ccache="
291 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
292 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
293 "
294fi
295
0c2d6b7d 296%cmake .. \
ea26b025 297 $ccache \
da5d1e09 298 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
299 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
300 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
301 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
302 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
303 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
304 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 305 -DBUILD_NEW_PYTHON_SUPPORT=ON \
200823d5
ER
306%if %{with examples}
307 -DINSTALL_C_EXAMPLES=ON \
308 -DINSTALL_PYTHON_EXAMPLES=ON \
309%endif
b3920a9d 310 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 311 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 312 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
313 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
314 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 315 %{?with_opengl:-DWITH_OPENGL=ON} \
da5d1e09 316 %{?with_gomp:-DWITH_OPENMP=ON} \
1c9fe580 317 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 318 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 319 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 320 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 321 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 322 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 323 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 324 %{?with_ximea:-DWITH_XIMEA=ON} \
d5e56e66 325 %{?with_xine:-DWITH_XINE=ON}
54551f29 326
8b9f61f7 327%{__make}
901927d3
AM
328
329%install
330rm -rf $RPM_BUILD_ROOT
95daeb66 331%{__make} -C build install \
901927d3
AM
332 DESTDIR=$RPM_BUILD_ROOT
333
9141b1e2
ER
334# see -doc package
335%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
200823d5
ER
336%if %{with examples}
337install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
338mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
339%endif
9141b1e2 340
4bd2eae7 341install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
a4737151 342cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
4bd2eae7 343
7545129b
JB
344# disable completeness check incompatible with split packaging
345%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
346
8d499a62
JB
347%py_comp $RPM_BUILD_ROOT%{py_sitedir}
348%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
349%py_postclean
350
b07433c6
JB
351%if %{with java}
352# move to proper directories, create symlink
353install -d $RPM_BUILD_ROOT%{_javadir}
354%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
c3075463
AM
355sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
356 $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
b07433c6
JB
357%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
358rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
359ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
360%endif
361
901927d3
AM
362%clean
363rm -rf $RPM_BUILD_ROOT
364
365%post -p /sbin/ldconfig
366%postun -p /sbin/ldconfig
367
933de752
ER
368%post core -p /sbin/ldconfig
369%postun core -p /sbin/ldconfig
370
485d5dca
JB
371%post viz -p /sbin/ldconfig
372%postun viz -p /sbin/ldconfig
373
b07433c6
JB
374%post -n java-opencv -p /sbin/ldconfig
375%postun -n java-opencv -p /sbin/ldconfig
376
901927d3
AM
377%files
378%defattr(644,root,root,755)
933de752
ER
379%attr(755,root,root) %{_bindir}/opencv_createsamples
380%attr(755,root,root) %{_bindir}/opencv_haartraining
381%attr(755,root,root) %{_bindir}/opencv_performance
382%attr(755,root,root) %{_bindir}/opencv_traincascade
158e0ccc 383%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
da5d1e09 384%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.2.4
158e0ccc 385%attr(755,root,root) %{_libdir}/libopencv_contrib.so.*.*.*
da5d1e09 386%attr(755,root,root) %ghost %{_libdir}/libopencv_contrib.so.2.4
158e0ccc 387%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
da5d1e09 388%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.2.4
158e0ccc 389%attr(755,root,root) %{_libdir}/libopencv_gpu.so.*.*.*
cf32945e 390%attr(755,root,root) %ghost %{_libdir}/libopencv_gpu.so.2.4
158e0ccc 391%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
da5d1e09 392%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.2.4
158e0ccc 393%attr(755,root,root) %{_libdir}/libopencv_legacy.so.*.*.*
da5d1e09 394%attr(755,root,root) %ghost %{_libdir}/libopencv_legacy.so.2.4
158e0ccc 395%attr(755,root,root) %{_libdir}/libopencv_nonfree.so.*.*.*
cf32945e 396%attr(755,root,root) %ghost %{_libdir}/libopencv_nonfree.so.2.4
158e0ccc 397%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
da5d1e09
JB
398%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.2.4
399%if %{with opencl}
158e0ccc 400%attr(755,root,root) %{_libdir}/libopencv_ocl.so.*.*.*
da5d1e09
JB
401%attr(755,root,root) %ghost %{_libdir}/libopencv_ocl.so.2.4
402%endif
158e0ccc 403%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
da5d1e09 404%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.2.4
158e0ccc 405%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
da5d1e09 406%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.2.4
158e0ccc 407%attr(755,root,root) %{_libdir}/libopencv_ts.so.*.*.*
cf32945e 408%attr(755,root,root) %ghost %{_libdir}/libopencv_ts.so.2.4
158e0ccc 409%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
da5d1e09 410%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.2.4
452b38e1 411%dir %{_datadir}/OpenCV
452b38e1 412%{_datadir}/OpenCV/haarcascades
413%{_datadir}/OpenCV/lbpcascades
901927d3 414
933de752
ER
415%files core
416%defattr(644,root,root,755)
158e0ccc 417%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
cf32945e 418%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.2.4
158e0ccc 419%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
cf32945e 420%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.2.4
158e0ccc 421%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
cf32945e 422%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.2.4
158e0ccc 423%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
cf32945e 424%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.2.4
158e0ccc 425%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
cf32945e 426%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.2.4
158e0ccc 427%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
cf32945e
JB
428%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.2.4
429
430%if %{with vtk}
431%files viz
432%defattr(644,root,root,755)
158e0ccc 433%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
cf32945e
JB
434%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.2.4
435%endif
933de752 436
901927d3
AM
437%files devel
438%defattr(644,root,root,755)
cf32945e
JB
439# core
440%attr(755,root,root) %{_libdir}/libopencv_core.so
441%attr(755,root,root) %{_libdir}/libopencv_flann.so
442%attr(755,root,root) %{_libdir}/libopencv_imgproc.so
443%attr(755,root,root) %{_libdir}/libopencv_ml.so
444%attr(755,root,root) %{_libdir}/libopencv_photo.so
445%attr(755,root,root) %{_libdir}/libopencv_video.so
446# GUI/extensions (base package)
447%attr(755,root,root) %{_libdir}/libopencv_calib3d.so
448%attr(755,root,root) %{_libdir}/libopencv_contrib.so
449%attr(755,root,root) %{_libdir}/libopencv_features2d.so
450%attr(755,root,root) %{_libdir}/libopencv_gpu.so
451%attr(755,root,root) %{_libdir}/libopencv_highgui.so
452%attr(755,root,root) %{_libdir}/libopencv_legacy.so
453%attr(755,root,root) %{_libdir}/libopencv_nonfree.so
454%attr(755,root,root) %{_libdir}/libopencv_objdetect.so
455%if %{with opencl}
456%attr(755,root,root) %{_libdir}/libopencv_ocl.so
457%endif
458%attr(755,root,root) %{_libdir}/libopencv_stitching.so
459%attr(755,root,root) %{_libdir}/libopencv_superres.so
460%attr(755,root,root) %{_libdir}/libopencv_ts.so
461%attr(755,root,root) %{_libdir}/libopencv_videostab.so
462# viz
463%if %{with vtk}
464%attr(755,root,root) %{_libdir}/libopencv_viz.so
0e077f8d 465%endif
901927d3 466%{_includedir}/opencv
509c07dc 467%{_includedir}/opencv2
da5d1e09 468%{_datadir}/OpenCV/OpenCV*.cmake
0c2d6b7d 469%{_pkgconfigdir}/opencv.pc
901927d3 470
9141b1e2
ER
471%files doc
472%defattr(644,root,root,755)
473# TODO: probably could rebuild them and package via make install
474%doc doc/*
475
200823d5
ER
476%if %{with examples}
477%files examples
478%defattr(644,root,root,755)
479%{_examplesdir}/%{name}-%{version}
480%endif
481
b07433c6
JB
482%if %{with java}
483%files -n java-opencv
484%defattr(644,root,root,755)
835e0cdd
ER
485%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
486%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
487%{_javadir}/opencv.jar
488%endif
489
901927d3
AM
490%files -n python-opencv
491%defattr(644,root,root,755)
452b38e1 492%attr(755,root,root) %{py_sitedir}/cv2.so
8d499a62 493%{py_sitedir}/cv.py[co]
This page took 0.157804 seconds and 4 git commands to generate.